Advertisement:

Author Topic: Main Logo Doesn't Appear  (Read 510 times)

Offline tonywells82

  • Semi-Newbie
  • *
  • Posts: 54
Main Logo Doesn't Appear
« on: October 09, 2020, 02:05:24 PM »
Hope this is the right place for this.. seeing as to how graphics are involved?

Anyway, since I had to move my forum over to a new ISP (hostgator.com) I've been having lots of problems with images and stuff. My site is;
http://www.tseatc.com/smf/index.php

Problem 1: My main page logo doesn't appear at all. Even though it seems to be in the correct place.

THEME URLs and CONFIGURATION

Theme%u2019s Name: SMF Default Theme %u2013 Curve
Theme%u2019s URL: http://www.tseatc.com/smf/Themes/default
Theme%u2019s Images URL: http://www.tseatc.com/smf/Themes/default/images
Theme%u2019s Directory: /home2/******/public_html/smf/Themes/default

THEME OPTIONS and PREFERENCES

Logo Image URL: http://www.tseatc.com/tseatc_forumlogo2.jpg
Try: /home2/******/public_html/Themes/default/images/tseatc_forumlogo2.jpg

One thing that confuses me about hostgator is their file structure. It's /home2/******/OTHER FOLDERS and there's no such as how it was on my previous ISP as just ******/OTHER FOLDERS

It's like this: /home2/******/etc/tseatc/smf/OTHER FOLDER
And I can see: /home2/******/public_html/smf/OTHER FOLDERS

So, in fact I can see TWO different SMF folders there. Which one is supposed to be the correct one?

I did run repair_setting.php and that made a few corrections but I still can't see my main page logo: tseatc_forumlogo2.jpg

Thank you

Gary: Edited to remove site username from paths.
« Last Edit: October 09, 2020, 04:14:07 PM by Gary »

Offline Gary

  • Sorceress's Knight
  • Lead Customizer
  • SMF Super Hero
  • *
  • Posts: 18,352
  • Gender: Male
  • So this is the luck of the draw...
    • Gazmanafc on Facebook
    • garygadsdon on LinkedIn
    • @Gazmanafc on Twitter
    • The Bongo Comics Fan Forum
Re: Main Logo Doesn't Appear
« Reply #1 on: October 09, 2020, 04:12:13 PM »
In the Current Theme section of the admin center, you have to use full URLs to specify a logo image not a path.

The logo you linked to is coming in 404. So, make sure you've correctly uploaded it to where to you want it to be.


When uploading to make something appear online, it should be in home2/[username]/public_html/[others] folders.
Gary M. Gadsdon
Do NOT PM me unless I say so

War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Offline tonywells82

  • Semi-Newbie
  • *
  • Posts: 54
Re: Main Logo Doesn't Appear
« Reply #2 on: October 09, 2020, 09:45:48 PM »
Thank you. I'll make those changes and let you know how it goes.
TW

In the Current Theme section of the admin center, you have to use full URLs to specify a logo image not a path.

The logo you linked to is coming in 404. So, make sure you've correctly uploaded it to where to you want it to be.


When uploading to make something appear online, it should be in home2/[username]/public_html/[others] folders.

Offline tonywells82

  • Semi-Newbie
  • *
  • Posts: 54
Re: Main Logo Doesn't Appear
« Reply #3 on: October 16, 2020, 05:09:53 PM »
Well, I still don't get it. I put my SMF main page logo here: /home2/tseatc87/public_html/Themes/default/images/tseatc_forumlogo2.jpg

But it still doesn't appear. I'm so very confused now. That doesn't appear and none of the pictures that used to be posted there on my forum appear at all. So frustrating.

Thanks!

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 59,513
  • Gender: Male
    • Kindred-999 on GitHub
Re: Main Logo Doesn't Appear
« Reply #4 on: October 16, 2020, 05:22:57 PM »
you need a URL in that field.... not a directory path

e.g. something starting with http://www.tseatc.com/smf/Themes/default/default/images/tseatc_forumlogo2.jpg  -- except that gives me a 404 -- which means that the file is NOT in that actual directory
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline tonywells82

  • Semi-Newbie
  • *
  • Posts: 54
Re: Main Logo Doesn't Appear
« Reply #5 on: October 16, 2020, 07:59:52 PM »
Thanks for that.

Here's the issue. I'm using HostGator now so when I log in to my Cpanel File Manager or Filzilla FTP.. this is all I can see there: /home2/tseatc87/public_html/smf/ OTHER DIRECTORIES & FILES...

On my previous ISP there was no such thing as /home2/tseatc87/    so this is what's confusing me.

The guy on HostGator was telling me that I should upload everything to: /home2/tseatc87/public_html/Themes/default/images/theme

And I did but I still don't see the logo appearing. Is it possible that SMF has a problem with HostGator whereby the images won't appear?

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,437
  • We were all equal in the end.
Re: Main Logo Doesn't Appear
« Reply #6 on: October 16, 2020, 09:06:12 PM »
The guy on HostGator was telling me that I should upload everything to: /home2/tseatc87/public_html/Themes/default/images/theme

'Everything' being what?  Your forum root is in /public_html/smf/, directory structure is same as any other install.  Path to custom logo is specified in Admin -> Current Theme -> Theme Settings -> Logo image URL

Quote
Is it possible that SMF has a problem with HostGator whereby the images won't appear?

Only problem with Hostgator is they're a crappy host with crappy support. :P

“There is nothing more frightful than ignorance in action.”  Goethe

Offline tonywells82

  • Semi-Newbie
  • *
  • Posts: 54
Re: Main Logo Doesn't Appear
« Reply #7 on: October 19, 2020, 01:31:19 AM »
OK. Thanks for that. The main logo is appearing now. Thanks to you.

My question now is: When people post on a SMF forum.. what directory does all their posted JPG pictures go into? Once I know this I'll be able to upload all those pictures from my laptop into that folder so they can appear again.

For some crazy reason I'm thinking it goes into; smf/themes/default/images/themes/post
but I could be wrong.

Thanks in advance.
TW

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 59,513
  • Gender: Male
    • Kindred-999 on GitHub
Re: Main Logo Doesn't Appear
« Reply #8 on: October 19, 2020, 02:09:50 AM »
You are wrong.

smf/attachments

Ir whatever you have configured in your attachments settings
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline tonywells82

  • Semi-Newbie
  • *
  • Posts: 54
Re: Main Logo Doesn't Appear
« Reply #9 on: October 19, 2020, 01:42:26 PM »
Thank you. Yea.. I'm wrong with lots of things. Especially when it comes to this SMF stuff. LOL

You are wrong.

smf/attachments

Ir whatever you have configured in your attachments settings