Advertisement:

Author Topic: Please help....one site keeps giving session verification failed notices.  (Read 320 times)

Online shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,080
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
I don't understand why....but one of my sites lately keeps giving me the

Session verification failed. Please try logging out and back in again, and then try again.

and the only way to fix it is to run repair_settings.php and set the theme back to default....then I can log in and switch the theme back and it works again for a day or two then I get the error again....

it's just this one site....it's just a rework of the default/curve theme

I use the stay logged in forever, but if I go to log into admin I get
Session verification failed. Please try logging out and back in again, and then try again.
if I log out and try to log back in I get
Session verification failed. Please try logging out and back in again, and then try again.

so then I have to do the repair settings, set theme back to default, then I can log in as normal and admin and change it back to custom theme and everything works fine again...I can even log out and back in, no problem....just seems that every day or two this stupid error pops up.

https://4rearth.info/

I've even tried resetting the cookie, emptying out cache, and my browsers cache....but the only thing that fixes it is resetting to default theme and then I can log in and change themes back and yadda yadda

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,819
  • We were all equal in the end.
Tried registering, your reg form is a mess.  Don't recognize theme, is it customized from scratch?
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Online shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,080
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
more or less, tore apart the default theme

ug....ok don't know what's up with that....tried to register a test account and am getting
Database Error
Please try again. If you come back to this error screen, report the error to an administrator.

ug...now what....

Online shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,080
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
arg and now i'm back to
Session verification failed. Please try logging out and back in again, and then try again.

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,819
  • We were all equal in the end.
Do you have the session check in the login?
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Online shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,080
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
well that's a new one....
Database Error: Field 'inactive_mail' doesn't have a default value
fixed that so hopefully registration works now

no can't find anything about session check however did find a bunch of stuff referring to httpbl which I had uninstalled but apparently it missed some things so...maybe that is the issue....now that that's cleaned up?

a bunch of undefined errors

after clearing out some stuff found these 2 odd ones

https://4rearth.info/index.php?action=admin;area=viewmembers;a56b89c68=ebfa3ab2191f33a08b2b4d320a823649
2: in_array() expects parameter 2 to be array, null
File: /Sources/Profile-Modify.php
Line: 2478


https://4rearth.info/index.php?scheduled=task;ts=1611532860
2: unlink(cache/images/.): Is a directory
File: Sources/ScheduledTasks.php
Line: 508

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,819
  • We were all equal in the end.
Those all look like mod errors.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Online shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,080
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
still haven't figured out the last two errors but eh, leave that for another day

going to mark this as solved *fingers crossed*

I think it was due to the left over bits from httpBL mod that didn't get removed on uninstall...my own fault, I forgot to remove it from other themes than default....

so far it hasn't happened again so it's a good sign

*note to self see about fixing images and cleaning up the registration page  :P