• Welcome to Simple Machines Community Forum. Please login or sign up.
September 16, 2021, 11:24:51 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


[SMF Converter] Yabb - 2.1

Started by JayBachatero, October 24, 2006, 12:07:33 PM

Previous topic - Next topic

enna

thank you very much.

I did it and this error came:
Error

SQL query:

UPDATE smf_topics SET ID_LAST_MSG = ID_LAST_MSG +1000000;

MySQL said: Documentation
#1146 - Table 'NAME_imga1.smf_topics' doesn't exist

(i just replaced my account with "name")

ThorstenE

sorry, my mistake.. you used a different table prefix and the table is named camileve_topics instead of smf_topics.

try it with:
UPDATE camileve_topics SET ID_LAST_MSG = ID_LAST_MSG + 1000000;
UPDATE camileve_topics SET ID_LAST_MSG = ID_FIRST_MSG + 1000000;

enna

thank you very much. I am workin on it. Will let you know. Greatly appreciate the help!

temestos

Hi,

I'm thinking of changing from YaBB to SMF. I tested to convert from the YaBB 2.1 -> SMF. All works fine but atleast things listed below are one problem. Anyone have suggestions how to fix em' ?

- Attachments do not convert. SMF attachments directory is empty, mysql attachments don't have any data. No errors in the conversion program.

- In private messages, I see 300 posts even though there should be only 58. Those posts seem to be related to topics I have posted something and not my actual pm's.

Thanks.

SleePy

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

temestos

Quote from: SleePy on May 28, 2009, 06:11:49 PM
Give this file a try.

No change.

Also one problem is that Scandinavian characters like Ä and Ö are not showing at all. They have been replaced by "?" character.

I will try to convert my yabb to clean 2.2 version without any modifications. And then convert to SMF. Hopefully it will solve these problems.

ThorstenE

Quote from: temestos on May 30, 2009, 01:59:59 PM
Also one problem is that Scandinavian characters like Ä and Ö are not showing at all. They have been replaced by "?" character.
This is UTF-8 related..
see  UTF-8 Readme

lgisl

April 05, 2010, 02:11:28 PM #467 Last Edit: April 05, 2010, 02:20:51 PM by lgisl
Hi,

I found problems to import the attachments of yabb, we solve changing this SQL in line 1220 of yabb21_to_smf.php, it has an error with real_id and temp fields, now it works:

      $result = convert_query("
            SELECT m.ID_MSG, con.real_id as temp_filename
            FROM {$to_prefix}messages AS m
               INNER JOIN {$to_prefix}convert AS con ON (con.temp = CONCAT(m.posterTime, ':', m.posterName))
            WHERE con.type = 'msg_attach'
            LIMIT $_GET[substep], $block_size");

Thanks

Regards
Lucas

lgisl

April 05, 2010, 02:16:01 PM #468 Last Edit: April 05, 2010, 02:20:06 PM by lgisl
Hi,

Another problem with yabb and iso8859-1 to utf8.

When we need to import the yabb to smf our forum files are in iso8859-1, the solution is convert all the files of yabb to utf8, we use this .sh:

--------------
#!/bin/bash

ICONVBIN='/usr/bin/iconv' # path to iconv binary

if [ $# -lt 3 ]
then
    echo "$0 dir from_charset to_charset"
    exit
fi

for f in $1/*
do
    if test -f $f
    then
        echo -e "\nConverting $f"
        /bin/mv $f $f.old
        $ICONVBIN -f $2 -t $3 $f.old > $f
    else
        echo -e "\nSkipping $f - not a regular file";
    fi
done
--------------

Later we execute this .sh in the directories Messages, Boards and Members of our yabb forum to convert all the files to utf8.

The sintaxis to run the .sh are:

file.sh directory_to_convert from_characterset to_characterset

example for directory messages:
/path_of_sh/name_of_sh.sh /path_of_your_yabb_directory/Messages iso-8859-1 utf8


With this files in utf8 and the solved attachments import the conversion works fine.

Thanks for the conversion script ;)

Regards
Lucas


the506

Just converted from YaBB 2.1 over to SMF today. I can tell that all of the posts were converted (topic and post totals match), but some of them are not showing up. In many threads, only the first page of 25 posts are viewable. There are quite a few 20+ page threads on this forum so it's a major problem.

What could be the cause of this problem and is there any way to fix it?

Thanks.

phunkybeam

September 11, 2011, 04:54:43 PM #470 Last Edit: September 11, 2011, 06:22:10 PM by phunkybeam
When i convert my board than i missing the Attachment on the Posts ... !?
Have you a Solutions vor this problem !?

Bazie

I am coverting Yabb 2.1 to SMF. First I tried it with the newest version 2.0.8 and later with 2.0. Still I get this error:
QuoteConverting membergroups...
Unsuccessful!
This query:

    REPLACE INTO `XXXXX_smf`.smf_XXXXXmembergroups
    (ID_GROUP, groupName, onlineColor, minPosts, stars)
    VALUES (2, SUBSTRING('Global Moderator', 1, 80), SUBSTRING('blue', 1, 20), '-1', SUBSTRING('5#stargmod.gif', 1, 255)),
    (3, SUBSTRING('YaBB Moderator', 1, 80), SUBSTRING('green', 1, 20), '-1', SUBSTRING('5#starmod.gif', 1, 255)),
    (1, SUBSTRING('Admini', 1, 80), SUBSTRING('red', 1, 20), '-1', SUBSTRING('0#staradmin.gif', 1, 255));

Caused the error:

    Unknown column 'groupName' in 'field list'
Any thoughts how to fix this?

Bazie

Quote from: Bazie on August 16, 2014, 09:32:41 AMAny thoughts how to fix this?
Help, please :)

SMF 1.1 RC3 is mentioned on starting post but I can't install 1.1 because of newer version MySQL :-\

margarett

For SMF2 you should use the converters from the download page:
http://download.simplemachines.org/?converters;software=yabb
Use 2.0.8 as the database schema is the same in all 2.0.x range ;)
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Bazie

Quote from: margarett on August 27, 2014, 01:31:27 PMFor SMF2 you should use the converters from the download page:
http://download.simplemachines.org/?converters;software=yabb
Use 2.0.8 as the database schema is the same in all 2.0.x range ;)
Now I did a fresh install of 2.0.8. Then I used converter from link above. Now I get this error message:
QuoteConverting...
Successful.
Converting membergroups...
Successful.
Converting members...
array(6) { [0]=> array(4) { ["file"]=> string(49) "/home/XXXXXX/public_html/forum/yabb21_to_smf.php" ["line"]=> int(219) ["function"]=> string(10) "alterTable" ["args"]=> array(4) { [0]=> &string(7) "members" [1]=> &array(1) { ["PRIMARY"]=> string(16) "DROP PRIMARY KEY" } [2]=> &string(0) "" [3]=> &array(1) { ["id_member"]=> string(74) "CHANGE COLUMN id_member id_member mediumint(8) unsigned NOT NULL default 0" } } } [1]=> array(2) { ["function"]=> string(12) "convertStep3" ["args"]=> array(0) { } } [2]=> array(4) { ["file"]=> string(43) "/home/XXXXXX/public_html/forum/convert.php" ["line"]=> int(1346) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) { [0]=> &string(12) "convertStep3" } } [3]=> array(4) { ["file"]=> string(43) "/home/XXXXXX/public_html/forum/convert.php" ["line"]=> int(973) ["function"]=> string(17) "run_php_converter" ["args"]=> array(0) { } } [4]=> array(2) { ["function"]=> string(7) "doStep1" ["args"]=> array(0) { } } [5]=> array(4) { ["file"]=> string(43) "/home/XXXXXX/public_html/forum/convert.php" ["line"]=> int(51) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) { [0]=> &string(7) "doStep1" } } }
Warning: Missing argument 1 for smf_db_list_indexes(), called in /home/XXXXXX/public_html/forum/convert.php on line 2864 and defined in /home/XXXXXX/public_html/forum/Sources/DbPackages-mysql.php on line 530

Notice: Undefined variable: table_name in /home/XXXXXX/public_html/forum/Sources/DbPackages-mysql.php on line 534
Incorrect table name ''

Bazie

Quote from: Bazie on August 27, 2014, 01:46:01 PMNow I did a fresh install of 2.0.8. Then I used converter from link above. Now I get this error message:
QuoteConverting...
Successful.
Converting membergroups...
Successful.
Converting members...
array(6) {
  • => array(4) { ["file"]=> string(49) "/home/XXXXXX/public_html/forum/yabb21_to_smf.php" ["line"]=> int(219) ["function"]=> string(10) "alterTable" ["args"]=> array(4) {
  • => &string(7) "members" [1]=> &array(1) { ["PRIMARY"]=> string(16) "DROP PRIMARY KEY" } [2]=> &string(0) "" [3]=> &array(1) { ["id_member"]=> string(74) "CHANGE COLUMN id_member id_member mediumint(8) unsigned NOT NULL default 0" } } } [1]=> array(2) { ["function"]=> string(12) "convertStep3" ["args"]=> array(0) { } } [2]=> array(4) { ["file"]=> string(43) "/home/XXXXXX/public_html/forum/convert.php" ["line"]=> int(1346) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) {
  • => &string(12) "convertStep3" } } [3]=> array(4) { ["file"]=> string(43) "/home/XXXXXX/public_html/forum/convert.php" ["line"]=> int(973) ["function"]=> string(17) "run_php_converter" ["args"]=> array(0) { } } [4]=> array(2) { ["function"]=> string(7) "doStep1" ["args"]=> array(0) { } } [5]=> array(4) { ["file"]=> string(43) "/home/XXXXXX/public_html/forum/convert.php" ["line"]=> int(51) ["function"]=> string(14) "call_user_func" ["args"]=> array(1) {
  • => &string(7) "doStep1" } } }
    Warning: Missing argument 1 for smf_db_list_indexes(), called in /home/XXXXXX/public_html/forum/convert.php on line 2864 and defined in /home/XXXXXX/public_html/forum/Sources/DbPackages-mysql.php on line 530

    Notice: Undefined variable: table_name in /home/XXXXXX/public_html/forum/Sources/DbPackages-mysql.php on line 534
    Incorrect table name ''
Any help on this?


Advertisement: