Advertisement:

Author Topic: need help from a real pro  (Read 1537 times)

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
need help from a real pro
« on: February 10, 2021, 11:33:00 PM »
site is completely BLANK
worked fine for 8? 10? years
made a few updates patched along the way
but as I made hundreds of hand-coded GUI optimizations
and lost my notes - did not want to mess with something broken
I think the last thing I did was just add a captcha a year or 2 ago?
anyway
the forum runs in an iFrame - but the frame is total empty
I also have the direct page and when I try that - is says page can NOT load HTTP error 500)
I am on call with server support
they said many updates to PHP 7.4? and they think my DB is 4?? or my something is 4?
(the tech lady English is not so clear)
they are trying a roll back for me? they asked if i can update the DB
but I can not see ANYTHING at all

VCSY-Chat 'dot' com = and the far tab button for forum
if I run the page

like i said been working GREAT until today
help?

THANKS


Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #1 on: February 10, 2021, 11:45:23 PM »
the friggen web host said they will call me within 48 hours
anyway = if I run the iframe source DIRECT
I get this error message

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

 does that ^^ help?

if it is a PHP issue
what should I do as I can not see ANYTHING at all
thanks!!

Offline shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,265
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: need help from a real pro
« Reply #2 on: February 10, 2021, 11:57:33 PM »
if you didn't do anything to your site, then your host did.....

what version of smf are you using?
unless you are using smf 2.0.18 or smf 2.1
then you can not use php7.4

anything below smf 2.0.16 you have to use php7.2 and under

if smf 1.x I don't think you can use anything over php 5.6 (not completely sure on that one)

log into your hosting account and try lowering your php down depending on the version of smf you are using.

as far as the error of unable to connect tot he database. this may be caused by the server being busy

90% that's the server took a crap
10% if you were messing around with the site, might have accidently messed something up....revert the changes

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 60,203
  • Gender: Male
    • Kindred-999 on GitHub
Re: need help from a real pro
« Reply #3 on: February 11, 2021, 09:07:55 AM »
Also, do note that SMF introduced security protections about iframes a few releases ago....      running the forum in an iframe is NOT recommended (well, actually, iframes, in general, are not recommended any more)
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Project Manager
  • SMF Super Hero
  • *
  • Posts: 19,819
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • My Daily Dose Of Blasphemy
Re: need help from a real pro
« Reply #4 on: February 11, 2021, 09:23:19 AM »
VCSY-Chat 'dot' com = and the far tab button for forum
Following that, I can see the frame and the error
"Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later."
First things first, check that your Settings.php is fine - then check your DB connection, and the DB credentials and compare them to the ones in your Settings.php

like i said been working GREAT until today
Sorry, doubtful. Might have worked, but isn't really healthy. See attached.
A Finnish Project Manager (Support Specialist)
Happily running multiple SMF 2.x installations.
 Fooling around with an i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #5 on: February 11, 2021, 10:13:14 AM »
1. THANKS to ALL
2. Yes - I did NOTHING new - so server farm did something
3. yes- I did see the errors - that was fetching some realtime OTC stock quotes =  not sure why stopped working
(I made this site for friend  years ago - he did not tell me that the Otc called stopped =I will delete that from the HTML
4. I can log onto site using FTP or cPanel = how can I determine my version? the license.txt does not tell me what version
5. I used the iframe just to show the same look and feel as the website - but many people now just log directly into the forum - which then does not run in the iFrame

6. will the wrong PHP error also cause the server connection error? - cn not imagein I am the only user with a connection error due to being busy over 36 hours +/-

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #6 on: February 11, 2021, 10:32:02 AM »
i just found a php manager on my server cPanel
for ALL my domains (2 hosted and 10 aliased) it says ea-php74
and for vcsy (main URL ) not aliased - it says ea-php54
guessing they reset it last (rollback) and they said they would?
but the error still exists

FYI
I just backed up the DB using myphp admin
and DL the Entire forum folder from my server to local HD
what is best what to 'remake?' upload?? all to a test folder on server
ie different folder or what ever
should I run a fresh install of the SMF ( it is an APP from my host)
is yes - can I then use old DB?
wish I had more time to play with all this
other suggestions?
THANKS



Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Project Manager
  • SMF Super Hero
  • *
  • Posts: 19,819
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • My Daily Dose Of Blasphemy
Re: need help from a real pro
« Reply #7 on: February 11, 2021, 11:12:35 AM »
Before panicking and overwriting everything as an attempted fix, it would be sensible to try and find out what is wrong first.

First things first, check that your Settings.php is fine - then check your DB connection, and the DB credentials and compare them to the ones in your Settings.php
A Finnish Project Manager (Support Specialist)
Happily running multiple SMF 2.x installations.
 Fooling around with an i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #8 on: February 11, 2021, 11:23:55 AM »
ok - read the settings php
it said version 2.0
it also listed all the connection settings
but how do I make sure they are still correct on the server?
can not imagine how it changed?
also =
was not going to REMAKE all - was just curious as to how to try in case I had to
convinced my pal that a working forum was more important than to just preserve the custom look and feel


Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Project Manager
  • SMF Super Hero
  • *
  • Posts: 19,819
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • My Daily Dose Of Blasphemy
Re: need help from a real pro
« Reply #9 on: February 11, 2021, 11:38:37 AM »
Your host or your hosting control panel should help you with the DB connection info. The error message shown would imply that everything is most likely as it should be, except for the small fact that SMF is unable to talk to your database. So figuring out why we can't reach the database, is the first step. You can also try to see if your server's error log shows anything that might be relevant.
A Finnish Project Manager (Support Specialist)
Happily running multiple SMF 2.x installations.
 Fooling around with an i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #10 on: February 11, 2021, 12:09:20 PM »
i found the DB and ran the cPanel - check DataBase = all passed
I also reset the PHP to 7.1 for the domain
(not sure how long that takes?)
I am promised a call from tech in 36 hours?

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #11 on: February 11, 2021, 01:14:54 PM »
I just made a new forum using the Server farm app = works great'
shows version 2.0.18 on the bottom
just for fun - how do I use the old database?
I do not care about the themes, add ons, gui etc et the moment
ty
PS
STILL want to fix my problem(S)

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #12 on: February 11, 2021, 01:21:19 PM »
just found this on another post: (guess it proves not something I did)

Quote
In an ongoing effort to bring you the very best products and services, we will be upgrading all of our servers to PHP 7.4. In addition to improved data processing, which can boost your site’s speed and performance, you’ll also gain increased security. Newer versions of PHP have more frequent security updates to help protect your site against unwanted hacks or malware.

When will it happen?

At some point during the upgrade window -- February 09, 2021 through February 14, 2021 -- your account will be updated, and older versions of PHP will no longer be supported. You may experience a brief disruption in service during this time
Do I need to do anything on my end?
Yes, if you have any custom code or plugins, we recommend that you upgrade all of your web installations to the newest PHP software available before we upgrade your account. Newer versions of PHP are already available on your current server, and you can set your site to use those versions with this helpful guide. You should also backup all of your website files.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 60,203
  • Gender: Male
    • Kindred-999 on GitHub
Re: need help from a real pro
« Reply #13 on: February 11, 2021, 02:44:36 PM »
However... php 7.4 should not have broken the connection to the database -- it would just show php error messages about deprecated code
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Project Manager
  • SMF Super Hero
  • *
  • Posts: 19,819
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • My Daily Dose Of Blasphemy
Re: need help from a real pro
« Reply #14 on: February 11, 2021, 03:14:56 PM »
just for fun - how do I use the old database?
The same way you would use it on the old install. You would need to know how to connect to it, and that's the problem right?
If you need to, repair_settings.php can help with changing the settings of an SMF install.
A Finnish Project Manager (Support Specialist)
Happily running multiple SMF 2.x installations.
 Fooling around with an i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #15 on: February 11, 2021, 06:09:06 PM »
I agree - server changing PHp should not have broken it -  but something did
cannot run repair settings on old site - can note see wanting to run?
I did see this option on new install
looked for it using FTPin to old site - can not fund the file - where is it?

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,936
  • We were all equal in the end.
Re: need help from a real pro
« Reply #16 on: February 11, 2021, 06:21:47 PM »
You have to upload repair_settings.php to forum root and run it with direct link.  Did you read Lex's link?  Get the file there.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #17 on: February 11, 2021, 06:31:55 PM »
sorry  saw the link - but though it was a sample
just read it = I think I can do it
will report back
THANKS

Offline TheDragon

  • Sr. Member
  • ****
  • Posts: 833
Re: need help from a real pro
« Reply #18 on: February 11, 2021, 07:02:57 PM »
did as instructed - got the same error
ran this:
(SNIP)
go this:
This page isn’t working vcsy-chat.com is currently unable to handle this request.
HTTP ERROR 500
« Last Edit: February 12, 2021, 01:53:15 AM by Aleksi "Lex" Kilpinen »

Offline Matthias

  • Jr. Member
  • **
  • Posts: 163
  • Gender: Male
Re: need help from a real pro
« Reply #19 on: February 11, 2021, 07:20:00 PM »
The request is:
HTTP ERROR 500

Feel free to look for this error message at your favourited search engine...
That's not an problem with SMF.
Quality first