• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 03:35:52 PM

News:

Wondering if this will always be free?  See why free is better.


No Login possible on fresh installation

Started by Dave J, March 11, 2021, 05:13:30 AM

Previous topic - Next topic

dungeonseeker

Quote from: albertlast on April 18, 2021, 02:25:18 AM
About the wrong domain,
you could test this change:
Session.php
search for
@ini_set('session.cookie_domain', '.' . $parts[1]);
an replace this with
@ini_set('session.cookie_domain', '.' . $parts[0]);

Hi, not sure if it has the same effect but I did fix the issue by editing the globalCookies key to 0 in the settings table of the database.

I tried changing the globalCookiesDomain key to 0 first (as suggested earlier) but that didn't work for me. Only once I turn global cookies off could I login.

Edit - I should also add that I did suffer from the same bug as the OP in this thread. My forum URL is hxxp:dungeonseeker.i234.me [nonactive] (its actually a DDNS domain name) and the default install set the subdomain key to ".i234.me" by default.

Since this is a totally fresh install (that I don't really need for a few weeks anyway) I'm quite happy to give you access to the admin account, files, phpmyadmin account and carte blanche to do anything you like (including a fresh install) if you want to investigate. Just PM me and I'll send you the info.

albertlast

in your case global cookies doesn't work and shouln't be allowed to enable,
since you provide a high chance to share account data with other services how are using i234.me also as service.

dungeonseeker

Quote from: albertlast on April 18, 2021, 06:42:39 AM
in your case global cookies doesn't work and shouln't be allowed to enable,
since you provide a high chance to share account data with other services how are using hxxp:i234.me [nonactive] also as service.

It enabled as part of a default install and the issue is that I then could not log in to make any changes at all.

Yes you're correct. I'm doing a site test run on my Synology NAS, the DDNS is from Synology, its running through Apache 2.4 and there are multiple services running on it. The thing is though, I don't need subdomain enabled cookies at all, I don't care if my other services cannot interact with SMF. I just can't understand why having them enabled caused this issue? All my subdomains are running on private virtual servers anyway.

dungeonseeker

OK, so after doing another reinstall I worked out that I need to make 2 changes to the database for login to work...

I must change globalCookies to 0 then manualy add localCookies and set it to 1.

Hope this is useful.

Advertisement: