• Welcome to Simple Machines Community Forum. Please login or sign up.
September 19, 2021, 12:15:00 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Message d'erreur pour chaque message posté !

Started by Paulo.chon, July 27, 2021, 06:09:30 PM

Previous topic - Next topic

Paulo.chon

Bonjour,

Etant en train de faire du ménage dans mon site, voilà que j'ai maintenant une erreur chaque fois qu'un message est posté.

Le journal d'erreur m'indique ceci :
Quote
2: A non-numeric value encountered
Appliquer le filtre: Ne montrer que les erreurs provenant de ce fichier
Fichier: /home/monsite/www/mobiquo/smartbanner.php
Ligne: 102

Et la ligne 102 de ce fichier est celle-ci :
   $current_page = isset($_REQUEST['start']) ? ($_REQUEST['start'] / $messages_per_page + 1) : 1;

J'ai désinstallé des mods et fait une requête sql pour supprimer des balises [youtube] mais ça ne semble pas avoir de rapport, du reste le fichier dont il est question avait déjà la même ligne auparavant.

Sauriez-vous me dire de quoi il s'agit et quel remède apporter ?
Merci.

Paulo.chon

En comparant les fichiers smartbanner.php en place et lors de la sauvegarde précédente, la seule différence est une ligne blanche, justement à la hauteur de cette fameuse ligne 102.
Avant
           {
                $location = 'topic';
                $current_page = isset($_REQUEST['start']) ? ($_REQUEST['start'] / $messages_per_page + 1) : 1;

                $other_info[] = 'page='.$current_page;
            }


Après
           {
                $location = 'topic';
                $current_page = isset($_REQUEST['start']) ? ($_REQUEST['start'] / $messages_per_page + 1) : 1;
                $other_info[] = 'page='.$current_page;
            }


Je ne pense pas que ça puisse faire de différence mais dans le doute j'ai remplacé le fichier par le précédent : j'ai toujours la même erreur.

Ce que j'ai fait entre les deux :
- Désinstallé le mod Arantor Captcha qui s'est fait sans problème.
- passé de PHP 7.0 à PHP 7.3

Je ne vois pas trop en quoi ça a pu jouer...

maximus23

Bonjour,


Attention pas mal de mods ne supportent pas les versions supérieures au Php 7.0.


:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Paulo.chon

Ah ça viendrait d'un mod ?

Il me semble que Mobiquo est lié au mod Tapatalk c'est bien ça ?

Enfin oui c'est certain je viens de le vérifier.
Donc désinstaller Tapatalk résoudrait le souci ?
Mobiquo n'intervient pas dans le reste du forum ?

Paulo.chon

Quote from: maximus23 on July 28, 2021, 02:21:51 AM
Attention pas mal de mods ne supportent pas les versions supérieures au Php 7.0.

Je reviens sur ce point :
Comment peut-on savoir si un mod supporte ou pas une version supérieure à 7.0 ?
Car en général il n'y a pas d'info sur la version de PHP supportée par les mods...

Je m'apprête à installer Simple Audio Video Embedder et je vois que là il en est question par contre, donc OK !
Quote5.0.3
!Fixed mobile detection for PHP 7.2+ so no warning messages logged

Mais pour les autres ?

Ou vaut-il mieux dans le doute rester en 7.0 ?
(J'avais un message d'avertissement de mon hébergeur OVH sur cette version plus suivie, c'est pourquoi je l'ai passé en 7.3)

Paulo.chon

July 28, 2021, 03:14:57 AM #5 Last Edit: July 28, 2021, 04:00:37 AM by Paulo.chon
J'ai désinstallé Tapatalk ce qui a supprimé Mobiquo.

J'ai un nouveau message d'erreur :
Quote2: include(): Failed opening '/homez.809/monsite/www/mobiquo/smartbanner.php' for inclusion (include_path='.:/usr/local/php7.3/lib/php')
Appliquer le filtre: Ne montrer que les erreurs provenant de ce fichier
Fichier: /home/monsite/www/Sources/Load.php
Ligne: 1678

Voilà la partie du fichier en question :
// Some basic information...
if (!isset($context['html_headers']))
$context['html_headers'] = '';

include($boarddir.'/mobiquo/smartbanner.php');
$context['menu_separator'] = !empty($settings['use_image_buttons']) ? ' ' : ' | ';
$context['session_var'] = $_SESSION['session_var'];
$context['session_id'] = $_SESSION['session_value'];
$context['forum_name'] = $mbname;
$context['forum_name_html_safe'] = $smcFunc['htmlspecialchars']($context['forum_name']);
$context['header_logo_url_html_safe'] = empty($settings['header_logo_url']) ? '' : $smcFunc['htmlspecialchars']($settings['header_logo_url']);
$context['current_action'] = isset($_REQUEST['action']) ? $_REQUEST['action'] : null;
$context['current_subaction'] = isset($_REQUEST['sa']) ? $_REQUEST['sa'] : null;
if (isset($modSettings['load_average']))
$context['load_average'] = $modSettings['load_average'];



Que faut-il que j'efface qui fait référence à Mobiquo, devenu introuvable ?

La ligne 1678 est celle-ci :
      include($boarddir.'/mobiquo/smartbanner.php');




Autre point qui n'a rien à voir : la racine de mon site est désigné par "home" ou par "homez.809" selon les endroits.
Cela apparaît ici.
J'ai demandé à OVH (mon hébergeur) si je pouvais remplacer homez.809 par home partout (comme me le suggère d'ailleurs le repair_settings) mais pas encore de réponse....

Paulo.chon

Houps maintenant ça génère une erreur à chaque fois qu'une page est affichée, le compteur monte très vite !  :P

Paulo.chon

Bon je me réponds :
En mettant la phrase en commentaire, le phénomène cesse, je n'ai plus d'erreur, ni en postant ni en affichant une page.

Je vais pouvoir effacer la ligne.

maximus23

Bonjour,

Oui avec tapatalk il reste souvent des morceaux qui ne se désinstallent pas correctement.

Une chance le code est entre commentaire donc très facile à éradiquer manuellement.

Pour savoir si un mod est compatible il suffit de regarder la date de mise à jour. Si elle date de mathusalem alors méfiance.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Paulo.chon

Ah merci !

Je fais du ménage et désinstalle pas mal de choses, parfois même des mods qui ne fonctionnaient plus (trop vieux) et avaient été désactivés, donc je ne veux plus installer que des trucs récents.
Du coup je vais rester sur PHP 7.3 (j'avais pensé rétrograder si ça posait problème, mais je préfère fonctionner avec des trucs bien à jour).
Et surtout les tenir à jour, bêtement je n'avais jamais pris la peine de faire les mises à jour de mods, ça ne m'avait même pas effleuré l'esprit que ça puisse être nécessaire !
Maintenant je comprends mieux le bouton "notifiez-moi des mises à jour" dans les mods, je vais bien veiller à l'activer !

Advertisement: