• Welcome to Simple Machines Community Forum. Please login or sign up.

SMF 2.0.18 - welche PHP-Version ist mindestens erforderlich?

Started by AmaSha, March 26, 2021, 06:54:58 AM

Previous topic - Next topic

AmaSha

Servus.

Ich muss demnächst einige sehr umfangreiche Arbeiten an meinem SMF-Forum und drumherum (Server) durchführen. Dazu muss ich mir natürlich so ein wenig eine "Roadmap" zurechtlegen. In diesem Zusammenhang dann meine Frage:

Welche PHP-Version brauche ich mindestens, damit ich das Upgrade auf 2.0.18 druchführen kann (Large Update)? Oder anders gefragt: Sollte ich erst das Forum (derzeit noch 2.0.13, leider) upgraden oder erst das PHP? Aus Zeitmnagel habe ich die letzten Upgrades immer vor mir hergeschoben und sicherlich auch wegen meiner noch eher dürftigen Bandbreite für Sicherung und Upload (16k-DSL, Glasfaser in Aussicht).

Danke im Voraus für Eure Antworten und ein schönes Wochenende.
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

m4z

Willkommen zurück! :)


Die Doku ist da leider etwas unübersichtlich.

Die SMF-Situation ist in etwa so (ich stütze mich nur auf Doku und Entwicklungs-Diskussionen, die ich finden konnte; ich betreibe selbst kein 2.0.x):
* SMF 2.0.7 bis 2.0.13 unterstützt PHP 4.1 bis 5.6
* SMF 2.0.14 – 2.0.15: PHP 5.4 – 7.1
* SMF 2.0.16: PHP 5.3 – 7.3
* SMF 2.0.17: PHP 5.3 – 7.3 (evtl. auch 7.4, dann aber mit vielen Fehlermeldungen)
* SMF 2.0.18: PHP 5.3 – 7.4
* es ist zu erwarten, dass zukünftige SMF-Versionen (2.0.19 / 2.1) PHP 5.6 oder höher unterstützen werden

Welche Versionen stehen dir zur Auswahl? Wenn es dir möglich ist, würde ich:
* für das Upgrade auf 2.0.14 auf 5.4/5.6 gehen,
* irgendwann ab 2.0.14/15 auf 7.1 gehen,
* ab 2.0.16 auf 7.3 gehen,
* ab 2.0.18 auf 7.4 gehen,

... denn alles vor 7.4 ist ja bereits aus dem offiziellen Support (wobei die Linux-Distributionen meist einige Monate/Jahre länger Support anbieten).
"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

AmaSha

Hi M4z.

Danke für die ausführliche Antwort.

Nun, ich denke, dass ich dann vor dem Umzug erst das Forum updaten werde, denn PHP 5.4 läuft auf dem Server schon/noch. Es steht also einem Update so gesehen nichts im Wege. Wenn die 2.0.18 dann läuft werde ich das Forum in diesem status quo komplett sichern und dann den Umzug auf den neuen Server vollziehen.

Ich denke, das ist eine gute Vorgehensweise.

Danach schaue ich mir noch mal das Email-Problem an, in der Hoffnung, dass es dann nicht mehr auftritt. ;)

Erstmal danke und allen ein schönes Wochenende.
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

AmaSha

Moin zusammen.

So, wir sind mittendrin im Patching.

Dazwischen einfach mal eine, wahrscheinlich saublöde, Frage: Können die bisherigen Update-Patches

Quote
...
3.    SMF 2.0.13 Update    1.0    [ Deinstallieren ]
4.    SMF 2.0.12 Update    1.0    [ Deinstallieren ]
5.    SMF 2.0.11 Update    1.0    [ Deinstallieren ]
6.    SMF 1.1.21 / 2.0.10 Update    1.0    [ Deinstallieren ]
7.    SMF 1.1.20 / 2.0.9 Update    1.0    [ Deinstallieren ]
...

deinstalliert werden oder MUSS ich die behalten.... *grübel*
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

AmaSha

So, nun ist es doch passiert...  :-\

Hätte ich mal alles richtig gelesen, aber so...?!  :'(

Also, das Forum ist bis 2.0.14 gepatched, weiter geht es nicht, da tatsächlich nur PHP 5.3.x installiert ist. Da wir demnächst auf einen größeren Server umziehen wollen (mit aktuellem Ubuntu und PHP 7.4) erscheint es mir unsinnig, jetzt noch mit ach und krach PHP 5.4.x oder ein höheres 5.x zu installieren.

Auch das große Patch von älteren Versionen auf 2.0.18 will nicht - ich bekomme immer wieder Fehlermeldungen im Paketmanager, dass die Datei leer sei usw.

Tatsächlich würde ich versuchen wollen, einen anderen Weg zu gehen:

1. Nach Serverumzug ein jungfräuliches 2.0.18 installieren und dann versuchen
2. die SQL-Datenbank des 2.0.14 zu importieren bzw. zu migrieren.

Das erscheint mir im Moment der Weg des geringsten Widerstandes zu sein.

Wie bekomme ich die 2.0.14er SQL-Datenbank in ein jungfräuliches 2.0.18 migriert, was muss ich machen bzw. beachten?  ::)

Danke im Voraus für Eure Antworten.   ;D
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

AmaSha

Guten Morgen.

Wir haben es jetzt einfach getan - 2.0.18 läuft, jetzt migrieren wir die einzelnen Tabellen wieder - zumindest die relevanten.

Ich werde berichten. :)
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

AmaSha

Guten Morgen.

Ich wollte berichten, also mache ich das auch. Vorneweg: Meine Laptoptastatur verschluckt bzw. unterschlägt momentan immer mal wieder den einen oder anderen Buchstaben, bitte nicht wundern...

Ausgangslagen: Ubuntu-Server (uralte Version) mit PHP 5.3.x, Forensoftware SMF 2.0.12. Aus beruflichen Gründen (Reisen) fehlte die Zeit für Updates. Zumal sich Updates bis 2.0.12 seither als schwierig erwiesen hatten. Meist brauchte es bis zu fünf Anläufe - die klassischen Fehlermeldungen zu TMP/TEMP-Verzeichnis etc.

Das Update auf Version 2.0.13 und auch 2.0.14 gelang, wenn auch mit Mühe (s.o.). Dann war Schluss - auf 2.0.15 wollte SMF nicht updaten! Das war also die Sackgasse, Punkt!

In Abstimmung mit meinem Co-Admin haben wir uns dann entschieden, das Forum einmal noch komplett zu sichern - Dateien, SQL-Datenbank komplett und alle SQL-Tabellen nochmals separat. Und dann den Server "plattmachen".

Gesagt, getan, der Server wurde neu aufgesetzt. Ein frisches Ubuntu 18.04 LTS drauf (mehr bietet mein Provider derzeit nicht an) mit PHP 7.3.x, für einzelne Webseiten sogar noch PHP 7.2 nutzbar (Switch im Admin -Panel).

Dann wurden zunächst drei andere Webseiten wieder eingerichtet und konfiguriert (einmal reines HTML, zweimal WordPress).

Ergriffene Maßnahmen: Wir haben zunächst versucht, das 2.0.14 auf dem neuen Server zum Laufen zu bringen - alle Files hochladen und die SQL-Datenbank entsprechend wiederhergestellt. Alle Parameter passten, aber die Seite blieb weiß. Das Fehlerprotokoll brachte einige Hinweise auf veraltete PHP-Skripte, die unter 7.2 bzw. 7.3 nicht mehr ausgeführt werden konnten. Also alles wieder löschen.

Dann ein frisches 2.0.18 aufgesetzt, TinyPortal 2.0.1 sowie den aktuellen Simple Audio Video Embedder dazu. Das ging komplett reibungslos, selbst die beiden Mods ließen sich komplett ohne Fehler installieren - keine Fehlermeldungen, ein Anlauf, fertig. Dann haben wir zunächst das Tiny Portal wieder so angelegt, wie es vorher war - ein Import der entsprechenden Tabellen hätte wegen Inkompatibilität nichts funktioniert. Als Hilfe hatten wir die alte SQL-Datenbank als Dummy mit hochgeladen und so konnten wir die Einträge der TP_-Datensätze zumindest auslesen und ggf. einzelnen HTML-Code übertragen.

Dann ging es an den Re-Import der einzelnen SMF-Tabellen - nur die relevanten (Members, Membergroups, Attachments usw.). So kam Schritt für Schritt alles wieder zurück. Es gab keine Importfehler bei der Wiedereingliederung der einzelnen Tabellen (okay, einen gabs, aber das war ein 30cm-Bug - ein Admifehler, Errorcode 0815 "Schusseligkeit"). Natürlich wurde nach jedem Re-Import einzelner Tabellen eine komplette Sicherung der gesamten SQL-DB durchgeführt. Bis die PN und die Text-Beiträge eingebaut waren war die DB ja noch recht klein.

Jetzt haben wir zwar noch einige kleine Bugs im Forum (z.B. fehlen einige von Usern hochgeladene Avatare - den Fehler muss ich noch ausbügeln), aber heute Nachmittag können wir wieder eröffnen.

Ich hoffe, mit diesem Bericht kann ich anderen SMF-Usern eine kleine Hilfe bei ähnlichen Problemen bieten. Ich beantworte auch gerne Fragen dazu, soweit es in meiner (Kenntnis-) Macht steht.

Euch allen ein schönes Wochenende und viel Spaß und Erfolg mit Euren Foren.

Gruß

Thomas
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

AmaSha

Und wieder den Tag vor dem Abend gelobt.....  :'( :'( :'( :'(

Wir haben tatsächlich noch ein enorm großes Problem: die "attachments".

So wie es aussieht sind die Dateianhänge beim Download sowohl meines Co-Admins als auch mir geschrottet worden - zumindest Bilder aller Formate und PDF's (Word, Excel u. Co nicht ausgeschlossen, soweit haben wir noch nicht getestet, weil es überwiegend um Bilddateien geht).

Mir stellt sich bloß eine Frage: Ist das technisch möglich, dass zwei Downloads (jeweils mit FileZilla, aktuelle Version) in die Grütze fahren können?

Oder gibt es ein Problem mit der Kompatibilität zwischen attachments unter 2.0.14 (vielleicht sogar schon 2.0.13, wir haben das nach dem Update nicht getestet) und 2.0.18?
Und wenn ja, welche Abhilfe gibt es?
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

wintstar

Prüfe die Einstellungen der Dateianhänge, insbesondere ob der Pfad zum Dateianhangverzeichnis korrekt ist
Quote?action=admin;area=manageattachments;sa=attachments

Prüfe die Zugangsberechtigung des Dateianhangverzeichnis (chmod) richtig vergeben sind
Quote?action=admin;area=packages;sa=perms

Sind Dateianhänge hier aufgelistet?
Quote?action=admin;area=manageattachments;sa=browse
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

AmaSha

Moin wintstar.

Quote from: wintstar on July 31, 2021, 06:29:19 AM
Prüfe die Einstellungen der Dateianhänge, insbesondere ob der Pfad zum Dateianhangverzeichnis korrekt ist
Quote?action=admin;area=manageattachments;sa=attachments

Sind an sich gesetzt:

- Alle Dateianhänge aktiviert
- im Moment ist die Dateiprüfung deaktiviert (bis das Problem gelöst ist!)
- Upload-Pfad verweist auf -> httpdocs/attachments (das Verzeichnis exisitert und ist mit 16.000+ Dateien entpsrechend gut besucht...)
- die Größen-Einstellungen entsprechen denen vor dem "Server-Umzug".
- Neukodierung ist deaktiviert
- Durchführen von umfangreichen Sicherheitskontrollen auf hoch geladene Bild Anhänge: deaktiviert
- Dateianhang als Bild im Beitrag anzeigen: aktiviert
- Bilder verkleinern, wenn sie im Beitrag angezeigt werden: aktiviert
- Miniaturbilder als PNG speichern: deaktiviert
- Max. Breite der Vorschau: 200
- Max. Höhe der Vorschau: 200

Quote from: wintstar on July 31, 2021, 06:29:19 AM
Prüfe die Zugangsberechtigung des Dateianhangverzeichnis (chmod) richtig vergeben sind
Quote?action=admin;area=packages;sa=perms

Wert ist "(CHMOD: 0755) "

Quote from: wintstar on July 31, 2021, 06:29:19 AM
Sind Dateianhänge hier aufgelistet?
Quote?action=admin;area=manageattachments;sa=browse

Yep, sind sie. Die Hashs der Tabelle "smf_attachments" passen soweit auch zu den vorhandenen Dateien im Verzeichnis -> httpdocs/attachments
Es ergeben sich lediglich die Diskrepanzen in einem Delta von fehlenden Dateien seit etwa Anfang Juli '21 - das ist wohl beim Sichern passiert, bevor wir umgezogen sind. Ist aber, nach Rücksprache mit den Usern, nicht so gravierend, weil die nachgereicht werden können.

Erstaunlich ist, dass Bilder, die jetzt hochgeladen werden, zum Teil auch geschrottet werden oder im Beitrag die falschen Bilder (Vorschau) angezeigt werden. Aber dazu kann ich später nochmal mehr schreiben, nachdem wir jetzt die beitragsbasierenden Gruppen zunächst mal in den Berechtigungen drin haben. Jetzt werden wir Avatare und Dateianhänge in diesem Kontext erstmal erneut testen.

Für den Moment wieder herzlichen Dank dür den Support und die Geduld. :)
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

wintstar

Wieviel Dateispeicher hast du bei deinem Hoster zur Verfügung, ist die Höchstgrenze erreicht?

? werden die Datei hochgeladen und im Verzeichnis abgelegt
? wenn ja, werden diese in der Datenbank gespeichert

Quotegeschrottet werden
Beschreibe das bitte genauer.
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

AmaSha

Hi wintstar.

Nope, Speicherplatz 30 GB (Forum inkl. attachments + Wiki) von 300 GB - eigener Server. Domainpaket ist auf "unbegrenzt" gesetzt. Da ist noch viel Luft nach oben.

Yep, die FIles kommen auf dem Server an und werden als Hash abgelegt, der auch in die DB geschrieben wird.

Geschrottet: Die typischen Verfärbungen von JPEGs, wie man das früher gerne mal noch auf langamen Internetleitungen hatte. Funktinierend hochgeladene PDF's konnten nach dem Download nicht geöffnet werden usw.

Aber: Nachdem ich jetzt das Berechtigungsmanagement auch für die beitragsbasierten Gruppen am Laufen habe scheint es richtig zu funktionieren - wir testen noch. Es gb inzwischen vier Uploads, die ohne Probleme funktioniert haben. Ich hoffe, dass jetzt die User mit den genannten Problemen ebenfalls noch mal testen und wir feststellen können, ob wir das Problem im Griff haben.

Ich melde mich wieder! :)
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

AmaSha

Guten Morgen.

So, ich wollte mich ja mal melden... *flöt*

Also, das Anfügen von Dateianhängen funktioniert wieder einwandfrei, da nun auch die beitragsbasierten Gruppen ins Berechtigungsmanagement eingefügt sind und entsprechend greifen. Ungelöst ist noch das Problem der vor dem Umzug gesicherten Daten, warum diese verstümmelt sind (JPG, PNG, PDF...) und die MP3 und WAV Dateien augenscheinlich nicht. Daran forschen wir noch.

Aktuell gibt es noch ein Problem mit den Avataren. Derzeit sollen die in den "attachments" abgelegt werden, aber das scheint wohl Probleme zu bereiten. Daher verlege ich das wieder auf das Avatar-Verzeichnis. Und dann testen wir mal, ob die Jungs ihre Avatare nach dem Upload auch wieder angezeigt bekommen. Auch dazu später noch eine Rückmeldung.

So viel für den Moment. Ich halte Euch auf dem Laufenden.

Schönen Sonntag.
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

wintstar

Es ist nicht hilfreich wenn du nur verstümmelt schreibst. Da du auf einen anderen Server umgezogen bist könnten auch die Einstellungen des Server verantwortlich sein wenn die Dateianhänge in schlechterer Qualität ?verstümmelt? angezeigt werden.

2.0.18 ist nur bedingt für eine höhere php Version, viele Fehlermeldungen werden vom Quellcode unterdrückt. Prüfe mal auf dem Server die Fehlerprotokolle.
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

AmaSha

Servus.

Ich bin noch 'ne Antwort schuldig - durch den Job komme ich nicht dazu. Daher  melde ich mich diesbezüglich am Wochenende. Wir haben den Fehler aber wohl gefunden, doch dazu dann am WE mehr.

Schöne Grüße und bleibt alle geund! :)
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

AmaSha

Hallöchen.

So, wir haben den Fehler gefunden - und es hat nichts mit SMF zu tun!

Der Fehler liegt eindeutig bei FileZilla. Die als reine Hashs, ohne Extender, abgelegten Dateien wurden beim Sichern (Download per FTP) als ASCII-Dateien behandelt, nicht als sog. "Binary Files". Dadurch gehen die Informationen im Dateiheader verloren und ein JPG wird dadurch zerstört. Ähnliches gilt für PNG oder PDF.

Dadurch sind viele Dateianhänge unwiederbringlich zerstört - und das müssen wir beiden Admins uns nun gefallen lassen.

Ob wir die Dateien (wir reden hier von 16.000+ "attachments") irgendwie wiederhergestellt bekommen könnten? Fraglich. Bislang haben wir noch keine Möglichkeit gefunden. Vielleicht hat jemand von Euch einen Tipp, ob es solche Tools gibt, aber ich fürchte, das wird nix. Jeder Tipp ist dennoch herzlich willkommen.

Ich markiere den Topic als "gelöst", da das Problem NICHT durch SMF verursacht wurde.

Schönen Sonntag noch. :)
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

m4z

"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

AmaSha

Hi M4z.

Darüber bin ich auch vor einiger Zeit gestolpert. WIr versuchen noch eine Lösung für zumindest kleinere Dateien zu finden....
 :-\
Beste Grüße aus dem hohen Norden

Thomas

Gekommen, um zu lernen.

Advertisement: