Advertisement:

Author Topic: Uploaded Avatars Not Showing  (Read 1042 times)

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Uploaded Avatars Not Showing
« on: May 14, 2021, 04:50:10 PM »
Uploaded avatars are not showing up for guests (and only guests not members) in 2.0.18 and I've tried everything in the admin avatars configuration section with no luck.  They simple show up as broken images or as that little page icon.

any ideas?

Offline Steve

  • Freak
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 4,927
  • Gender: Male
  • I have not yet begun to procrastinate.
Re: Uploaded Avatars Not Showing
« Reply #1 on: May 14, 2021, 06:31:19 PM »
I've split this topic off from the one you posted in as it was a solved topic from 4 years ago.

A couple of questions:

Did you read that whole topic and none of it was helpful?

And, would you mind if we shortened your display name as it's running into the title and time of the post? Possibly to jeepwrangler2k?
Please do not PM me for support.

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Re: Uploaded Avatars Not Showing
« Reply #2 on: May 14, 2021, 07:35:53 PM »
I've split this topic off from the one you posted in as it was a solved topic from 4 years ago.

A couple of questions:

Did you read that whole topic and none of it was helpful?

And, would you mind if we shortened your display name as it's running into the title and time of the post? Possibly to jeepwrangler2k?

Yes I read the whole topic.  Thanks.

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #3 on: May 14, 2021, 09:34:57 PM »
Link to forum?
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Re: Uploaded Avatars Not Showing
« Reply #4 on: May 14, 2021, 11:58:50 PM »
Oh sorry..  https ://undergroundmusiccompanion.com but I think this forum will xxx out my post.

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #5 on: May 15, 2021, 12:01:58 AM »
Guests can't view anything except portal blocks.  Where are you not seeing avatars?
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Re: Uploaded Avatars Not Showing
« Reply #6 on: May 15, 2021, 12:05:58 AM »
In my theme called Redsy they normally show up along the top of the forum under the Online area just above the login prompt.

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #7 on: May 15, 2021, 12:24:40 AM »
That's odd.  If you look at this link you'll see avatar -

 https://www.thekrashsite.com/smf20/index.php?action=dlattach;attach=1;type=avatar

You're a guest on my test forum and can see it.  But on your forum it goes to login -

 https://undergroundmusiccompanion.com/index.php?action=dlattach;attach=7;type=avatar

Guests cannot view avatars.  There's no permission for that, unless it's something in the portal.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #8 on: May 15, 2021, 12:42:39 AM »
Same thing in Curve, it's not a theme problem.  Don't see anything in TP that can cause that (you should upgrade to current version).  Is mod_security enabled on your server?
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Re: Uploaded Avatars Not Showing
« Reply #9 on: May 15, 2021, 12:51:45 AM »
the TP version I'm using is the only one that worked for 2.0.18.   I don't know if mod_security is enabled on the server. How do I find that?

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #10 on: May 15, 2021, 12:59:55 AM »
If it's in cpanel -> security you can disable it, otherwise you'd have to ask host support.  IIRC you should have it in HG cpanel, but don't really think that's the problem.  Just something to eliminate.

I just installed TP 2.0.1 on 2.0.18 forum, should work fine on yours.  You have to uninstall existing version first, all content will be retained if you don't check 'Remove all data associated with this modification'.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #11 on: May 15, 2021, 01:30:09 AM »
I've registered as Krash and can see avatars when logged in.  Going offline, if you can't fix it make me admin and I'll have a look tomorrow.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Project Manager
  • SMF Super Hero
  • *
  • Posts: 20,114
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • LexArma on GitHub
    • aleksi-kilpinen on LinkedIn
    • Aleksi Kilpinen
Re: Uploaded Avatars Not Showing
« Reply #12 on: May 15, 2021, 02:23:54 AM »
It's pretty simple really. Your forum doesn't allow guest browsing, so the forum isn't showing anything to guests even though the portal is.
You can move avatars to a separate folder and not treat them as attachments - this would fix the problem, or you can allow guest browsing on the forum and limit access with permissions instead.
( For moving the avatars out of attachments, see step 1 in https://www.simplemachines.org/community/index.php?topic=293441.0 )
A Finnish Project Manager (Support Specialist)
Happily running multiple SMF 2.x installations.
 Fooling around with an i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #13 on: May 15, 2021, 04:03:20 PM »
   Of course, that's the one thing I didn't try.  Replicates the glitch in TP on test install.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline @rjen

  • Sr. Member
  • ****
  • Posts: 743
  • Gender: Male
    • FJR-club Nederland
Re: Uploaded Avatars Not Showing
« Reply #14 on: May 15, 2021, 04:37:28 PM »
I think Lex already identified the issue: the avatars being attachments blocks them in the recent topics. The block uses the SMF ssi function. In fact the block should better respect the overall SMF setting allow_guestaccess .

We will pick that up in TP2.1.0
Running SMF 2.0 with Tinyportal 2.0.1 at www.fjr-club.nl
Testing SMF 2.1 with Tinyportal 2.1.0 at test2.fjr-club.nl

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Re: Uploaded Avatars Not Showing
« Reply #15 on: May 15, 2021, 05:01:22 PM »
It's pretty simple really. Your forum doesn't allow guest browsing, so the forum isn't showing anything to guests even though the portal is.
You can move avatars to a separate folder and not treat them as attachments - this would fix the problem, or you can allow guest browsing on the forum and limit access with permissions instead.
( For moving the avatars out of attachments, see step 1 in https://www.simplemachines.org/community/index.php?topic=293441.0 )

Thank you. I made a folder on my root called avs or /home4/underion/avs.  Then under admin forum avatar settings I changed Upload avatars to - from attachment directory to specific directory and then typed avs into the upload directory but I get an error message saying that the custom avatar directory must be empty or invalid and it's definitely empty. Also tried the full path on my server of /home4/underion/avs instead of just avs but still not working and same error msg.

What did I do wrong or not do correctly yet?

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #16 on: May 15, 2021, 05:08:52 PM »

You have to use full server path for upload directory -

  /home/thekrash/public_html/smf20/avs

And full path for upload url -

  httpx://www.thekrashsite.com/smf20/avs

Copy it from Server-stored avatars (up top) and just change directory name.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Re: Uploaded Avatars Not Showing
« Reply #17 on: May 15, 2021, 05:12:17 PM »
Yes I just figured out what I was doing wrong - forgot to fill in the Upload URL as https://undergroundmusiccompanion.com/avs and now it seems to work without the error msg.

But sadly guests still can't see avatars. Does this mean I have to let them see the forum with restrictions as the only way they'll see them then?

Offline jeepwrangler2k

  • Semi-Newbie
  • *
  • Posts: 27
Re: Uploaded Avatars Not Showing
« Reply #18 on: May 15, 2021, 05:16:52 PM »
I've registered as Krash and can see avatars when logged in.  Going offline, if you can't fix it make me admin and I'll have a look tomorrow.

OK I'm doing that now.  you are now an admin to the site.

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 11,090
  • We were all equal in the end.
Re: Uploaded Avatars Not Showing
« Reply #19 on: May 15, 2021, 05:23:09 PM »
Almost right, fixed upload directory.  Should work now.
“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns