SMF Support > SMF 1.1.x Support

theme not loading on subdomain

(1/2) > >>

I made a copy of my forum on a subdomain with the intent of running upgrade from  from 1.1.21 to 2.0.17.

The forum appears to run but the theme(s) are not loading.

I have checked the paths and they are correct. I've tried including ending (/), leaving it off. No change. I don't know what else to try.

repair_settings.php does not run properly - it stops after path to attachments - no update button or whatever is on the bottom of the page.  Forum is here: [nofollow]

You can view the console & see errors by opening developer tools in your browser - on most browsers, you do this by pressing F12.

If you look at the console, you are getting this error message:

--- Quote ---The resource from “” was blocked due to MIME type (“text/html”) mismatch (X-Content-Type-Options: nosniff).
--- End quote ---

A quick google search says that usually means the file is missing...  Does that file exist?  Are you sure all files were copied over?

If the files exist, the next thing to look at is the setting "X-Content-Type-Options: nosniff".  See if your web folks can disable that.  (Also based on a quick google search...)


--- Quote ---The resource from “” was blocked
--- End quote ---

Well that path is wrong. There is an extra :forum: in it. Where is it getting it from? I have in my settings:

--- Code: ---$boardurl = ''; # URL to your forum's folder. (without the trailing /!)
$boarddir = '/home/school10/public_html/forumnew'; # The absolute path to the forum's folder. (not just '.'!)
$sourcedir = '/home/school10/public_html/forumnew/Sources'; # Path to the Sources directory.

--- End code ---

and for theme settings:

--- Quote ---Theme directory (templates): /home/school10/public_html/forumnew/Themes/EA
URL to above directory: [nofollow]
URL to images directory: [nofollow]
--- End quote ---

Best guess is you have an (unwanted?) redirect in there.  Pretty common for subdomains to redirect to a folder.

I would check cPanel for redirects.  If none found, check all of your .htaccess files.


[0] Message Index

[#] Next page

Go to full version