SMF Support > SMF 2.0.x Support

Trouble getting Localhost to work (Linux)

(1/1)

BigAlGeorge:
Im hoping that someone can give me some tips I recall years ago I spent hours getting lampp to work properly but cant recall.

Ive installed lampp with zend. Transferred my site from a DirectAdmin install to a subdir /htdocs/alsbrew/alsbrew_forum with directory permissions for me (tried 777 as well)



phpmyadmin imported sql with SimpleMachines Settings.php:
$boardurl = 'https://localhost/webfiles/alsbrew/alsbrew_forum';      # URL to your forum's folder. (without the trailing /!)
$webmaster_email = 'myemail';      # Email address to send emails from. (like noreply@yourdomain.com.)
$cookiename = 'SMFCookie693';      # Name of the cookie to set for authentication.

########## Database Info ##########
$db_type = 'mysql';
$db_server = 'localhost';
$db_name = 'elcheapo_brewforum';
$db_user = 'elcheapo_admin';
$db_passwd = 'mypass';
$ssi_db_user = '';
$ssi_db_passwd = '';
$db_prefix = 'baz_';
$db_persist = 0;
$db_error_send = 1;

########## Directories/Files ##########
# Note: These directories do not have to be changed unless you move things.
$boarddir = '/opt/lampp/htdocs/webfiles/alsbrew/alsbrew_forum';      # The absolute path to the forum's folder. (not just '.'!)
$sourcedir = '/opt/lampp/htdocs/webfiles/alsbrew/alsbrew_forum/Sources';      # Path to the Sources directory.
$cachedir = '/opt/lampp/htdocs/webfiles/alsbrew/alsbrew_forum/cache';      # Path to the cache directory.

I get a blank screen with localhost/webfiles/alsbrew/alsbrew_forum

So I tried installing into htdocs a fresh install of flatfile CMS Typesetter, same thing; blank screen (Typesetter usually works with anything.)

Have tried various settings in .htaccess but made only a little difference on one of my typesetter imports as shown here, then what the site looks like live.

Anything I can do to help, lets know and I'll try it. PHPinfo seems to show everything as it should and mod_rewrite is enabled in .htaccess.

Appreciate. Al.







Aleksi "Lex" Kilpinen:
A blank page is usually a server error, do you get anything logged in the error logs?

BigAlGeorge:
Great tip: /opt/lampp/logs there are php error and security.

Via the logs Ive got simplemachines and litecart working well.
SimpleMachines is really robust and a huge help is with 'repair_settings.php' which ensures you specify correct links.

A tip is that you may have username and password set on your online server, but these do not apply to your imported dbase.
username root and no password will usually get you working off localhost.

I still dont have my CMS typesetter working properly and the errors are not exactly succinct but will report any additional tips here and mark solved when sorted thanks heaps.
Al.

Aleksi "Lex" Kilpinen:
You're welcome, glad I could help.

BigAlGeorge:
Typesetter CMS would not play with Lampp due to the PHP version being 7.4:
'Array and string offset access syntax with curly braces is no longer supported'
I sorted this out, but still more errors so using the beta Typesetter 2, it worked better, but there is a directory issue (not permissions still continues to bug)

At least I have Litecart and SimpleMachines working 100%.

Navigation

[0] Message Index

Go to full version