SMF Support > SMF 2.1.x Support

Installing a new clean 2.1 RC3 install have issue

(1/3) > >>

thomcd8:
I have installed a clean 2.1 rc3 install and get this error in the installing

Fatal error: Uncaught Error: Call to undefined function display_db_error() in /home/www/politicalawareness.net/Sources/Subs-Db-mysql.php:101 Stack trace: #0 /home/www/politicalawareness.net/install.php(399): smf_db_initiate('localhost', '', 'blahblah', 'blahblah', 'smf_', Array) #1 /home/www/politicalawareness.net/install.php(952): load_database() #2 /home/www/politicalawareness.net/install.php(145): ForumSettings() #3 {main} thrown in /home/www/politicalawareness.net/Sources/Subs-Db-mysql.php on line 101

Any thoughts on the fix?

Thank you in advance

shawnb61:
Message above edited to remove DB credentials.  Please be careful not to share sensitive information when posting.


Looks like it is still running the installer code for some reason. 

Did your installation complete OK?  If so, delete install.php & try again.

thomcd8:
No its getting stuck with that error right at forum settings in the install.php at step 4

thomcd8:
i deleted it even tried from the one on github and tried installing and get stuck on step 4 after entering all the info, i get that error when i hit continue

shawnb61:
OK, so it appears the installation never completed successfully. 

First, some basics:
 - What version of mysql?
 - What php version?
 - Have you double-checked the DB credentials, e.g., by accessing the DB via phpmyadmin?

Navigation

[0] Message Index

[#] Next page

Go to full version