• Welcome to Simple Machines Community Forum. Please login or sign up.
September 27, 2021, 11:45:18 AM

News:

Check out the SMF Function DB!


Help with error message

Started by trippyfool, June 12, 2021, 06:56:08 PM

Previous topic - Next topic

trippyfool

Get this message when making a post, any help would be appreciated.

Expression #7 of SELECT list is not in GROUP BY clause and contains nonaggregated column 'thecornf_forum.ln.sent' which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by
File: /home/thecornf/public_html/Sources/Subs-Post.php
Line: 1410

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 1.1.11, while your database is at version 1.1.4. The above error might possibly go away if you execute the latest version of upgrade.php.


Thanks

shadav

um well, other than the normal advice, update to 2.0.18
1.x is eol (has been for awhile) and most hosting companies are getting rid of older php versions

I'm not sure if vbgamer's advice here would help or not as it was for smf 2.0.x

Quote from: vbgamer45 on May 15, 2020, 01:34:01 PM
Might require a code change edit your Settings.php and put


$mysql_set_mode = 1;

Quote from: vbgamer45 on May 15, 2020, 01:45:05 PM
Opps actually needs to be

$mysql_set_mode = true;


trippyfool

Thanks. Where would I place that code in my Settings.php?

I've been wanting to upgrade for awhile, but health issues have kept me from tackling it. Does anyone do upgrades for others?

Thanks again.

shadav

you could post in the Help Wanted (not for support) board

to be honest, as far behind as you are, it'd be better to just do the 2.0.18 large upgrade
since any mods that you might have installed would all be outdated as well and need updated and any themes in use
the large upgrade would install clean files and update the database, so no data would be lost but any themes and mods installed would be gone, you can then download the latest versions of any mods you were using or wanted to use so that everything would now be up to date

Aleksi "Lex" Kilpinen

Definitely would suggest getting up to date and go to the large upgrade to 2.0.18.
It's a big jump, as it means losing all modifications and custom themes - but at this point in time, it's past due time to go there really.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

trippyfool

I will just go for the large upgrade then. The forum is huge and is very old. Lots of themes and mods have come and gone. I'm sure the large upgrade is much needed for a multitude of reasons.

Thanks for the advice and the heads up to the help wanted forum.


Advertisement: