• Welcome to Simple Machines Community Forum. Please login or sign up.

Database error: .../Sources / Subs-Post.php

Started by Panoulis64, July 19, 2021, 08:39:07 AM

Previous topic - Next topic

Panoulis64

When I post a topic, I get a message

Database error
/home/triglian/public_html/Sources/Subs-Post.php
Line: 1839
Recently, before receiving these, I made changes, after questions here.

1. Question for birthday text
https://www.simplemachines.org/community/index.php?topic=578114.0

2. Subject title, larger
https://www.simplemachines.org/community/index.php?topic=578180.0

In the second issue, I reset the values I changed, but I continue to receive the same message.
I also reset the settings to the second question of the first question.
Without solving the problem.
What he advises me

vbgamer45

Can you attach that file might assist in troubleshooting
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Panoulis64

This is exactly what I see, like the picture.

The Subs-Post.php
writes this on the line 1839
array('id_msg')


Panoulis64

The packages I have are those of the attached image. There is no translation package.
also a month ago we did a big upgrade

Shambles

Maybe you had a QT package previously?  In any case, just try what was suggested:

QuoteSolution 1: Edit the table messages , field qt_lang and add as default value "en"

Panoulis64

Thanks for your answer.
However, the server administrator should see this and make the changes.

Really very old, I had a QT package.

Panoulis64

Good evening, we did what you mentioned and now there is no problem.
I would like to ask, if you know.
In PHP my admin, I saw that there are many tables from old packages.
If they are removed and if I have kept backups. I will have a problem;
I say this because my problem here was with an old package that I had uninstalled, if I understood correctly.

Shambles

Quote from: Panoulis64 on July 20, 2021, 12:24:42 PM
In PHP my admin, I saw that there are many tables from old packages.
If they are removed and if I have kept backups. I will have a problem;

Leave them alone, unless they cause you issues in the future, would be my advice.

Quote
I say this because my problem here was with an old package that I had uninstalled, if I understood correctly.

Yes, that was the cause. The uninstaller may have left the table there and a more strict version of your database query software may now be insisting on fields within it having default values.

Advertisement: