• Welcome to Simple Machines Community Forum. Please login or sign up.
November 30, 2021, 07:54:59 AM

News:

Wondering if this will always be free?  See why free is better.


Says Errors but No Errors?

Started by Shades., September 02, 2021, 07:42:18 PM

Previous topic - Next topic

Shades.

2.1RC4

Top "Admin" button shows 2 errors after installing just about any mod, but when I click on the error log there is no errors to be seen! And also clicking on any button/link the 2 error text in the admin button disappear until next random mod install! ???

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean


Diego Andrés

If the mod is using hooks could just be that the forum loaded the hooks before the files and so couldn't find the files/functions indicated yet.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Shades.

Is there an easy way to create a simple error that will show in the admin error logs just so I can make sure it's logging something? Not having any errors should be a good thing lol but has me concerned too cause I know I'm not that good! ;D

Plus with it popping up 1 or 2 errors on the link and then nothing be there in admin is weird! :o

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Diego Andrés

Should be displaying.
Do you still have the issue present or did it only happen when installing a mod?
What mod did you install?

SMF Tricks - Free & Premium Responsive Themes for SMF.

Shades.

It just happens randomly, not on any certain mod! I can just be clicking around and I'll see the error pop up then go to check it out and theres nothing there! :o

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

Ok I just uploaded the custom form mod on my 2.1RC4 test forum cause I knew it would kick out an error in admin...so it says:

Database Error
Data too long for column 'text' at row 19
File: /home/*****/public_html/*****/****/Packages/temp/install.php
Line: 129

so I took a screenshot of the link "error log" and the actual error log page (see attachment) there should be something in there because the number in the error log link is not going away this time.

You cannot see attachments on this board.

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

Quote from: Shades. on September 05, 2021, 05:12:52 PMIs there an easy way to create a simple error that will show in the admin error logs just so I can make sure it's logging something? Not having any errors should be a good thing lol but has me concerned too cause I know I'm not that good! ;D

Plus with it popping up 1 or 2 errors on the link and then nothing be there in admin is weird! :o
I really need to figure out how to see if the error logs are working by triggering it somehow. I removed two hooks that had an "X" beside them cause they were no longer in use and the error number in admin link went away. The two mods associated with the hooks were for 2.0 but I was experimenting lol, Custom Form mod and Email inactive Users mod just for the record. ;) But like I said, I removed their hooks and the error number (2) in the link went away but still no errors in logs!

Any ideas?

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

I think I finally figured it out that my index.template.php file was corrupted (by me) so I reuploaded a fresh index.template file and the error log is showing again and all the old errors are viewable now.

Marking this solved by self lol for now! 8)

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

September 07, 2021, 05:52:27 PM #9 Last Edit: September 07, 2021, 06:11:48 PM by Shades.
Nope, there is something wrong with the database once upgraded from 2.0.18 because my 2.0.18 is producing errors like it should but when I upgrade a copy of it to 2.1RC4 for testing it won't produce the errors and I've even tried deleting the old errors before updating. :o

Went and tried to login with wrong password which should cause it to report an error but it didn't! :(

Gonna try a "Nightly Upgrade" next and see what happens but I don't like using it cause some of the pre 2.1 mods won't work with it. ;)

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

Can't upgrade from 2.0.18 to the 2.1RC4 "Nightly" cause it keeps timing out but have no problems upgrading with the 2.1 download from SMF other than my errors posted above. :(

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

September 08, 2021, 08:38:03 PM #11 Last Edit: September 08, 2021, 08:48:06 PM by Shades.
Now I can't upgrade at all! I don't know what the problem is so giving up! >:(

I've upgraded a copy of my forum several times before but now it stalls at "Executing: "Changing column names." (1 of 41 - of this script)"

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

Finally got the stupid thing (you know...the thing man) to upgrade...lol! (But only the download from here)

But still shows that there are errors but there are none! >:(  ???

In the attached is an image of the copy of my forum and database with no mods and no edits, none!

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Shades.

Well that was exhausting but I finally figured it out!

So I uninstalled these two patches before upgrade:

1. SMF-20-fix_birthdate (uninstall before 2.0.19)
2. SMF-20-string-func-patch (uninstall before 2.0.19)

and these two mods

1. Stack Trace
2. DevCenter

Not sure which one was causing the problem but after uninstalling them I did my upgrade with the 2.1RC4 download from here (not sure about the "Nightly") and the upgrade went smooth on the test copy. I tried to sign in with wrong password so it would kick out an error. So when I finally logged in the errors were there and everything is working like it should so far.

Now we know it was one of those mods or patches or maybe all of them I dunno but I would make sure to uninstall them before upgrading so you don't have to go through the nightmare like I did to figure out what's wrong! ;)

Solved 8) 

ShadesWeb.com - Custom Logos
https://shadesweb.com

BikerHound.com - Sniffing out the road ahead
https://bikerhound.com

Dream as if you'll live forever; Live as if you'll die today. - James Dean

Advertisement: