News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Quick edit not working at all: Firefox + Windows 10

Started by Antechinus, September 04, 2021, 06:55:18 PM

Previous topic - Next topic

Antechinus


Mick.


Antechinus


Mick.

#3
Quote from: Antechinus on September 04, 2021, 07:09:47 PMWhat are you using to access it here?
Firefox Developer latest version




Testing quick edit ~ Steve

Steve

Please do not PM me for support.

Aleksi "Lex" Kilpinen

Testpost.

Quick Edit with FF on Win10.
Modify with FF on Win10.
Quick Edit with Chrome on Win10.
Modify with Chrome on Win10.

Seems to work just fine for me.
Tested FF 91.0.2 and Chrome 92.0.4515.159 on Windows 10 Pro 21H1 Build 19043.1165
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Shambles

Have you got a javascript blocker/extension running?

Just tested it here, and Quick Edit doesn't react if my js blocker is active.

Antechinus


Antechinus

Nope. But opened the console in dev tools, and I'm getting this when I try to edit:
Uncaught ReferenceError: oQuickModify is not defined
    onclick https://www.simplemachines.org/community/index.php?topic=578824.new#new:1

Antechinus

Ok, you lot. I haz done some more testing. :P

Quick reply is not working for me, at all, with FF 92.0, FF Dev Build 93.0 b4, Chrome 93.0.4577.82, or Edge Version 93.0.961.47. With all of these browsers I get the exact same error in the console and debugger:
Code (Console) Select
Uncaught ReferenceError: oQuickModify is not defined at HTMLLIElement.onclick (VM93 index.php:1323)
Code (Debugger) Select
oQuickModify.modifyMsg('4097895', '')Yes, this is for a message that is still within the editable time limit (just to stave off the obvious muppet question :D ).

The source code for that message just shows the basic markup, with no trace of anything related to quick edit functionality. I think this is going to have to be called an actual bug in 2.1 RC4.
Code (Page source) Select
<div class="keyinfo">
<div id="subject_4097895" class="subject_title subject_hidden">
<a href="https://www.simplemachines.org/community/index.php?msg=4097895" rel="nofollow">Re: [Preview] Ice Cream theme [SMF 2.1 RC4]</a>
</div>
<h5>
<span class="messageicon" >
<img src="https://static.simplemachinesweb.com/smf/smsite/images/post/xx.png" alt="" id="msg_icon_4097895">
</span>
<a href="https://www.simplemachines.org/community/index.php?msg=4097895" rel="nofollow" title="Reply #9 - Re: [Preview] Ice Cream theme [SMF 2.1 RC4]" class="smalltext"><strong>Today</strong> at 02:19:38 AM</a>
<span class="page_number floatright">
#9
</span>
<span class="smalltext modified floatright" id="modified_4097895">
</span>
</h5>
<div id="msg_4097895_quick_mod"></div>
</div><!-- .keyinfo -->
<div class="post">
<div class="inner" data-msgid="4097895" id="msg_4097895">
I am deliberately playing for cool and icy. Summer here can be hell on Earth. Cool and icy is good sometimes. <img src="https://static.simplemachinesweb.com/smf/smileys/simple/wink.gif" alt=";&#41;" title="Wink" class="smiley"><br><br>Anyway it&#39;s still WIP. The basic idea is sound, and it will evolve into something usable.
</div>
</div><!-- .post -->

Aleksi "Lex" Kilpinen

I'm not at all doubting your report here, but confused about what differs in these cases then - It works for others, on the same browsers on the same os.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF


lurkalot

Quote from: Antechinus on September 14, 2021, 01:13:10 PMI'm confused too. :D

I just tested it again here with the same version of Edge you are using. https://www.simplemachines.org/community/index.php?topic=578955.0

Edit

Testing quick edit in Edge in Win 10

Antechinus

That doesn't help me. :D :D :D :D :D :D :D
Ok, can anyone think of any other way I can test it, to nail this down?

I have already tried disabling all extensions in FF, and it makes no difference.

Steve

Please do not PM me for support.

Antechinus

I doubt that will fix the problem. :D
Quote from: Antechinus on September 14, 2021, 12:42:08 PMQuick reply is not working for me, at all, with FF 92.0, FF Dev Build 93.0 b4, Chrome 93.0.4577.82, or Edge Version 93.0.961.47.

Antechinus

Just had a bright idea: tried testing quick edit on a standard member account on local RC4. Works perfectly. So, it's something specific to this site.

Yes, have tried clearing cache and cookies, doing hard refresh, restarting browser, all the usual. ;)

Aleksi "Lex" Kilpinen

Well that's actually a good hint - there are a few different yet somewhat similar issues on this site that I've randomly come across lately, so yeah - there might be something odd going on somewhere.

I was logged in, and checking a like only to learn that I'm banned.
You cannot view this attachment.

I was logged in, and tried to clear my alerts only to be presented a login form.
You cannot view this attachment.

To name a couple examples.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Antechinus


Aleksi "Lex" Kilpinen

I'd love to blame it all on Liroy, but since immediately after another attempt was fine and getting that notice didn't seem to leave any log entry - I'll file it under "random hiccups".
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

shadav

yeah I randomly get the log in screen on the alerts a page fresh usually fixes it
however I use chrome

SleePy

Do you sit on that page for a while?  I.e, long enough that your session times out on the forum?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Aleksi "Lex" Kilpinen

I can actually replicate that login issue 100% of the time by first going to https://simplemachines.org/ and then opening the alerts, and clicking mark read while on that page. 
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Diego Andrés

So that's not a cust site issue only, good to know  :laugh:

SMF Tricks - Free & Premium Responsive Themes for SMF.

SleePy

Ahh yea.  Looks like that page isn't responding properly when the request comes from a cors domain.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Antechinus

The quick edit is working for me now, at least with Firefox. Firefox is up to v93.0 now, but I don't know if that is relevant.

Have not got around to checking other browsers yet.

Antechinus


SleePy

Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf



SleePy

I just tested in firefox (mac) with a cleared cache, no issue.  No addons running on it.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Antechinus


SleePy

Are you receiving any javascript errors by chance?
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf


Antechinus

Console error message:
Uncaught ReferenceError: oQuickModify is not defined
    onclick https://www.simplemachines.org/community/index.php?topic=578824.new#new:1

SleePy

Do you have it in your html source code:
var oQuickModify = new QuickModify
Also type in the console:
window.XMLHttpRequest
Either the code is missing for some reason, or the browser isn't supporting javascript properly to do xhjr.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Antechinus

I have this (from another thread where I have just posted):

            <li class="quick_edit" id="modify_button_4102136" onclick="oQuickModify.modifyMsg('4102136', '')">
                <a href="javascript:void(0);">
                    <span class="main_icons quick_edit_button"></span>Quick Edit
                </a>
            </li>

And:
            if ('XMLHttpRequest' in window)
            {
                var oQuickModify = new QuickModify({
                    sScriptUrl: smf_scripturl,
                    sClassName: 'quick_edit',
                    bShowModify: true,
                    iTopicId: 579468,
                    sTemplateBodyEdit: '\n\t\t\t\t\t\t<div id="quick_edit_body_container">\n\t\t\t\t\t\t\t<div id="error_box" class="error"><' + '/div>\n\t\t\t\t\t\t\t<textarea class="editor" name="message" rows="12" tabindex="4">%body%<' + '/textarea><br>\n\t\t\t\t\t\t\t<input type="hidden" name="c93aa3d" value="c7b9857a7a00cae8c7f111fd4213ac77">\n\t\t\t\t\t\t\t<input type="hidden" name="topic" value="579468">\n\t\t\t\t\t\t\t<input type="hidden" name="msg" value="%msg_id%">\n\t\t\t\t\t\t\t<div class="righttext quickModifyMargin">\n\t\t\t\t\t\t\t\t<input type="submit" name="post" value="Save" tabindex="5" onclick="return oQuickModify.modifySave(\'c7b9857a7a00cae8c7f111fd4213ac77\', \'c93aa3d\');" accesskey="s" class="button"> <input type="submit" name="cancel" value="Belay That" tabindex="6" onclick="return oQuickModify.modifyCancel();" class="button">\n\t\t\t\t\t\t\t<' + '/div>\n\t\t\t\t\t\t<' + '/div>',
                    sTemplateSubjectEdit: '<input type="text" name="subject" value="%subject%" size="80" maxlength="80" tabindex="7">',
                    sTemplateBodyNormal: '%body%',
                    sTemplateSubjectNormal: '<a hr'+'ef="' + smf_scripturl + '?topic=579468.msg%msg_id%#msg%msg_id%" rel="nofollow">%subject%<' + '/a>',
                    sTemplateTopSubject: '%subject%',
                    sTemplateReasonEdit: 'Reason for editing: <input type="text" name="modify_reason" value="%modify_reason%" size="80" maxlength="80" tabindex="8" class="quickModifyMargin">',
                    sTemplateReasonNormal: '%modify_text',
                    sErrorBorderStyle: '1px solid red',
                    sFormRemoveAccessKeys: 'postmodify'
                });

Typing that code you suggested into the console yields this result:
Uncaught ReferenceError: oQuickModify is not defined
    onclick https://www.simplemachines.org/community/index.php?topic=579468.msg4102136#msg4102136:1

Kindred

Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

SleePy

Typing that code should not mention anything about oQuickModify.  Your browser should respond with something about a function existing.  Chrome responds with:
ƒ XMLHttpRequest() { [native code] }
Right now its like a extension isn't allowing that function to exist, so of course its not working.
Jeremy D — Site Team / SMF Developer
Support the SMF Support team!
Profiles:GitHub
Join us on IRC Libera.chat/#smf

Antechinus

Ok, when I get some coffee into me I'll go through disabling extensions, and see if that makes a difference.

I suspect it won't, because when I first reported this I tried it with every browser I have installed, and had the same issue with all of them, and most of them are not running any extensions at all. Still, it's an easy check for Firefox, so worth trying.

Antechinus

This seems to be fixed now. It has just started working again today. Not sure if there were site code changes involved, or if it's just eddies in the space-time continuum. Marking as solved anyway. :)

Arantor

What's Eddy doing in the space time continuum anyway?

Antechinus

He likes to hang out there. Thinks it makes him look cool.  8)

Advertisement: