• Welcome to Simple Machines Community Forum. Please login or sign up.
October 16, 2021, 11:57:40 AM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Deprecated: Directive 'allow_url_include' is deprecated in Unknown on line 0

Started by Dazed, September 13, 2021, 12:31:02 AM

Previous topic - Next topic

Dazed

So, running the stable version if I recall but after moving to a new host I get this when I attempt to view the site.

I have used the repair_settings.php file which corrects a few issues. I still have the same issue. Where can I look to resolve the issue? Is this something correctable in the database or elsewhere? Is it a host issue?

Arantor

Are you using 1.1? If so, your first step really is going to be to upgrade to 2.0... 1.1 was first released 15 years ago and is not compatible with current hosts.
No good deed goes unpunished
All helpful urges should be circumvented

Dazed

Quote from: Arantor on September 13, 2021, 03:48:17 AMAre you using 1.1? If so, your first step really is going to be to upgrade to 2.0... 1.1 was first released 15 years ago and is not compatible with current hosts.

As far as I know its a 2.0 install. I don't think there were any files older than maybe 12 months as this is a board I mess with. I'll have to dig deeper and check what php the new host has running while I'm there

Shambles

Quote from: Dazed on September 13, 2021, 11:35:05 AMAs far as I know its a 2.0 install.

You posted in the 1.1.* board, hence the confusion.

The quoted setting was deprecated at PHP7.4 apparently, so see if you can lower your version to 7.3

Arantor

Moreover I can't imagine why this setting would be relevant in 2.0 but absolutely could for 1.1...
No good deed goes unpunished
All helpful urges should be circumvented

shadav

the footer of the site should tell you which version it is
or in your admin you should see a box that says Support Information and in that box you should see Forum version: with your version there
or in your Settings.php it will at least tell you if it's a v1.x or v2.0


Dazed

Quote from: Arantor on September 13, 2021, 03:48:17 AMAre you using 1.1? If so, your first step really is going to be to upgrade to 2.0... 1.1 was first released 15 years ago and is not compatible with current hosts.

No, I misstated the version as I was not able to access the site once I changed the dns. Had to change it back to get more information.

The site was on php 7.4 which something there did not like it seems. I reverted back to 7.3 the warning went away.

Quote from: Shambles on September 13, 2021, 11:39:50 AM
Quote from: Dazed on September 13, 2021, 11:35:05 AMAs far as I know its a 2.0 install.

You posted in the 1.1.* board, hence the confusion.

The quoted setting was deprecated at PHP7.4 apparently, so see if you can lower your version to 7.3

My apologies. I had guessed at the version.

So where we are today.... I was hosted with a useless company that hasn't replied to a support ticket in months. My mistake going with the "cheaper" option. Anyway, I have done a site backup with all sites and sql databases.

My main issue NOW is that I cannot get the repair_settings tool to function properly. On the new host I got the green box at the top and as soon as I saved the changes it reverted to telling me that the database information was incorrect which it obviously was not.

So, at this point, what are my options and what do I look for?

There used to be a line that could be added to a configuration file to disable all addons which I am wondering if one is causing an issue. I could not find that line to add even though I used it in years past.

I am not sure on the best path to take at this point. I am to the point of erasing everything and starting fresh but would rather not. Ideas, suggestions, etc would be appreciated.

shadav

in the root folder of your forum make sure that the information in Settings.php are correct for your new server and database info

Dazed

With the new host I am on PHP 7.3 for this forum and all seems to be good. Is it worth going to 7.4 at this point?

shadav

unless you are using smf 2.0.18 php 7.4 will not work
also depending on what mods you have installed and how up to date they are 7.4 may not work

Dazed

Quote from: shadav on September 19, 2021, 09:45:55 PMunless you are using smf 2.0.18 php 7.4 will not work
also depending on what mods you have installed and how up to date they are 7.4 may not work

Thanks, I'll leave it where it is as I don't see much benefit and am really liking the RC version. Patience lol....

Steve

Marking solved. If you have further questions/problems regarding this topic feel free to mark it unsolved.
Please do not PM me for support.

Advertisement: