• Welcome to Simple Machines Community Forum. Please login or sign up.

Custom title overlapping avatar?

Started by truce., September 22, 2021, 06:53:07 AM

Previous topic - Next topic

truce.

Hey there! Apologies if this is vague, I'm a bit of a newbie so I'm not quite sure what I'm doing. I was wondering whether I could get some help with the placement of the custom title as it looks to be overlapping the avatar in threads. I think it may be because of the placement of the online icon as I believe it should beside the username rather than above it, but I'm not sure how to move it! I've attached an image showing what it looks like.



Any help would be appreciated, thanks ;D

Forum version: SMF 2.0.18

Arantor

What theme are you using?

Normally the online indicator should be to the left rather than above the username and that's pushed the title down into the avatar.
No good deed goes unpunished
All helpful urges should be circumvented

truce.

We're using Curve Minimal with modified stylesheets.

I'm not sure if this of any use but I tried "Admin > Features and Options > Layout > Show online/offline in posts and PMs" and unticked it, yet the absence of the online indicator didn't change the position of the title.

Arantor

No good deed goes unpunished
All helpful urges should be circumvented

truce.

www.bearbonesrp.com/index.php. The current theme on the site isn't the theme in question, though. The one with this issue is a new theme in the making to replace the current theme, but for some reason this new theme is pushing the title into the avatar. I could show the index.css stylesheets of the new theme via pastebin if that would be of any help?

shadav

without being able to see the issue on your site, we can't really offer much help, other than guessing
can you set the overall theme to the one giving you issues long enough for one of us to see the problem and try to help fix it

truce.

I've switched the default theme to the one giving me issues now! Hope that helps.

Shambles

I'm no css expert but using the inspector tools I got to this:




I simply changed the -3 to 0 using the tool:





I couldn't see that setting in your index.css file but if you look for it you may find it in a template.

shadav

yes you've hardcoded negative margins into your display.template.php
you will need to remove/change all of them
<li class="membergroup" style="margin-bottom: -3px"><li class="title" style="margin-bottom: -4px;">there maybe more but those are the 2 I saw anyways
in your display.template.php search for
margin-bottom: -and remove or change all of them

truce.

That's fantastic, I've managed to get it to work now, thank you all so much!

Advertisement: