• Welcome to Simple Machines Community Forum. Please login or sign up.

¿Me ayudan por favor con estos avatares?

Started by Luis Soto, September 22, 2021, 06:17:45 PM

Previous topic - Next topic

Luis Soto

September 22, 2021, 06:17:45 PM Last Edit: September 22, 2021, 06:44:42 PM by RockLee
Bueno, estuve intentando añadir un avatar que cuando te registres te lo de, pero tengo un problema y es que el avatar lo da pero en esta parte de el foro no lo puedo ver.

Como pueden ver en esta Imagen aquí si sale el avatar
You cannot see attachments on this board.


Como pueden ver aquí en esta parte de la Imagen, no sale el avatar, aquí es donde quiero saber como ponerlo.
You cannot see attachments on this board.

No es necesario poner una letra mas grande, normal se puede leer bien - Rock Lee

Diego Andrés

¿Cómo agregaste los otros?
Tendrías que hacer lo mismo en el Display.template.php

SMF Tricks - Free & Premium Responsive Themes for SMF.

Luis Soto

Quote from: Diego Andrés on September 22, 2021, 06:36:08 PM¿Cómo agregaste los otros?
Tendrías que hacer lo mismo en el Display.template.php

Bien pero esto es lo que tengo en el Display Témplate, lo que marque en rojo es lo que tengo, a ver si me pueden ayudar.
You cannot see attachments on this board.

Mike66

Admin - Configuration - Current Theme - Theme Options and Preferences

"Show user avatars in message view:"

Por si acaso no lo tiene marcado/aprobado?

Luis Soto

Quote from: Mike66 on September 23, 2021, 05:10:59 AMAdmin - Configuration - Current Theme - Theme Options and Preferences

"Show user avatars in message view:"

Por si acaso no lo tiene marcado/aprobado?
Osea bro si salen los avatares pero si los subo yo desde el PC en configuración del perfil del foro.
pero cuando un user se registra no le sale en los mensajes el perfil, Quiero que cuando un user se registre le Salga ese perfil bien y les sale en todas partes menos ahí, cuando escriben un mensaje o responden algo

Diego Andrés

Quote from: Luis Soto on September 22, 2021, 11:40:48 PMBien pero esto es lo que tengo en el Display Témplate, lo que marque en rojo es lo que tengo, a ver si me pueden ayudar.
You cannot see attachments on this board.

Pues eso es el código por defecto.
Por eso te mencionaba que si ya tienes el avatar en las otra áreas, es exactamente igual, asumiendo que tú hiciste eso ya que no lo mencionas. Y de no ser el caso, tampoco mencionaste que theme o mods instalaste...

Básicamente es agregar un else a ese código en el Display.template.php

else
         echo '
      <div class="avatar">
           <img src="imagen" alt="" />
       </div>';

SMF Tricks - Free & Premium Responsive Themes for SMF.

Luis Soto

Quote from: Diego Andrés on September 23, 2021, 03:01:07 PM
Quote from: Luis Soto on September 22, 2021, 11:40:48 PMBien pero esto es lo que tengo en el Display Témplate, lo que marque en rojo es lo que tengo, a ver si me pueden ayudar.
You cannot see attachments on this board.

Pues eso es el código por defecto.
Por eso te mencionaba que si ya tienes el avatar en las otra áreas, es exactamente igual, asumiendo que tú hiciste eso ya que no lo mencionas. Y de no ser el caso, tampoco mencionaste que theme o mods instalaste...

Básicamente es agregar un else a ese código en el Display.template.php

else
         echo '
      <div class="avatar">
           <img src="imagen" alt="" />
       </div>';

Listo agregue el Else, pero lo tenia que colocar atras del If o debajo del mismo, yo lo agregue debajo del IF asi

if (!empty($settings['show_user_images']) && empty($options['show_no_avatars']) && !empty($message['member']['avatar']['image']))
      else
            echo '
                        <div class="avatar">
                           <a href="', $scripturl, '/imagen/', $message['member']['avatar.png'], '">

Diego Andrés

Después

if
      contenido
else
    contenido

SMF Tricks - Free & Premium Responsive Themes for SMF.

Luis Soto

Quote from: Diego Andrés on September 23, 2021, 05:22:49 PMDespués

if
      contenido
else
    contenido

Osea coloco el ELSE, pero cuando subo el theme y entro a un post me sale error y ahora este es el codigo completo a ver si me pueden ayudar a que el avatar salga en los post, ya que es en el unico lugar donde no sale :(

// Show avatars, images, etc.?
            if (!empty($settings['show_user_images']) && empty($options['show_no_avatars']) && !empty($message['member']['avatar']['image']))
                echo '
                                <center><li class="avatar">
                                    <a href="', $scripturl, '?action=profile;u=', $message['member']['id'], '">
                                        ', $message['member']['avatar']['image'], '
                                    </a>
                                </center></li>';

Diego Andrés

Adjunta el archivo en el post para revisar.
Por cierto, la etiqueta <center> es obsoleta.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Luis Soto

Quote from: Diego Andrés on September 23, 2021, 07:19:21 PMAdjunta el archivo en el post para revisar.
Por cierto, la etiqueta <center> es obsoleta.

Aqui esta el archivo, y gracias por ayudarme :)
You cannot see attachments on this board.

Diego Andrés


SMF Tricks - Free & Premium Responsive Themes for SMF.


Diego Andrés

Debes cambiar la ruta de la imagen que tienes por defecto

SMF Tricks - Free & Premium Responsive Themes for SMF.

Luis Soto

Quote from: Diego Andrés on September 23, 2021, 08:39:49 PMDebes cambiar la ruta de la imagen que tienes por defecto
Bien en donde pusiste No avatar todo bien, en la ruta de la imagen la tengo asi
/imagenes/avatar.png
asi?

Diego Andrés

Puedes usar directamente la url de la imagen src="urlimagen.png"
Para usar la ruta de tu foro sería
src="', $settings['images_url'], '/imagen.png"
$settings['images_url'] Hace referencia a la carpeta images del theme que estés utilizando, por lo cual la imagen tendría que estar ya alojada en dicho directorio.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Luis Soto

Quote from: Diego Andrés on September 23, 2021, 08:53:32 PMPuedes usar directamente la url de la imagen src="urlimagen.png"
Para usar la ruta de tu foro sería
src="', $settings['images_url'], '/imagen.png"
$settings['images_url'] Hace referencia a la carpeta images del theme que estés utilizando, por lo cual la imagen tendría que estar ya alojada en dicho directorio.

Bien entonces el código quedaría asi no?
despues del Alt coloco el nombre de la imagen no
<img src="images_url" alt="avatar.png" />

Diego Andrés

Sí...
alt no necesariamente necesita algo, solamente proporciona un texto/descripción en caso de que la imagen no esté disponible por cualquier motivo, se puede dejar vacío.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Luis Soto

Quote from: Diego Andrés on September 23, 2021, 09:08:54 PMSí...
alt no necesariamente necesita algo, solamente proporciona un texto/descripción en caso de que la imagen no esté disponible por cualquier motivo, se puede dejar vacío.

Bien creo que te falto algo en el codigo por eso no estaba entiendo bien, mira
<img src="", $settings['images_url'], '/avatar.png' alt="" />
 yo puse este con el settings

tu pusiste asi
<img src="images_url" alt="" />

pero tengo problema en el que yo puse y es que el $settings no sale en azul y solo se queda en gris que puedo hacer?
<img src="", $settings['images_url'], '/avatar.png' alt="" />

Diego Andrés

Quote from: Luis Soto on September 23, 2021, 09:22:31 PMtu pusiste asi
<img src="images_url" alt="" />

Era solamente un ejemplo (placeholder) ya que desconozco la ruta que quieres utilizar.

Quote from: Luis Soto on September 23, 2021, 09:22:31 PM<img src="", $settings['images_url'], '/avatar.png' alt="" />

Utilizaste comillas dobles al principio, y al final colocaste simple
<img src="", $settings['images_url'], '/avatar.png' alt="" />
Debería ser
<img src="', $settings['images_url'], '/avatar.png" alt="" />

SMF Tricks - Free & Premium Responsive Themes for SMF.

Advertisement: