• Welcome to Simple Machines Community Forum. Please login or sign up.
November 28, 2021, 05:53:09 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Incorrect string value: '''' for function inet_aton in Subs.php

Started by jrbray1, September 28, 2021, 04:43:18 AM

Previous topic - Next topic

jrbray1

SMF 2.0.18 fresh install, Linux Mint, private server, after install with no problems I visited the General Discussion forum and was greeted with

Incorrect string value: '''' for function inet_aton
File: /var/www/html/testforum/Sources/Subs.php
Line: 2650

A forum search has posts about similar messages 5+ years ago has responses like https://www.simplemachines.org/community/index.php?topic=550608.msg3903635#msg3903635 which talk about editing out 'Listen [::0]:80' from httpd.conf. Its not in my apache2.conf, and it seems rather an aggressive step to do without explanation.

Arantor

SMF 2.0 doesn't support IPv6. That's what that line edits out - Apache listening on port 80 for IPv6 addresses.
No good deed goes unpunished
All helpful urges should be circumvented

jrbray1

I didn't think I was using IPv6 on a vanilla Mint 20.2 uma, but hxxp:www.linuxmint.com/rel_uma_cinnamon_whatsnew.php [nonactive] says " IPV6 DNS is now visible", and ipconfig showed
        inet6 fe80::4a05:590a:39af:610e  prefixlen 64  scopeid 0x20<link>

Using Menu/System/Preferences/Internet and Network/Advanced Network Configuration, I turned off IPv6 for my wifi connection, and SMF started working.

So it looks like you were right. Hopefully these instructions will help someone else

Arantor

Is this a localhost setup or something publicly accessible?
No good deed goes unpunished
All helpful urges should be circumvented

Advertisement: