• Welcome to Simple Machines Community Forum. Please login or sign up.

undefined function matchPackageVersion()

Started by wintstar, October 05, 2021, 05:50:40 PM

Previous topic - Next topic

wintstar

Fresh install 2.1 RC4

QuoteFatal error: Uncaught Error: Call to undefined function matchPackageVersion() in /var/www/html/smf21rc/Sources/Subs-Themes.php:275

When testing with my mod Themes Demo this error message came up. I checked if a theme with a low version is to be installed (theme-info/install/@for).


In Subs-Themes.php line 273  this should be missing:
require_once($sourcedir . '/Subs-Package.php');
Change this
// The theme isn't compatible with the current SMF version.
if (!$install_versions || !matchPackageVersion($the_version, $install_versions))
{
remove_dir($path);
fatal_lang_error('package_get_error_theme_not_compatible', false, SMF_FULL_VERSION);
}

to
// The theme isn't compatible with the current SMF version.
require_once($sourcedir . '/Subs-Package.php');
if (!$install_versions || !matchPackageVersion($the_version, $install_versions))
{
remove_dir($path);
fatal_lang_error('package_get_error_theme_not_compatible', false, SMF_FULL_VERSION);
}

This fixes the error in my test forum.
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

Sesquipedalian

Please open a bug report for this on GitHub.
I promise you nothing.
Sesqu... Sesqui... what?
Sesquipedalian, the best word in the English language.

wintstar

Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

Advertisement: