• Welcome to Simple Machines Community Forum. Please login or sign up.
December 08, 2021, 08:34:35 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Webfont Inter v3.19

Started by wintstar, October 23, 2021, 10:33:12 AM

Previous topic - Next topic

wintstar

Link to the mod

Adds the webfont Inter v3.19 to your theme.

Features
  • Font Inter can be disabled and the font size can be set in the Admin Center
  • Font size of the members can be reset in the Admin Center
  • Members can select the font size in their profile if the Inter font is enabled

Quote from: https://rsms.me/inter/Inter is a typeface carefully crafted & designed for computer screens.
Inter features a tall x-height to aid in readability of mixed-case and lower-case text. Several OpenType features are provided as well, like contextual alternates that adjusts punctuation depending on the shape of surrounding glyphs, slashed zero for when you need to disambiguate "0" from "o", tabular numbers, etc.

Changelog
v1.2
Version 1.2
Bug Undefined index: inter_fontsize_options solved.
Many thanks for reporting the error to TurtleKicker.
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

Gryzor

This looks nice. Am I the only one getting the "Although the package was downloaded to the server it appears to be empty etc etc" error?

wintstar

The SMF Customization Team has reviewed the mod and reported no bugs. So it seems that you are the first.

Probably you try to install this mod under SMF 2.0.18. Under this version you can not install this mod. This mod is to be installed only from version 2.1 RC4.

Quote from: https://custom.simplemachines.org/index.php?mod=4296COMPATIBLE WITH 2.1 RC4
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

Gryzor

Not sure why you quoted the "Compatible with 2.1 RC4" part? Is it only for the RC4? Because the mod page mentions "v1.1 1.1.21, 2.0.18, 2.1 Beta 1, 2.1 Beta 2, 2.1 RC1, 2.1 RC2, 2.1 RC3, 2.1 RC4". 

Could it this be why? I'm on 0.18 myself.

Gryzor

Egad! There's no edit button? When I posted this I didn't see your note about versions, weird, unless you edited your message...

Anyhow, as I said, the mod page does mention other versions. Unless I have the wrong understanding of the info displayed on the page...

Kindred

not sure what that info means down in the packages section
1.1.21, 2.0.18, 2.1 Beta 1, 2.1 Beta 2, 2.1 RC1, 2.1 RC2, 2.1 RC3, 2.1 RC4



but the mod info itself says: COMPATIBLE WITH 2.1 RC4
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

wintstar

1.1.21, 2.0.18, 2.1 Beta 1, 2.1 Beta 2, 2.1 RC1, 2.1 RC2, 2.1 RC3, 2.1 RC4
It is a bug of the mod page. This does not take into account the version check and thus captures all SMF versions that are specified.

This is a version check. For this SMF Version should not have to install the mod.

<install for="2.1 Beta 1, 2.1 Beta 2, Beta 3, 2.1 Beta 4, 2.1 RC1, 2.1 RC2, 2.1 RC3">
<readme lang="english" parsebbc="true" type="inline">This mod is [b]not compatible[/b] with your version of SMF, it requires 2.1 RC4.</readme>
<readme lang="german" parsebbc="true" type="inline">Diese Modifikation ist [b]nicht kompatibel[/b] mit Ihrer Version von SMF. Es erfordert 2.1 RC4.</readme>
<readme lang="german_informal" parsebbc="true" type="inline">Diese Modifikation ist [b]nicht kompatible[/b] mit deiner Version von SMF, es wird 2.1 RC4 benötigt oder höher.</readme>
</install>


SimpleDesk Mod also uses this.

Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

TurtleKicker

This looks really nice. Seems to be working fine in 2.1RC4 however I do occasionally see the following errors in the log:

https://www.***********.com/index.php?action=forum
***********/Sources/font_inter_source/Subs-FontInter.php (Line 29)  Backtrace information

Type of error: Undefined
Error messageSelect
8: Undefined index: inter_fontsize_options

wintstar

I can not understand the error. The error is triggered by messageSelect.


QuoteType of error: Undefined
Error messageSelect
8: Undefined index: inter_fontsize_options

The same trigger has also occurred here
Quote from: Shades. on July 30, 2021, 05:29:57 PM
QuoteGuest
 107.77.200.135
 c2c254de731143a3b06646e582f40b17
 https://*****.com/*****/index.php?action=profile;u=1
 /home2/*****/public_html/*****/Sources/AvatarsDisplayIntegration.php (Line 178)

Type of error: Undefined
Error messageSelect
8: Undefined index: profile_of

inter_fontsize_options is an entry in your database of the table ***_themes. Please check if the error is reported in the original SMF default theme - Curve2. I suspect that the error is triggered by a mod with the function "messageSelect" or there is an error in your additional theme.

   
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

TurtleKicker

Quote from: wintstar on November 02, 2021, 08:43:29 AMinter_fontsize_options is an entry in your database of the table ***_themes. Please check if the error is reported in the original SMF default theme - Curve2. I suspect that the error is triggered by a mod with the function "messageSelect" or there is an error in your additional theme.

It must be another mod. That will take some trial and error to pin down. I'm using the default Curve2 theme (albeit with a color-changing mod).

wintstar

I installed some of your mods from your website in a test forum. The error you reported is not reported in my test forum. What did you do before the error was reported to you?
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

TurtleKicker

Quote from: wintstar on November 02, 2021, 07:30:24 PMI installed some of your mods from your website in a test forum.
You can see a list of all my mods??? o_O

QuoteThe error you reported is not reported in my test forum. What did you do before the error was reported to you?

Not sure yet. In looking at the logs, it seems to be triggered by all sorts of things. The last time it was triggered was at 5:33pm EST.

I'm seeing:
/index.php?action=profile;area=forumprofile;u=51
/index.php?action=profile;area=popup;ajax
/index.php?
/index.php?action=likes;ltype=msg;sa=like;like=99
/index.php?action=verificationcode;vid=post
/index.php?topic=68.msg99;topicseen
/index.php?action=forum
/index.php?page=podcasts
/index.php?action=login2;sa=check;member=51

That was all from one user from 5:31-5:33
Then before him:
/index.php?action=forum
/index.php?topic=41.0
/index.php?board=2.0
/index.php?action=forum
/index.php?action=login2;sa=check;member=7

From 5:24-5:25

Before him, the last errors were from a third person around 1:56pm. It's been a while since I myself triggered it... I cleared my log mid-day today.

wintstar

QuoteYou can see a list of all my mods??? o_O
Not all, only those that are in credits => action=credits.

I think that the error is triggered by other mods.  So far I cannot reproduce the error in a freshly installed with unchanged SMF default theme - Curve2.

Did you check in the database if there is a data set with inter_fontsize_options in the table ***_themes?

1 1 inter_fontsize_options default
1 for id_member, 1 for id_theme (default: 1 for Curve2),  inter_fontsize_options for variable, default for value (Standart fontsize).
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

wintstar

Have finally been able to reproduce the error  :)

QuoteUndefined index: inter_fontsize_options

I will fix the bug and update the mod.
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

wintstar

The error is triggered when resetting the themes options for members in the admin center.

Temporary fix for the bug, go to your own profile and set the font size.

Maybe they are able to test this fix:

found fSources/ont_inter_source/Subs-FontInter.php (line 29)
    $inter_fontsize = $context['user']['is_guest'] ? $settings['inter_fontsize_settings'] : (($options['inter_fontsize_options'] == 'default') ? $settings['inter_fontsize_settings'] : $options['inter_fontsize_options']);
change to
    $set_options = ($options['inter_fontsize_options'] == 'default') ? $settings['inter_fontsize_settings'] : $options['inter_fontsize_options'];

    if (!isset($options['inter_fontsize_options']) || empty($options['inter_fontsize_options']))
        $inter_fontsize = $settings['inter_fontsize_settings'];
    elseif ($context['user']['is_guest'])
        $inter_fontsize = $settings['inter_fontsize_settings'];
    else
        $inter_fontsize = !empty($settings['inter_font_enable']) ? $set_options : $settings['inter_fontsize_settings'];

Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

wintstar

Webfont Inter v3.19 Mod updated to v1.2.

Changelog
v1.2
Bug Undefined index: inter_fontsize_options solved.
Many thanks for reporting the error to @TurtleKicker.
Regards Stephan

,,In order for the possible to come into being, the impossible must be attempted again and again."
Hermann Hesse (1877-1962)

My HomepageMy Board - My Atelier

Advertisement: