• Welcome to Simple Machines Community Forum. Please login or sign up.

Is there a primer on how to upgrade my DB to match my SMF version?

Started by rcane, December 12, 2021, 11:29:18 AM

Previous topic - Next topic

rcane

Getting an error when installing simple portals.

This will be the first time I upgrade so I'm reading around to make sure I don't miss a step or damage something.


You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FROM smfqg_sp_blocks
WHERE col = 5
ORDER BY row DESC
LIMIT 1' at line 2
File: /home/myDomain/public_html/myDomainName.com/Sources/PortalAdminBlocks.php
Line: 680

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.18, while your database is at version 2.0.17. The above error might possibly go away if you execute the latest version of upgrade.php.





    Server: Localhost via UNIX socket
    Server type: MySQL
    Server connection: SSL is not being used Documentation
    Server version: 8.0.27 - MySQL Community Server - GPL
    Protocol version: 10
    User: username@localhost
    Server charset: UTF-8 Unicode (utf8mb4)

Web server
    cpsrvd 11.100.0.5
    Database client version: libmysql - 5.6.43
    PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation
    PHP version: 7.3.33

phpMyAdmin
    Version information: 4.9.7


Doug Heffernan

There are no database changes between 2.0.17 and 2.0.18. Running the upgrader is not necessary imo. If your forum files are already at version 2.0.18. you are good. But if you want to run the upgrade for your own piece of mind, do so by all means. There is no harm in doing that.

Can you check the version value btw at the smf_settings table and see what it says?

Regarding the error, that is releated to the portal mod. Try tpost at its support topic. You can get better support there from its developers and/or co-users. Hope it helps.

rcane

This was from the smf_settings file. 

I wasn't able to get simpleportals to run the shoutbox without gettings these errors.  otherwise the forum was working well.


You cannot see attachments on this board.

Doug Heffernan

Quote from: rcane on December 12, 2021, 12:23:56 PMThis was from the smf_settings file. 

I wasn't able to get simpleportals to run the shoutbox without gettings these errors.  otherwise the forum was working well.


You cannot see attachments on this board.

As I thought. The value is stuck at 2.0.17 in the version field. You can either change that to 2.0.18 directly in the database if you want, or you can run the upgrader. That is if you files are indeed at version 2.0.18.

But personally I would recommend running the upgrader rather than editing things directly in the database, although this is a minor/fairly easy change.

You can also ignore this, because as I already mentioned above, there are no db changes between those 2 versions. The choice is yours.

Anyways, whenever you make changes to the db, is best to always make a thorough backup of it and forum files too if you have made edits to them, before you make the changes. Hope it helps.

Aleksi "Lex" Kilpinen

For the error you might want to post in the portal's own support topic to get better answers.
There is no reason to worry about the version message though, there is no need to update anything in your database.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Advertisement: