• Welcome to Simple Machines Community Forum. Please login or sign up.

Upgrade 2.1 RC4 - questions diverses

Started by bisane, December 12, 2021, 06:36:13 AM

Previous topic - Next topic

bisane

Bonjour à tous !

Je n'avais pas réussi à urgrader mon forum de la RC2 à la RC3, mais j'ai réussi sans encombres majeures à passer à la RC4.
Un problème cependant : ça bloque à l'Étape 5: Convertir les chaînes sérialisées en chaînes JSON sur la table "settings". Très curieux, car cela avait parfaitement fonctionné sur un forum de test, comportant strictement la même configuration et les mêmes tables, directement importées.
Reste que le forum semble fonctionner correctement. J'espère, en croisant les doigts, ne pas avoir de mauvaises surprises !

Cependant, inévitablement, certaines fonctionnalités ne sont plus opérationnelles, et ont pu aussi soulever d'autres questions.
Je signale au passage que j'ai dû traduire certains "morceaux" de texte, qui étaient restés en anglais, en particulier ceux concernant la connexion et la déconnexion.

1/ menu :
J'ai pu modifier les boutons et la présentation.
Je m'étonne que le "logo" connexion n'apparaisse pas, et que ce soit le point d'interrogation qui s'affiche.
Une idée pour corriger cela ?

2/ groupes additionnels :
J'avais réussi à afficher les groupes additionnels, et leurs icônes, dans les profils et sur les mini-profils qui apparaissent dans les différents topics.
J'ai réussi à faire apparaître ces derniers dans les profils grâce à ce mod : Display Additional Membergroups on Profile, mais comment affricher aussi les icônes associées ?
A noter que, là aussi, nouvelle surprise, le script fonctionne mais provoque de nombreuses erreurs, alors que ce n'est pas le cas dans la version de test, alors que les fichiers sont identiques... :o

3/ affichage des nouvelles :
   a: comment faire pour les afficher sur toutes les pages ?
   b/ comment supprimer les boutons clignotants en dessous ?

4/ calendrier :
Comment faire en sorte qu'il s'affiche sur le mois en cours et non sur la liste des événements à venir ?

5/ sitemap :
Rien à voir avec l'upgrade actuel, mais j'en profite : il fut un temps où SMF générait et actualisait un sitemap. J'ai eu beau chercher dans les mods, je n'ai rien trouvé...

J'aurai sans doute d'autres questions ! ;D
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Quote from: bisane on December 12, 2021, 06:36:13 AMUn problème cependant : ça bloque à l'Étape 5: Convertir les chaînes sérialisées en chaînes JSON sur la table "settings".
Là je reste assez dubitatif car si une erreur se produit lors de la mise à jour cela va mettre à mal le fonctionnement intégral du forum et pas seulement au niveau du settings qui lui est primordial au fonctionnement de base du forum.

Quote from: bisane on December 12, 2021, 06:36:13 AMJe signale au passage que j'ai dû traduire certains "morceaux" de texte, qui étaient restés en anglais, en particulier ceux concernant la connexion et la déconnexion.
Oui pour la RC4 si on se base sur les fichiers Smf il y a plein de choses qui ne sont pas traduites suite au passage sur une nouvelle plateforme de traduction qui pour ma part est assez indigeste alors que j'avais tout traduit.

Quote from: bisane on December 12, 2021, 06:36:13 AM2/ groupes additionnels :
Là c'est un module que j'avais mis à jour pour ta version de Smf de l'époque et depuis lors comme personne ne l'utilise dans notre entourage je n'ai plus suivi son évolution par rapport aux nouvelles versions de Smf.

Quote from: bisane on December 12, 2021, 06:36:13 AMa: comment faire pour les afficher sur toutes les pages ?
   b/ comment supprimer les boutons clignotants en dessous ?
Là c'est un de mes modules qui faisait cette fonction il existe toujours sur mon site et est mis à jour.

Quote from: bisane on December 12, 2021, 06:36:13 AMRien à voir avec l'upgrade actuel, mais j'en profite : il fut un temps où SMF générait et actualisait un sitemap. J'ai eu beau chercher dans les mods, je n'ai rien trouvé...
L'auteur du module qui apportait cette option à retiré son mod de la circulation mais tu dois toujours avoir dans tes packages celui qui fonctionnait sur ta RC2 il fonctionne toujours très bien sur la RC4.

Fais attention en faisant tes tests d'être en symbiose avec ton "Mode local" et ton "Mode exploitation" surtout au niveau de la version du Php.

Bon courage.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Hello, Max ! :)

Quote from: maximus23 on December 12, 2021, 08:46:33 AMje reste assez dubitatif
Moi aussi, mais je t'assure que ça fonctionnait bien, à part les erreurs évoquées.
Mais n'étant moi-même pas très satisfaite, je suis à nouveau repartie de zéro, et là, miracle, ça a fonctionné jusqu'au bout !
Les erreurs, quant à elles, persistent, générées également par le Cookie Consent.
C'est énervant... :P

Quote from: maximus23 on December 12, 2021, 08:46:33 AMFais attention en faisant tes tests d'être en symbiose avec ton "Mode local" et ton "Mode exploitation" surtout au niveau de la version du Php.
Je n'ai pas à faire attention à cel : je ne suis jamais parvenue à installer le site en local. Je fais donc les tests en grandeur nature sur le serveur, et bien sûr avec la même configuration.
C'est d'autant plus inexplicable.

2/ reste que si on parvient à afficher un groupe additionnel, on doit aussi pouvoir faire apparaître son icône sans trop de difficulté, non ?

3/ m'en occuperai demain ou plus tard : je sature, là...

5/ pas très convaincants, les mods testés...

6/ Très embêtant !!!
Quand je souhaite ajouter une date au calendrier différente de celle de ce jour, ça ne fonctionne pas ! Ca indique "date invalide".
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

Personne n'a une idée ?

En fait, il semble que toute installation de mods induise des erreurs. Résultat, je les ai quasiment tous supprimés, y compris "News any pages", qui donne lieu à ceci (et pas seulement à des erreurs signalées dans le journal) sur toutes les pages :
Fatal error:  Uncaught Error: Call to undefined function
newsfader() in
/home/clients/0ffeda41a2a2e77746dfb788ded5d8f3/web/Themes/default/index.template.php:394
Stack trace:
#0
/home/clients/0ffeda41a2a2e77746dfb788ded5d8f3/web/Sources/Load.php(2702):
 template_body_above()
#1
/home/clients/0ffeda41a2a2e77746dfb788ded5d8f3/web/Sources/Subs.php(3896):
 loadSubTemplate('body_above', true)
#2
/home/clients/0ffeda41a2a2e77746dfb788ded5d8f3/web/Sources/Subs.php(3483):
 template_header()
#3 /home/clients/0ffeda41a2a2e77746dfb788ded5d8f3/web/index.php(190):
obExit(NULL, true, true)
#4 {main}
  thrown in /home/clients/0ffeda41a2a2e77746dfb788ded5d8f3/web/Themes/default/index.template.php on line 394

Je rappelle aussi que cette question est de la plus haute importance pour notre forum :
Quote from: bisane on December 12, 2021, 03:21:12 PM6/ Très embêtant !!!
Quand je souhaite ajouter une date au calendrier différente de celle de ce jour, ça ne fonctionne pas ! Ca indique "date invalide".
Et là, je ne sais même pas où il faut aller chercher d'où provient l'erreur... :(
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Pour mes modules des milliers de downloads et rien en retour actuellement.

Quand tu installes un mod il indique que tout est ok ? il ne marque rien de spécial pour l'installation ?

Pour la date oui je viens de regarder elle doit se trouver au format US pour être acceptée. Je pensais ce bug résolu depuis longtemps mais je vois qu'il existe toujours.

Je vais voir ce qu'on en dit et voir si une modification a été faite car pas mal de choses ont été modifiées sur la version github.

Je suppose que tu as bien pris la RC4 officielle pas celle sur github actuellement ?

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Quote from: maximus23 on December 15, 2021, 03:26:08 PMpas celle sur github actuellement ?
Je ne sais même pas ce que c'est ! :P

Je crois que je vais repartir de zéro pour toutes les modifs !
Mais quand j'aurai un peu de temps devant moi...

Pour le calendrier, j'attends de tes nouvelles !
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

Quote from: bisane on December 16, 2021, 02:28:45 PMPour le calendrier, j'attends de tes nouvelles !
UP ! :P

Aucune explication ou idée pour le 1/ ?

Découverte du jour :
7/ Citer :
Si l'on cite un message précis, ça fait un simple "citer", contrairement à ce qui se passe ici, alors que "citation de" figure bien dans le texte lorsque l'on poste.
C'est presqu'aussi embêtant pour nous que le calendrier, puisque l'on cite souvent des messages d'autres topics.

8/ Subs.php ligne 2013 :
Cette ligne indique ceci (8: undefined offset: 0) :
$data = $sizes[$data] . 'em';Elle provoque un erreur, que je ne comprends pas, dans un topic, qui met des plombes à s'afficher (https://forum-entraide-surendettement.fr/index.php?topic=29733.0) et parfois dans la recherche.
Y a-t-il un moyen de corriger cela ?
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Pour 7/8 :

Tu es certaine de ta version de Php tu es bien sur une version intermédiaire tel que 7.2 ?

em existe dans les bbcodes.

Sinon tu as peut-être une erreur dans le message édite le et regarde en mode Source si tu n'as pas ce genre de truc dans la structure du message et effaces le, le cas échéant..

Pour le 1 : Tu passes faire un tour sur mon site tout y est déjà détaillé.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

PHP 7.2.
L'hébergeur me dit d'ailleurs que cette version est obsolète.
Comment est-il possible de changer cela ?

Quote from: maximus23 on December 19, 2021, 12:31:22 AMem existe dans les bbcodes.
Oui, ça, je sais bien ! :P
Ca ne m'explique pas comment cela peut produire une erreur rendant un fil inaccessible...
Je ne vois rien de particulier dans la source, non.

Toujours en attente pour les autres questions...
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonsoir,

Quote from: bisane on December 19, 2021, 03:58:23 AMToujours en attente pour les autres questions...

Tu as tout ce que tu as demandé sur mon site :)

Dis moi qu'il te manque :)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Sur ton site, pas le "cookie consent".


1/ menu :
Comment afficher le bouton connexion et non le point d'interrogation ?

4/ affichage du calendrier sur le mois en cours

7/ problème des citations non résolu.

Le 8 a entraîné une question sur la version PHP, et tu n'as pas répondu à ceci :
Quote from: bisane on December 19, 2021, 03:58:23 AMComment est-il possible de changer cela ?
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

Oh, et j'en ajoute une 9ème ! :P 8)

9/ lorsque les forumeurs ajoutent une pièce jointe, la plupart du temps, une ligne [attach id=xxx nomdufichier] apparaît dans le message.
Comment éviter cela ?
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonsoir,

Quote from: bisane on December 19, 2021, 01:37:10 PMSur ton site, pas le "cookie consent"
Je mettrai le mien ce soir car celui que j'avais sous la main n'était pas un de mes modules :)

Quote from: bisane on December 19, 2021, 01:37:10 PMproblème des citations non résolu.
Là je ne vois pas car sur tous mes sites je n'ai jamais eu ce problème je vais regarder dans les bugs pour voir on ne sait jamais.

Quote from: bisane on December 19, 2021, 01:37:10 PMLe 8 a entraîné une question sur la version PHP, et tu n'as pas répondu à ceci :
QuoteComment est-il possible de changer cela ?
Pour le moment tu laisses tel quel cela t'évitera bien des problèmes et cette version est encore loin d'être obsolète.

Quote from: bisane on December 19, 2021, 01:37:10 PM4/ affichage du calendrier sur le mois en cours
Tu as cela sur les évènements ou le simple calendrier du menu ?

Quote from: bisane on December 19, 2021, 01:55:27 PM9/ lorsque les forumeurs ajoutent une pièce jointe, la plupart du temps, une ligne [attach id=xxx nomdufichier] apparaît dans le message.
Comment éviter cela ?
Tu devais avoir un mod concernant les fichiers joints pour les positionner dans le message.
Je ne sais plus le nom du mod par coeur regarde dans tes Packages.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Quote from: maximus23 on December 19, 2021, 02:01:13 PMJe mettrai le mien ce soir
Vu ! Merci ! ;)
Et installé. Mais ça plante !!! >:( >:( >:(
Erreur index.template.php ligne 484 : celle où se trouve le renvoi vers le script.
Et au moment de désinstaller, ça me dit que le script n'existe pas (cookieconsent.latest.min.js), alors qu'il existe bel et bien !
Ca m'a fait la même chose pour un autre script associé à un mod, que j'ai également dû désinstaller.
C'est incompréhensible ! ::) ::) ::)

Pour le 4/, c'est quand on clique sur le bouton calendrier que je voudrais que la page s'affiche sur le mois et non sur la liste d'événements.

Quote from: maximus23 on December 19, 2021, 02:01:13 PMTu devais avoir un mod concernant les fichiers joints pour les positionner dans le message
Pas du tout... :P
Il est en effet possible de le faire, mais sur demande.
Je n'ai strictement rien touché de ce côté-là.
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Quote from: bisane on December 20, 2021, 04:44:37 AMEt installé. Mais ça plante !!!
J'ai corrigé la version pour le fichier donc essaye le pour voir ce qu'il en est :)
Donc repasse prendre le nouveau fichier.

Quote from: bisane on December 20, 2021, 04:44:37 AMPas du tout... :P
Il est en effet possible de le faire, mais sur demande.
Je n'ai strictement rien touché de ce côté-là.
Alors les fichiers sont manquants ce qui est normal que tu aies cette indication dans le message.

Lors de ta mise à jour la base de donnée n'a pas trouvé les fichiers attachés y étant relié.

Donc tu as du faire un test mais sans les répertoires complets des fichiers attachés.

Ne fait surtout pas le test sur tes fichiers attachés de production.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Max, tu ne prends pas bien le temps de me lire ! :) 

Je ne dis pas que les pièces jointes ne s'affichent pas (je connais bien le problème de celles qui ont disparu... :P ).
Je demande comment éviter qu'un message de ce type [attach id=xxx nomdufichier] n'apparaisse, en plus, dans le corps du message lui-même !

Ca semble être ok pour le Cookie Consent...
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonsoir,

Si j'ai bien lu ne t'inquiète pas.  ;D

Si la balise apparaît c'est qu'elle n'est pas suppléé par l'image.

Maintenant si on retire ces balises via une requête sql ce sont tous les fichiers impactés dans les messages qui ne s'afficheront plus.

Je n'ai jamais regardé du côté de la maintenance si ce genre de purge existe je n'utilise pas les fichiers attachés.

Cette balise permet quand même la mise en page du message en positionnant l'image dans le texte.

Donc la mettre hors service en retirant la fonction d'insertion ne serait pas une bonne solution non plus mais on peut le faire.

:)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Quote from: maximus23 on December 20, 2021, 11:18:53 AMSi j'ai bien lu ne t'inquiète pas.  ;D
Ben bon, t'as pas bien lu...
Quote from: bisane on December 20, 2021, 10:38:13 AMJe demande comment éviter qu'un message de ce type [attach id=xxx nomdufichier] n'apparaisse, en plus, dans le corps du message lui-même !
Les PJ sont bel et bien présentes !
Et si j'enlève ce texte dans le message, la PJ reste bien présente.

Quote from: maximus23 on December 20, 2021, 11:18:53 AMCette balise permet quand même la mise en page du message en positionnant l'image dans le texte.
Pas du tout ! Elle s'affiche telle quelle.

J'essaie dans un message suivant avec un autre navigateur, pour voir si ça le fait, que tu aies un exemple.
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

.You cannot see attachments on this board.
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

Bah, ça ne le fait pas...  :P
Dès que j'ai de nouveau le problème sur le forum, je fais une copie d'écran.
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

Quote from: maximus23 on December 20, 2021, 11:18:53 AMSi la balise apparaît c'est qu'elle n'est pas suppléé par l'image.
Alors... pas tout à fait !
Je viens de faire le test.
Si on supprime un fichier joint, alors qu'on l'avait inséré dans le message, cela affiche : Aucun message n'est associé avec ce fichier


Mais j'en reviens à ma désormais question principale...
Comment faire pour que les citations apparaissent de manière complète, à savoir avec le lien vers le message cité et son auteur ?
Quelqu'un pourrait-il au moins avoir l'amabilité de me dire dans quel fichier cela "se passe" ?
Je ne vois rien dans post-template (normal, en fait...) ni dans subs.php.
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonsoir,

C'est des fichiers JavaScripts qui se trouvent dans thèmes/scripts.

Il faut regarder sur Github si tu vois des modifications concernant les citations et les reporter le cas échéant pour corriger cela.

Pour le moment je suis sous Smartphone donc je ne sais voir cela en détail.

Je te souhaite une bonne fête de fin d'année car je serai absent un petit moment.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

Quote from: bisane on December 29, 2021, 03:42:02 AMMerci, Max ! ;)
Je regarde ça...
Rien trouvé de concluant...

Quote from: maximus23 on December 28, 2021, 01:23:02 PMIl faut regarder sur Github
Je répète que je ne sais pas ce que c'est, ni où c'est ?


Nouveau problème avec les dates...
Je n'ai pas signalé, mais l'affichage en toutes lettres des dates n'est guère pratique ni facile à corriger.
Mais, plus embêtant : depuis quelques jours, l'intégralité des anniversaires du forum s'affiche sur la page d'accueil et quand on ouvre le calendrier !!!
C'est un peu encombrant... :-\ :-\ :-\
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Quote from: bisane on December 31, 2021, 03:10:42 AMJe répète que je ne sais pas ce que c'est, ni où c'est ?
https://github.com/SimpleMachines/SMF2.1/milestones

Quote from: bisane on December 31, 2021, 03:10:42 AMMais, plus embêtant : depuis quelques jours, l'intégralité des anniversaires du forum s'affiche sur la page d'accueil et quand on ouvre le calendrier !!!
Réglage en Admin => Forum => Calendrier => Réglages

Quote from: bisane on December 31, 2021, 03:10:42 AMJe n'ai pas signalé, mais l'affichage en toutes lettres des dates n'est guère pratique ni facile à corriger.

Réglage dans Admin => Réglage si c'est pour le format général des dates.

Si c'est pour le calendrier dans les réglages du calendrier en format court.

:)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Heu... Max, tu me prends pour une quiche, ou tu ne me lis pas ?
La question ne porte sur l'affichage des anniversaires d'une manière générale, mais sur le fait que tous les anniversaires s'affichent en même temps, au 1er janvier.
Il s'agit bien d'un bug, non d'un quelconque réglage...

Les réglages du format de date, c'est pour l'affichage dans le forum.
Je parle, moi, de ce qui s'affiche au moment d'ajouter un événement au calendrier.
Cela a été modifié suite à ce bug :
Quote from: maximus23 on December 15, 2021, 03:26:08 PMPour la date oui je viens de regarder elle doit se trouver au format US pour être acceptée. Je pensais ce bug résolu depuis longtemps mais je vois qu'il existe toujours.
Jamais, auparavant, la date ne s'était affichée en toutes lettres.

Bonne fin d'année à tous ! :)
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Je réitère ma réponse pour la date ou quel soit forum ou calendrier. Voir Capture en bas :)

Si tu mets dans les réglages généraux : %d %m %Y à %T tu auras la date en format numérique tel que 31 12 2021 et si tu changes de format par exemple %d %B %Y à %T tu auras le mois en entier 31 Décembre 2021.

Pour régler la date dans les évènements on a le DatePicker ce qui permet de sélectionner directement la date dans le calendrier qui s'affiche pour le début et la fin donc le format n'a pas grande importance.

Dernière chose en ce qui concerne le format de date chaque membre sait le définir dans son profil également.

Quote from: bisane on December 31, 2021, 12:17:02 PMLa question ne porte sur l'affichage des anniversaires d'une manière générale, mais sur le fait que tous les anniversaires s'affichent en même temps, au 1er janvier.

On peut dire que c'est un bug ou pas car c'est tous les membres qui n'ont pas mis de date dans leur profil ou qui ne l'ont pas mis à jour. C'est pour cela que je t'ai dis de le désactiver dans tes réglages pendant 2 jours si tu veux.

Bonne fête de fin d'année.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Quote from: maximus23 on December 31, 2021, 01:27:20 PMPour régler la date dans les évènements on a le DatePicker ce qui permet de sélectionner directement la date dans le calendrier qui s'affiche pour le début et la fin donc le format n'a pas grande importance.
Ca en a une pour moi (nous) ! :P
Quand tu veux changer d'année, c'est plus pratique de la taper dans la case qui s'affiche, ce qui est quasiment impossible en la circonstance.

Quote from: maximus23 on December 31, 2021, 01:27:20 PMC'est pour cela que je t'ai dis de le désactiver dans tes réglages pendant 2 jours si tu veux.
Heu... non, tu ne l'as pas dit, ça. Tu l'as peut-être pensé ! ;D
C'est tout de même bizarre qu'un calendrier, qui est censé afficher des "événements" enregistrés, se prenne à afficher tous ceux qui ne le sont pas au 1er janvier ! ??? ::)
Tu n'appelles pas ça un bug : dont acte ! :)
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

Je reviens sur mes citations... (rien trouvé de tel dans le github, que j'ai parcouru malgré mon anglais très perfectible).

En fait, il semble y avoir un bug entre l'affichage "normal" et celui où on affiche la source, et donc la manière dont le message est ensuite envoyé.
Je crois que je vais avoir beaucoup de mal à m'expliquer, alors je le tente en images :

Citation en mode normal :
You cannot see attachments on this board.

Ce qui donne une fois posté :
You cannot see attachments on this board.

Et après passage en mode "afficher la source" :
You cannot see attachments on this board.

Citation en mode "afficher la source" :
You cannot see attachments on this board.
Là, c'est ok !
Mais si on repasse en mode "normal", retour au 1er exemple.

Ca peut donner des pistes de solutions ?
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Quote from: bisane on January 02, 2022, 12:31:52 PMC'est tout de même bizarre qu'un calendrier, qui est censé afficher des "événements" enregistrés, se prenne à afficher tous ceux qui ne le sont pas au 1er janvier !

Voici un correctif pour les dates erronées ou manquantes :

https://github.com/SimpleMachines/SMF2.1/commit/50108b94c316bf4f69f8689dc19d9bc0f944fa06

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Ca marche pô... :(

 Parse error: syntax error, unexpected 'db_query' (T_STRING), expecting ',' or ')' in /home/clients/0ffeda41a2a2e77746dfb788ded5d8f3/web/Sources/Subs-Calendar.php on line 40

De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

maximus23

Bonjour,

Code testé et pas la moindre erreur.

Mets ton fichier je regarderai si tu veux.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Voilà le fichier...

Je suis quand-même beaucoup plus embêtée avec le problème des citations... :( :'(
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Sur Github les modifications se présentent avec un + et avec un -

Quand tu as un moins il faut supprimer le code.

Quand tu as un plus il faut ajouter le code.

En dehors de ces deux signes il ne faut rien modifier.

Ci-dessous le fichier corrigé plus deux autres fichiers en js pour les citations à tester.

Ils finissent par un underscore que j'ai mis pour ne pas écraser tes fichiers originaux donc retire le.

Ils se mettent dans scripts de ton thème par défaut.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Merci, Max ! :)

Pardon de revenir si tard, mais la semaine a été chargée ! :P

Quote from: maximus23 on January 03, 2022, 08:01:16 PMSur Github les modifications se présentent avec un + et avec un -
Merci pour l'explication !
Sauf que mon fichier ne ressemblait guère à celui cité...
Je le mets en PJ.
Le tien fonctionne, en tout cas !!! :)

Et ça fonctionne aussi pour les citations !!! Ouf !!!
Mais si je pouvais savoir ce que tu as modifié, histoire de comprendre... :P
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

Toutes les modifications viennent de GitHub et si tu veux voir la différence des modifications apportées tu fais une comparaison des deux fichiers.

Je ne sais pas t'aider plus avant mardi car mon pc principal est en phase de transformations.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

C'est l'histoire d'un forum où la résolution d'un problème en entraîne un nouveau... :P

Sur le quotedText.js, je ne comprends pas les 2 autres corrections, mais ok pour "supprimer les sélections précédentes".
Reste le mini problème que la sélection de droite à gauche fonctionne mal, mais ce n'est pas bien grave.
Je ne vois rien en tout cas qui ait quelque chose à voir avec le problème des citations évoqué.

Pour le jquery.sceeditor.smf.js, j'ai cru comprendre que les lignes 853 et suivantes + celles qui en découlent ont résolu le problème des "liens" vers les citations (auteur, date et heure).
Je ne comprends en revanche pas du tout les manips sur les mailto, url et iurl (au passage, je n'ai toujours pas compris ce qu'est une IURL ni son intérêt...).
Il semble en tout cas qu'elles aient produit le problème suivant, embêtant lui aussi, car obligeant à multiplier des manipulations inutiles : si l'on copie un texte qui inclue un lien, celui-ci ne se colle plus ! Il faut donc retourner au texte copié pour copier le lien et ensuite l'insérer sur le texte collé.
Comme ici, au demeurant... Mais ça, ça ne m'arrange pas du tout, du tout ! :P :(
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

alexetgus

Salut,

URL ouvre un lien dans un nouvel onglet.
IURL ouvre un lien dans l'onglet actuel.

C'est pratique selon que l'on a des liens externes et/ou internes au site. ;)

bisane

Merci pour l'explication, Alex ! :)

Je reste en panne avec ma copie de textes/liens... :P
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Heu, Max, si je puis me permettre : je ne cherche pas à devenir une spécialiste des iurl ! :P
Le problème est survenu suite au changement de jquery.sceeditor.smf.js que tu as suggéré pour résoudre le problème des citations qui ne citaient pas leurs sources et pour lequel il me semble que des modifications ont été apportées qui n'ont rien à voir avec le problème décrit !
Mais comment faire le tri dans ces différentes modifications ? Au doigt mouillé ?
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Bonjour,

On est toujours sur des RC donc des bugs quoi que l'on fasse il y en aura toujours tant que toutes les solutions ne sont pas pas adaptées on en corrige une pour peut-être en provoquer une autre.

Tu peux tester la version du jour : https://www.simplemachines.org/community/index.php?topic=558451.0

C'est une version ou les corrections apportées sont mises en place une par une au fur et à mesure de leur validation.

Cette version n'est pas dite stable juste pour tests mais tu pourras voir si tous les bugs que tu as actuellement sont corrigés.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

On s'est croisés ! :P

Et je reviens donc à ceci :
Quote from: bisane on January 12, 2022, 02:25:56 PMJe ne comprends en revanche pas du tout les manips sur les mailto, url et iurl (au passage, je n'ai toujours pas compris ce qu'est une IURL ni son intérêt...).
J'ai donc supprimé toutes les modifications ce qui ne me semblaient pas être en rapport direct avec le problème des citations et... ça marche !!!! Ouf !!!

Je précise que ce n'est quand-même pas évident à "suivre", je pense même pour quelqu'un d'un peu plus doué que moi en codage...
Je regarde cependant ton lien de ce pas... en rappelant que je suis une quiche en anglais !
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

bisane

J'ai parcouru...
Je ne vois pas très bien à quoi ça peut me servir...
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

maximus23

Quote from: bisane on Yesterday at 01:39:05 PMJe ne vois pas très bien à quoi ça peut me servir...
Cela te permet d'avoir un suivi des versions en cours.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Oui... mais, concrètement, ça ne me sert pas à grand chose ! :P

Nouveauté du matin...
Lorsqu'un membre n'a pas activé son compte, un lien d'activation apparaît dans son profil.
Ben si je clique dessus, il ne se passe rien d'autre qu'un renvoi vers la page "en attente d'approbation".
Là, il est possible de contourner le problème, donc pas très gênant pour moi, mais un bug à peut-être signaler.
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

Advertisement: