News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Issues with alerts

Started by chadon, March 12, 2022, 07:34:19 PM

Previous topic - Next topic

Aleksi "Lex" Kilpinen

Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

chadon

Ahhhhhh!!! I received an alert for your "lets try".

I will try that on my forum. Thanks Aleksi.

Aleksi "Lex" Kilpinen

Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

FrizzleFried

Oh,  and to add to the pile...

Yesterday I posted a post that got 7 likes during the day (that is what is reported on the post).

Any idea why in my ALL ALERTS section I only show... 2?

Seems ... wrong to me...


Arantor

If you visited the topic in the meantime the alerts would have been marked as read because my little patch isn't installed here so visiting the topic marks them read automatically. Check your 'all alerts' page for them.
Perhaps it would have been better if I'd simply never bothered. Y'all clearly would be less unhappy that way.

FrizzleFried

That is what I mean... my ALL ALERTS page has 2 entries ... total ... for likes on that post...

This is my ALL ALERTS page for yesterday.  There was one more that is not included on this image that fell below but had nothing to do with the post in question.  Note only TWO "likes" for that post.




FrizzleFried

FWIW... your "fix" for my forum "fixes" this issue as well.  Since I implemented that fix I have gotten exactly ZERO complaints on the matter.

Crazy,  huh?   That (fixed) behavior is EXACTLTY what my users were used to and expecting.

:)

chadon

Quote from: chadon on May 21, 2022, 09:40:26 AMAhhhhhh!!! I received an alert for your "lets try".

I will try that on my forum. Thanks Aleksi.
I tried the same settings on my forum and I still don't receive any alert.

shawnb61

Quote from: chadon on May 21, 2022, 10:58:32 AM
Quote from: chadon on May 21, 2022, 09:40:26 AMAhhhhhh!!! I received an alert for your "lets try".

I will try that on my forum. Thanks Aleksi.
I tried the same settings on my forum and I still don't receive any alert.

Are you receiving no alerts at all?  Or only a subset of expected alerts?

As noted above, there are some measures to avoid alert spam.  E.g., it will try not to send dupes if you have unread alerts.  Also, it will try not to send alerts if it knows you have read the thread up to that point.  E.g., if you have a thread open, and are wondering why you're not getting alerts for updates to that thread, it's because you're already looking at it.  For a good test, you need to be browsing elsewhere.

Alerts are intended to bring your attention to updates in a thread you were interested in that you might have missed.  The alerts are not a log of all updates to that thread.  (The thread itself is the log of all updates to the thread...)
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

chadon

Quote from: shawnb61 on May 21, 2022, 02:01:58 PMAre you receiving no alerts at all?
I deleted all read alerts after I updated from 2.1.1 to 2.1.2 and I didn't receive a single one since.
No other members of the forum have reported receiving alerts either. To my knowledge, they all have the same problem as me.


shawnb61

Quote from: chadon on May 21, 2022, 02:09:24 PM
Quote from: shawnb61 on May 21, 2022, 02:01:58 PMAre you receiving no alerts at all?
I deleted all read alerts after I updated from 2.1.1 to 2.1.2 and I didn't receive a single one since.
No other members of the forum have reported receiving alerts either. To my knowledge, they all have the same problem as me.

Were you receiving alerts before then?  When you say you deleted them, where/how did you delete them?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

chadon

Before the update, I didn't receive alerts for replies to subscribed topics but I did receive them for "likes" "quoted messages" and things like that.
I deleted them from this page :
/index.php?action=profile;area=showalerts
by using the "DELETE ALL READ ALERTS" button.

chadon

Also, before the 2.1.2 update, I had complaints about alerts not working when users had too many of them and it worked again after they used the "DELETE ALL READ ALERTS" button.

shawnb61

Can you look in the DB and see if there are records in the smf_background_tasks table?  How many are there?

More questions:
 - Any errors in the error log?
 - Any errors in your apache log?
 - PHP version?
 - MySQL version?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

chadon

A lot. I have 64 pages of 25 rows each.

shawnb61

OK, so the plumbing is clogged somehow...  Them there are undelivered alerts.

I snuck this in earlier, you may have missed it...
Quote from: shawnb61 on May 21, 2022, 02:32:10 PMMore questions:
 - Any errors in the error log?
 - Any errors in your apache log?
 - PHP version?
 - MySQL version?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

chadon

Quote- Any errors in the error log?
7 errors since the last 24h but nothing rekated to that. They are mostly permission issues or bad passwords

Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- Any errors in your apache log?
I'm not sure how to read them.
From the "errors" feature on cPanel, the "Latest web server error log messages" are from the 10th of May but there are a lot of them.

Should I paste them here ?

shawnb61

Quote from: chadon on May 21, 2022, 02:53:15 PM
Quote- Any errors in the error log?
7 errors since the last 24h but nothing rekated to that. They are mostly permission issues or bad passwords

Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- Any errors in your apache log?
I'm not sure how to read them.
From the "errors" feature on cPanel, the "Latest web server error log messages" are from the 10th of May but there are a lot of them.

Should I paste them here ?

Yes.  Generally, you should try to 'anonymize' them, so we don't see forum internal paths, etc. 
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

chadon

I forgot that:
Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- PHP version?
PHP Version    7.4.29

Quote from: shawnb61 on May 21, 2022, 02:40:10 PM- MySQL version?
Version    mysqlnd 7.4.29

chadon

I see on some of the errors that php 8 was used and that's because i did some tests that day to see if it would work better under php 8.

Quote[Tue May 10 21:22:06.416598 2022] [cgi:error] [pid 16015] [client 207.46.13.4:20864] AH01215: PHP Fatal error:  require_once(): Failed opening required '/home/xxxx/public_html/fr/Sources/PrettyUrls-Filters.php' (include_path='.:/opt/cpanel/ea-php74/root/usr/share/pear') in /home/xxxxx/public_html/fr/Sources/QueryString.php on line 769: /usr/local/cpanel/cgi-sys/ea-php74
[Tue May 10 14:01:22.896256 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215:   thrown in /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php on line 1027: /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.895730 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #5 /home/xxxx/public_html/fr/Sources/Session.php(187): smf_db_insert('replace', 'smf_sessions', Array, Array, Array): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.895406 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #4 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(802): smf_db_query('', '\\n\\t\\t\\tREPLACE INT...', Array, Object(mysqli)): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.895040 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #3 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(494): smf_db_error('\\n\\t\\t\\tREPLACE INT...', Object(mysqli)): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.894709 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #2 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(590): log_error('Erreur de base ...', 'database', '/home/xxxx/p...', 187): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.894344 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #1 /home/xxxx/public_html/fr/Sources/Errors.php(129): smf_db_error_insert(Array): /usr/local/cpanel/cgi-sys/ea-php80, referer: https://www.mustangv8.com/fr/index.php
[Tue May 10 14:01:22.894110 2022] [cgi:error] [pid 16369] [client 194.230.158.47:50756] AH01215: #0 /home/xxxx/public_html/fr/Sources/Subs-Db-mysql.php(1027): mysqli_stmt_bind_param(false, 'iissssssis', 17991, 1652184082, 'c2e69e2f', '?pretty;action=...', 'Erreur de base ...', '396c5cfc3fcbf1f...', 'database',
 

Advertisement: