Strange issue when trying to use the package manager to install a mod -SMF 2.1.1

Started by melcon, March 04, 2022, 06:18:32 AM

Previous topic - Next topic

Steve

Please do not PM me for support.

melcon

Quote from: Doug Heffernan on April 21, 2022, 05:33:39 AM
Quote from: melcon on April 21, 2022, 02:30:43 AM#php_flag display_errors offI can't remember why this line is there, we've been running SMF since version 1 so probably some historical reason.

That is to disable PHP Error Reporting. If I were you, I would switch php error reporting back on. Are you on a shared hosting or do you manage your own dedicated/vps box?

This issue that you are getting while installing a mod, does it happen only when performing that particular action or do you get it when you perform other actions too?

Did the error pop up immediately after you upgraded to Smf 2.1.1. or did you do some modification to your forum/server prior to that?
The issue only occurs when performing that particalur action, all other functionality works as expected.
The php flag is commented out (as Steve noted), I will just remove the entire line to be sure. We are on shared hosting.

Doug Heffernan

Quote from: melcon on April 25, 2022, 09:01:47 AMThe issue only occurs when performing that particalur action, all other functionality works as expected.
The php flag is commented out (as Steve noted), I will just remove the entire line to be sure. We are on shared hosting.

Can you try something? Go to the Package Manager->Options and uncheck the following option: "Create a backup of key SMF files whenever a package is installed or uninstalled."

I saw it on another topic that doing that helped. Hopefully it will work for you too.

melcon

Sounded like a good tip! Just tried it and leads to the same result unfortunately.

Advertisement: