Upgrade 2.1.1 Server has not responded for 30 Sec

Started by Alpay, April 28, 2022, 05:40:47 AM

Previous topic - Next topic

Alpay

Hello,
   2.0.19 to 2.1.1 Upgrade error..

"Adding support for alerts" (15 --> 71)
Server has not responded for 30 seconds. It may be worth waiting a little longer before trying again.

php.ini => max_execution_time=259200

xampp: php : 7.4.29

----
Edit:
upgrade.php

 * The maximum time a single substep may take, in seconds.
 *
 * @var int
 */
$timeLimitThreshold = 6;

600 sec.
the result is still the same..


how can i fix it ?

Alpay

Updating old values...done
Changing default values...done
Removing all karma data, if selected...done
Emptying error log, if selected...done
Adding login history...done
Copying the current package backup setting...done
Copying the current "allow users to disable word censor" setting...done
Converting collapsed categories...done
Parsing board descriptions and names...done
Dropping "collapsed_categories"...done
Adding new "topic_move_any" setting...done
Adding new "enable_ajax_alerts" setting...done
Adding new "alerts_auto_purge" setting...done
Adding new "minimize_files" setting...done
Collapse object...done
Adding new "DEFAULTMaxListItems" setting...done
Adding new "loginHistoryDays" setting...done
Enable some settings we ripped from Theme settings...done
Adding new "httponlyCookies" setting...done
Adding new "samesiteCookies" setting...done
Disable Moderation Center Security if it doesn't exist...done
Disable Moderation Center Security if it doesn't exist...done
Adding new profile data export settings...done
Adding settings for marking boards as read...done
Adding more space to the mime_type column...done
Converting legacy attachments...done
Note attachment conversion complete...done
Fixing invalid sizes on attachments...done
Fixing attachment directory setting...done
Adding new columns to log_group_requests...done
Adjusting the indexes for log_group_requests...done
Adding support for tag in package manager...done
Adding support for package hashes...done
Adding support for validation servers...done
Add Package Validation to Downloads Site...done
Ensure The Simple Machines Customize Site is https...done
Add validation to Simple Machines Customize Site...done
Altering the session_id columns...done
Adding new columns to topics ...done
Adding a new column "callable" to scheduled_tasks table...done
Adding new scheduled tasks...done
Adding a new task-related setting...done
Remove old tasks added by modifications...done
Adding the new table...done
Adding new columns to boards...done
Adding the boardindex_max_depth setting...done
Removing manage_boards permission...done
Adding new columns to categories...done
Adding the count to the members table...done
Adding the new table for alerts...done
Adding alert preferences...done

Server has not responded for 30 seconds. It may be worth waiting a little longer before trying again.

Kindred

Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Alpay

Quote from: Kindred on April 28, 2022, 08:34:20 AMSo, did you wait?

Yes :) ... the result is still the same..

upgrade.php > $timeLimitThreshold = 240;  >>>> waiit.. waiittt.... the result is still the same..

Adding alert preferences...done

Server has not responded for xxx seconds. It may be worth waiting a little longer before trying again.


Doug Heffernan

Quote from: Alpay on April 28, 2022, 09:35:37 AM
Quote from: Kindred on April 28, 2022, 08:34:20 AMSo, did you wait?

Yes :) ... the result is still the same..

upgrade.php > $timeLimitThreshold = 240;  >>>> waiit.. waiittt.... the result is still the same..

Adding alert preferences...done

Server has not responded for xxx seconds. It may be worth waiting a little longer before trying again.



Set the default language to English and try it again. I have tried it myself a couple of times when doing  2.0.19 to 2.1. upgrades, and it solved the problem. It solved it also for another couple of other users who had the same issue. Hope it helps you too.

Aleksi "Lex" Kilpinen

@Sesquipedalian Is this something you are aware of? Sounds like the upgrade might have issues, if switching to English works as a fix.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

Sesquipedalian

Quote from: Aleksi "Lex" Kilpinen on April 28, 2022, 11:09:50 AM@Sesquipedalian Is this something you are aware of? Sounds like the upgrade might have issues, if switching to English works as a fix.

I was not. I must say, it seems very strange to me that switching to English would solve a timeout issue on a specific sub-step of upgrading the database.

The next step in the upgrader is "Upgrading post notification settings". It is conceivable that there might a timeout in that stage for various reasons (none of them language related).

I would suggest that @Alpay open the upgrade_2-1_mysql.sql file and make the following change on line 998:

Code (Find) Select
$limit = 100000;
Code (Replace) Select
$limit = 1000;
If Alpay is using PostgreSQL instead of MySQL, then this change should instead be made on line 1193 of upgrade_2-1_postgresql.sql.


This change will tell the upgrader to make changes in the relevant sub-step in batches of 1000 instead of batches of 100000. Smaller batches might help avoid this timeout. Please let us know whether that change fixes the problem, Alpay.
Slava Ukraini!
Heroiam slava!

I promise you nothing.

Sesqu... Sesqui... what?
Sesquipedalian, the best word in the English language.

Sir Osis of Liver

"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Alpay

Quote from: Sesquipedalian on April 28, 2022, 12:40:33 PM
Quote from: Aleksi "Lex" Kilpinen on April 28, 2022, 11:09:50 AM@Sesquipedalian Is this something you are aware of? Sounds like the upgrade might have issues, if switching to English works as a fix.

I was not. I must say, it seems very strange to me that switching to English would solve a timeout issue on a specific sub-step of upgrading the database.

The next step in the upgrader is "Upgrading post notification settings". It is conceivable that there might a timeout in that stage for various reasons (none of them language related).

I would suggest that @Alpay open the upgrade_2-1_mysql.sql file and make the following change on line 998:

Code (Find) Select
$limit = 100000;
Code (Replace) Select
$limit = 1000;
If Alpay is using PostgreSQL instead of MySQL, then this change should instead be made on line 1193 of upgrade_2-1_postgresql.sql.


This change will tell the upgrader to make changes in the relevant sub-step in batches of 1000 instead of batches of 100000. Smaller batches might help avoid this timeout. Please let us know whether that change fixes the problem, Alpay.

Yeeesss, grateful for the solution. ;)
Completed without any problems.
And, thank you to those who replied.


Advertisement: