Smf 2.1 HTTP ERROR 500 hatası

Started by cihancan, May 07, 2022, 04:09:00 AM

Previous topic - Next topic

cihancan

Merhaba arkadaşlar.
Mevcut 2.0 sitemi upgrade yaparak 2.1.1 sürümüne yükselttim. Ama bazı konuları değiştirmek istediğimde beyaz bir sayfa açılıyor ve
Bu sayfa çalışmıyor
xyz.com şu anda bu isteği işleme alamıyor
HTTP ERROR 500
şeklinde bir uyarı çıkıyor ve istediğim değişiklikleri yapamıyorum. Bunun sebebi ve çözümü ne olabilir.

gevv

Merhaba,

forumun kurulu olduğu dizinde .htaccess  dosyası var mı?  yoksa boş bir tane oluşturup deneyin
ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

cihancan

Quote from: gevv on May 07, 2022, 07:26:27 AMMerhaba,

forumun kurulu olduğu dizinde .htaccess  dosyası var mı?  yoksa boş bir tane oluşturup deneyin
.htaccess dosyası yoktu. Dediğiniz gibi bir tane boş oluşturup attım ama yine değişikliğe izin vermiyor. İşin ilginç tarafı hızlı düzenle seçeneği ile değişiklik yapılabiliyor. Fakat hızlı düzenle kısmından eklenti ekleme veya değiştirme yapılamıyor. FAZLASI Düzenle menüsünde ise hata veriyor.

ForumSever

Geçmişte benzer bir hatada mod security i kapatmıştım.

gevv

@ForumSever  hocamın söylediği gibi modsecurity sorunu olabilir zaten  tüm smf.2.1  kurulumlarında  yerli yabancı hostlarda  sorun yaşıyorum sorun yaratan şeyi bulup beyaz listeye ekliyorlar.  Ama ben hiç 500 hatası almadım hep 403

hosting firmasına durumu bildirin hatta  hesap oluşturup sorunu görmelerini sağlayın  büyük ihtimal çözerler

mod security kapatmanızı  önermem  güvenlik sorunları olabilir
ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

cihancan

Arkadaşlar deneme yanılma yöntemi ile sorunu şu şekilde bulup çözüme kavuşturdum. Siteyi 2.0.19 sürümünden upgrade ederek 2.1.1 sürümüne yükseltmiştim. Hata veren konulara baktığım zaman hepsinin içerisinde link ve bağlantılar olduğunu fark ettim. Konu içerisinde link olmayan konularda hata vermiyordu. Smf 2.0.x serilerinde linkleri
http://xyz.com
şeklinde girdiğimde herhangi bir hata vermiyordu. Ama 2.1.x sürümlerinde HTTP ERROR 500 hatası vermeye başladı. Ben de linkleri
https://xyz.com
şeklinde yazıp güncelle dediğim zaman hata vermedi ve kaydetme işlemi başarılı oldu. Sorun bundan olabilir mi bilmiyorum ama bu şekilde yapınca çözüme kavuştu.

gevv

Kesin sunucu kaynaklı bir sorun

Phpbb forumda da sadece imgbb linkleri 403 veriyor http https fark etmiyor

Sizin sunucu niye 500 veriyor onu bilmiyorum

Yukarıda söylediğim gibi durumu firmaya bildirin

Bu güvenlik güncellemeleri baya uğraştıracak ben uzun süredir ayıklama yapıyorum sorun yaratan karakter, kod, kelime vb. bildiriyorum modsecurity ayarlarında beyaz listeye ekliyorlar
ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

Advertisement: