SMF 2.1.4 has been released! Take it for a spin! Read more.

Main Menu

The callable ! could not be called.

Started by chadon, May 11, 2022, 08:24:42 AM

Previous topic - Next topic


Hi, since updading from Smf 2.1.1 to 2.1.2 each page load creates an error in the logs, here are the details:

 [ip address]
 f484e4015d464181e0e966e3be22cb0a;area=logs;sa=errorlog;desc  Backtrace information

Type of error: General
Error messageSelect
The callable ! could not be called.

When I click on backtrace information:

Quote#0: call_helper()
Called from /home/mustvco/public_html/fr/Sources/Subs.php on line 4175
#1: obExit()
Called from /home/mustvco/public_html/fr/index.php on line 206

Line 4175 on Subs.php is:

$call = call_helper($function, true);
Line 206 on index.php is:

obExit(null, null, true);


I will try an upgrade of the database tonight unless someone has a better suggestion.

In over 10 years of using SMF, I never had troubles doing updates or upgrades but since I tried SMF 2.1 RC3 not a single one happened without big troubles.

My forum has now over a million messages and I noticed that only 2 large forums listed on the wiki are running with SMF 2.1, many still use the version 1.X.X.

Is it because it's too complicated to upgrade a forum once the database gets too big?


Bitcointalk is super stubborn, they don't want to upgrade because they believe some of the functionality in 2.0 is fundamentally insecure. I had long, long chats with them about how misguided their views are, but that's for another story. They're also not interested in upgrading because they're writing a new forum from scratch last I heard.

I would suspect that in a lot of the other cases there is a 'if it isn't broken, don't fix it' approach, and for others it's because the amount of development required is significant and people didn't want to do it until 2.1 was finalised before starting to make changes.

As for your actual error, this I think indicates a possibly rogue mod doing something it shouldn't. What mods do you have installed on your 2.1.2?


Quote from: Arantor on May 11, 2022, 01:45:09 PMAs for your actual error, this I think indicates a possibly rogue mod doing something it shouldn't. What mods do you have installed on your 2.1.2?

It was related to mods. They each had their hooks installed 5 times and with the help of my co-administrator, we uninstalled all mods, removed all hooks and no more errors were logged.

Then a first mod was reinstalled, the last version of Tinyportal  and errors appeared again and 5 pages of hooks were created for just that mod.

We then decided to delete the Sources and Themes folders and upload fresh files from the large upgrade package and so far, everything is good, even with Tinyportal and other mods installed.


The problem came from this mod :

I installed it again and the errors and the mess up with the hooks came back and I had to start all over.
I will notify its author in his topic.


Marking solved then. Bugo is pretty good at fixing any problems with his mods.
DO NOT pm me for support!