News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Memcached not working?

Started by Scooter Trash, June 03, 2022, 03:16:32 AM

Previous topic - Next topic

Scooter Trash

Greetings.

I recently moved to a new host. The new host has Memcached. It's enabled. In the SMF cache settings I have Memcache set to 127.0.0.1:11211

The host shows Memcached IP address: 127.0.0.1 and Memcached Port: 11211

...SMF is telling me; "SMF has not been able to detect a compatible accelerator on your server."

What am I doing wrong?

Illori

memcache and memcached are not the same. i dont believe SMF 2.0 will support memcached. i believe SMF 2.1 does.

Scooter Trash

Quote from: Illori on June 03, 2022, 04:49:07 AMmemcache and memcached are not the same. i dont believe SMF 2.0 will support memcached. i believe SMF 2.1 does.

I have SMF ver. 2.0.19

In the cache settings it says;

"SMF supports caching through the use of accelerators. The currently supported accelerators include:
APC
eAccelerator
Turck MMCache
Memcached
Zend Platform/Performance Suite (Not Zend Optimizer)
XCache'

Original post should have said "Memcached."

According to what I've been able to find, both SMF 2.0.19, and my host use Memcached.

Arantor

There are two connector libraries in PHP for the Memcached service, one is called memcache, one is called memcached. Very helpful, I know.

If SMF says it doesn't detect it, that means the relevant connector is not available - your new host probably only has the newer connector installed, which 2.0 doesn't support.

Scooter Trash

Quote from: Arantor on June 03, 2022, 05:24:38 AMThere are two connector libraries in PHP for the Memcached service, one is called memcache, one is called memcached. Very helpful, I know.

If SMF says it doesn't detect it, that means the relevant connector is not available - your new host probably only has the newer connector installed, which 2.0 doesn't support.

 :( Thanks

MrPython

How to install the correct connector? Need to downgrade/upgrade PHP version?

I use:
SMF 2.0.19
PHP 7.4-fpm
nginx/1.18.0
Debian 11

php-fpm7.4 -i
...

PHP Version => 7.4.28

...

memcached

memcached support => enabled
Version => 3.1.5
libmemcached version => 1.0.18
SASL support => yes
Session support => yes
igbinary support => yes
json support => yes
msgpack support => yes


Arantor

Yeah you have the newer one installed.

Ideally upgrade to SMF 2.1 but failing that you can try to get php-memcache as a package installed (vs php-memcached)

Downgrading PHP is a bad idea and leaves you open to security issues as below 7.4 is not officially supported.

MrPython

Quote from: Arantor on June 13, 2022, 06:16:06 AMIdeally upgrade to SMF 2.1
8)
Thank you!
Updated SMF to 2.1.2 and PHP 8.1.7.
Memcached is up and running!
But it seems to me that the forum has become slow, compared to version 2.0.19

Advertisement: