News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

mise à jour 2.0.19 vers 2.1 problème

Started by fonfonsd, June 21, 2022, 08:57:24 AM

Previous topic - Next topic

fonfonsd

bonsoir
j'ai testé en 7.4 pas mieux, je tente en 7.2

fonfonsd

Re bonsoir

le 7.2 ne change rien :-X  :-X

maintenant plus que des messages d'erreurs base de données


 Invité
https://www.fjassociation.fr/cron.php
/htdocs/Sources/Subs.php (Ligne 529)
Informations de traçage

Type d'erreur: Base de données
Message d'erreur Sélectionner
: Incorrect string value: '\xE0\xAE\x9A\xE0\xAE\xBF...' for column `fjass1868702`.`smf_settings`.`value` at row 1




fonfonsd

bonjour
quand je vais sur mysql j'ai dans paramètre généraux utf8umb4_unicode_ci





fonfonsd


maximus23

Bonjour,

Je ne saurais pas t'aider pour le moment car occupé une 15 de jours.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

bisane

Quote from: bisane on June 25, 2022, 09:43:51 AMJe ne sais pas trop pour le reste, mais il est certain que cette url, à la fin de la 2° image, n'est pas "normale" :
https://www.fjassociation.fr/index.phphttps://www.fjassociation.fr/cron.php
Pardon d'insister, mais une telle url ne devrait pas exister, or elle persiste dans vos copies d'écrans...
Il doit quand-même bien y avoir une erreur dans les paths.
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

fonfonsd

bonjour

mais pas de souci tu peux insister.  Pour les paths, je dois regarder où ? car avec repair_settings tout est ok

bisane

Je n'y connais pas grand chose...
Vous avez vérifié vos tâches cron ?
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

fonfonsd

Bonjour à tous

sur la partie internationale du forum, on me dit que problème viendrait du langage de ma base de données, on me dit de faire cela

En effet. toutes les tables et colonnes doivent avoir le même jeu de caractères de classement. Vous devez les définir sur utf-8 et cela devrait résoudre votre problème. Faites d'abord une sauvegarde de votre base de données, avant de convertir le caractère de classement en utf-8.



je m'y prends comment ? merci
stephane

bisane

Dans l'admin -> maintenance -> base de données -> Convertir les entités HTML au format UTF-8
Il faut ensuite mettre toutes les tables de la BDD en UTF-8

Vous risquez d'avoir quelques surprises dans les contenus de vos messages, avec des caractères spéciaux improbables...
Mais le passage en UTF-8 semble désormais être incontournable. :(
De tous les bouquets de ta vie, garde une fleur qui ne fânera pas.

fonfonsd

Bonjour
j'ai réglè le problème c'etait la ligne smf_settings qui n'était pas en UTF8

GravuTrad

On a toujours besoin d'un plus petit que soi! (Petit!Petit!)


Think about Search function before posting.
Pensez à la fonction Recherche avant de poster.

Advertisement: