News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

2.1.2 Activation emails aren't being sent?

Started by DragonLady, June 27, 2022, 03:20:11 PM

Previous topic - Next topic

DragonLady

I've had several members or wannabe members tell me they haven't received activation emails after changing their passwords or registering for the forum.  It seems to be an intermittent problem that isn't affecting everyone, so I'm not sure if it's a bug in the scripts or if I have something set up wrong or if they're just making typos or other areas when they fill in the forms.

Anyone else having this issue?  Or has this been resolved somewhere?

DragonLady

After sending this I suddenly realized I don't receive my alerts anymore.  When I went to /mysite/index.php?action=profile;area=showalerts there was one...but there should've been at least one more.



Aleksi "Lex" Kilpinen

If it's seemingly random, my first guess would be that the messages get filtered in transit as spam.

A couple of things you can easily check to try and avoid this:

- Don't use a fake sender address. You can use a properly configured black hole address, but you should not use an address that doesn't actually exist.
- It is practically always better to use SMTP instead of php to send mail
- If you are forced to use php to send mail, it is often better to use an email address that is actually hosted on the same domain as the forum
- If you can set up SPF and DKIM records for your mail it's bound to help, but you might not actually have any control over this. (If you are using a proper 3rd party SMTP service, you shouldn't have to worry about this one)


Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

DragonLady

Thank-you Aleksi :)

I'm not using a fake sender address, and I am using an email address that is hosted on the same domain. 
I think I'm using php but I'll have to check.

I'll ask my hosts about the records.


Aleksi "Lex" Kilpinen

If you can switch to using SMTP, it can make a difference. Would probably be a good idea to test it out.
Slava
Ukraini!


"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

How you can help SMF

DragonLady

Thanks for all your help so far. :)

I changed some settings for my alerts, and when I saved the changes, it started working again.

I'll have to ask my hosts about the email settings.

Advertisement: