News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Profile popup from website

Started by Abavagada, July 11, 2022, 02:22:01 PM

Previous topic - Next topic

Abavagada

I'm working to build a website around SMF 2.1.1.

I've got a page with calls to load SSI and the css and javascript.

I've copied in the code for the profile popup at the top left.

All seems to work fine. When I click on the member name to load the profile popup, the "loading..." line appears, but the popup doesn't load.
There is no other script on the page to interfere with it, and the javascript is obviously working well enough to load the "loading..." line.

To clarify:
This is called before everything:
require_once('...path to forum.../SSI.php');

Then in the header:
template_css();
template_javascript();

Then after everything:
ssi_shutdown();

Any suggestions?

Kindred

please 1- provide/attach your whole code  and 2- provide a URL to test the issue?
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Arantor

That's really not all the code you need. The "loading" is there by default without you doing anything, what you need is the definition and call out to the smcPopupMenu for it to load its content via AJAX.

It was never really designed to be called via SSI unless using template_header in its entirety.

Abavagada

Solved it. It was an issue with the COR security. Needed to be set to allow sharing.

Advertisement: