stuck at upgrade to 2.1.2

Started by klausp45, July 23, 2022, 05:26:28 AM

Previous topic - Next topic

klausp45

Hi,
I am trying to upgrade my smf forum 2.0.19 to 2.1.2 for some days now. First I got stuck several times during the upgrade-process via upgrade php. The process didn't throw out any errors, just stopped at different steps.
Now I doubbled the server-resspurces to 2 cpu and 4 gb ram. It's running smoother now and gets stuck at following steps everytime I restart it. There are no errors in server logs. Clicking "try again" doesn't do anything.

Quote"Cleaning up after old UTF-8 languages" (59 of 71)
Update the members' languages...done
Server has not responded for 30 seconds. It may be worth waiting a little longer before trying again. Click here to try again.

After the normal upgrade via "large upgrade" failed, I copied the "full install" files to a new dir, copied the root-files from the "large upgrade" over it and linked them via repair-settings (fixed also dir-settings) to a "fresh" sql-db from the 2.0.19 system, to get sure nothing is messed up.

php: 8.1
db:    MariaDB 10.3.35

Thanx for any help.

marcosbr

Just a suggestion...
Leave 2.0 out of PHP 8...
Update and switch to PHP8...
Nothing in life is absolute. We are always learning... Did you know that?
https://amigosdaeletronica.com.br

Arantor

I don't believe 8.1 is officially supported yet, try with 8.0.

klausp45

Thanks for the answers.
I tried the upgrade now with php 7.4, 8.0, 8.1. Nothing worked. All stuck at the same step.

SpacePhoenix

Don't know if MariaDB has one, anything listed in the slow query log?

klausp45

M
Quote from: SpacePhoenix on July 24, 2022, 06:27:01 AMDon't know if MariaDB has one, anything listed in the slow query log?
Thank you. My hoster will enable it. Will get results later.

The settings.php upgrade info is:
"{"id":1,"name":"Administrator","pass":,"started":1658611637,"updated":1658663306,"version":"2.0.15","step":3,"substep":340,"skip_db_substeps":false,"main":2}"

anyone knows, what this substep 340 is?

klausp45

couldn't solve the problems with the upgrade via browser.
but everything worked from commandline now.

Steve

Quote from: klausp45 on July 25, 2022, 05:26:05 PMeverything worked from commandline now
Meaning what? Your issue is resolved?
Please do not PM me for support.

Arantor

The command line upgrader is more reliable than the web one, chances are the OP is actually all upgraded now.

Doug Heffernan

Marking this as solved in that case. @klausp45, if we misread/misunderstood you and the upgrade is not completed and you will still need assistance, please feel free tom ark it as unsolved anytime

Advertisement: