News:

Join the Facebook Fan Page.

Main Menu

Insert a link not working

Started by minky, July 26, 2022, 06:11:48 AM

Previous topic - Next topic

minky

When I use 'insert a link' it works fine when I preview my reply but when I post the reply containing the link it does not work.  Had no problem prior to upgrade to 2.1.2




Arantor


minky

No, it changes HTTP to HxxP and has unactivated in red at the end.

Like someone else I have found on my forum if I 'post' then go to Quick edit and hit save link is changed to correct syntax and works fine.

Arantor

Hmmm, so when you say "doesn't work", how does it not work? How exactly are you adding the links?

Kindred

changing http to hxxp is a mod in use here which prevents spammers from adding links with a brand new account.

If that is what's happening on your own site, then you probably have a similar mod installed, but you have it configured incorrectly.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

minky

hxxp is not what happens on my site, I have two mods tinyportal and Cleantalk.

I have had smf forum since 2005, no problem with links. I know how they should look in the post and now they do not look right nor do they work until I have used quick edit - save, then they look right and work.

I open a site in a tab copy the address, select insert link, paste the address in input field, put text in the other input field.  I preview it it looks right and works.

I save the post and the link is not formatted correctly until after the quick edit trick.

1st image is at preview(link as it should be), 2nd is after posting.


You cannot view this attachment.

You cannot view this attachment.

 

Arantor

Um, action=post is not going to work for you seeing that it's the link to the full reply page, and SMF will *always* disable that link.

If you want to link to a topic, the link should be index.php?topic=123.0 or similar, not have an action=post in it.

minky

#7
I only used that url as an example of the results I get, it can be any url from another tab i.e. a newspaper site, BBC, Met office so on and so forth ANY URL !

I just went on my forum made a link to Rightmove, after posting it looks like the following and obviously will not work..

Rightmove (https://www.rightmove.co.uk/ [nofollow])

It does though look correct and work on preview, and will look/work after quick edit - save.

(nofollow) added by smf.

Arantor

Let's see for me then.

Bare URL: https://www.rightmove.co.uk/

Manual url bbcode manual URL code

I haven't previewed, just saved.

minky

All I can ask is you register on my forum, verylittlehelps.com [nofollow] and try it there, and see if you get any ideas.

Or I can create a temp membership for you

minky

Apparently I'm not the only one with the problem on my forum nor is it only my forum that has the problem.

Arantor

As demonstrated, this site doesn't have the problem, but the first thing that comes to mind is that you've gone into the bbcode configuration and disabled the url bbcode which would give you the look as described.

This site also doesn't have many mods so I'd be interested to know what mods you have if that doesn't solve the problem.

minky

url bbcode is enabled, it has never been disabled.  I have tinyportal and Cleantalk installed.

Arantor

Weird. Can you upload your Sources/Subs.PHP file please? (As an attachment, not pasted into the body of a post.)

minky

Yes. and further to the url bbcode subject if it was disabled why would links work fine after using quick edit/save.

Thank you for trying to help an old man.

Diego Andrés

Also check if the URL bbc is enabled for signatures, this is a known bug that makes the URL fail in posts.
https://github.com/SimpleMachines/SMF/issues/7404

SMF Tricks - Free & Premium Responsive Themes for SMF.

Arantor

Yeah, that's a very good shout, Diego - I asked for Subs.php to verify the actual definition was intact (which it is), and that's the next thing, because what happens is that the signature enabled options end up corrupting the regular post ones, which leads back to the disabling things it shouldn't, with the described behaviour.

minky

Thank you Diego, on a first test run that has solved the problem.
Thank you Arantor it does appear to be a known bug.
Lets look forward to a fix update.

Help much appreciated.

Strange how QUICK EDIT-SAVE resolves the link issue.

Advertisement: