News:

SMF 2.1.2 has been released! Take it for a spin! Read more.

Main Menu

Database may require an upgrade?

Started by Jito463, August 05, 2022, 03:18:37 PM

Previous topic - Next topic

Jito463

I've been managing our forums for a few years, and mostly things have run smoothly.  Lately, a handful of people have started experiencing issues with the forums, such as the 'unread messages' not updating and now issues with activating new accounts.  Here's one error message I saw recently while trying to activate a user's account from the automatically generated link:

QuoteTable './nfoaadmi_foru/smf_log_search_words' is marked as crashed and last (automatic?) repair failed
File: /home2/nfoaadmin/public_html/online_community/Sources/Subs-Post.php
Line: 2035

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.19, while your database is at version 2.0. The above error might possibly go away if you execute the latest version of upgrade.php.

I've run the upgrade.php (at least I assume I ran the correct one), and it didn't find any updates available.  I did update a while ago to 2.0.19, but it's been running fine for months since then.  Here are the following mod packages installed (all of which were previously installed before I took over, save for the SMF updates), which are all reporting as up to date:

Quote1.   SMF 2.0.19 Update   1.0
2.   SMF 2.0.18 Update   0.1.0
3.   SMF 2.0.17 Update   1.0
4.   SMF 2.0.16 Update   1.0
5.   Login Security   1.0.3 (possibly the cause?)
6.   Quick Ban on Account Delete   1.0.1
7.   Error Log Counter   1.0
8.   Default Avatar   2.3
9.   Ad Managment   3.3a
10.   Show JDALLAUI in Post and PM   1.5.1
11.   Welcome Topic Mod   2.3
12.   Automatic Package Version Emulation   1.5
13.   Remove Child Boards   2.3.4
14.   Simple Audio Video Embedder   4.5
15.   Disable 'last edit by...' for Administrators   1.0
16.   No Temp Directory Removal   1.1.8

If there's any further information I need to provide, please let me know.

Doug Heffernan

Quote from: Jito463 on August 05, 2022, 03:18:37 PMTable './nfoaadmi_foru/smf_log_search_words' is marked as crashed and last (automatic?) repair failed
File: /home2/nfoaadmin/public_html/online_community/Sources/Subs-Post.php
Line: 2035

smf_log_search_words table should be repaired. You can do so from pma.

Quote from: Jito463 on August 05, 2022, 03:18:37 PMNote: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.19, while your database is at version 2.0. The above error might possibly go away if you execute the latest version of upgrade.php.

Your database is at a very old version. Personally I would recommend, if I may, that you run the upgrader to bring it up to date with the files.

Illori

Quote from: Doug Heffernan on August 05, 2022, 03:50:22 PM
Quote from: Jito463 on August 05, 2022, 03:18:37 PMNote: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.19, while your database is at version 2.0. The above error might possibly go away if you execute the latest version of upgrade.php.

Your database is at a very old version. Personally I would recommend, if I may, that you run the upgrader to bring it up to date with the files.

there are no database changes so even running the upgrade will not do much. that message has been removed in SMF 2.1 as it more confusing then anything.

Jito463

Quote from: Doug Heffernan on August 05, 2022, 03:50:22 PMsmf_log_search_words table should be repaired. You can do so from pma.
PMA?  I did run the repair from forum maintenance, but I'm not sure if that's the same thing you're referring to.

Quote from: Doug Heffernan on August 05, 2022, 03:50:22 PMYour database is at a very old version. Personally I would recommend, if I may, that you run the upgrader to bring it up to date with the files.
Quote from: Illori on August 05, 2022, 04:10:49 PMthere are no database changes so even running the upgrade will not do much. that message has been removed in SMF 2.1 as it more confusing then anything.
So, is an update required or isn't there?  I thought I already ran the upgrade.php, and it reported there were no updates available.  Did I do the wrong one, or is it moot?

Kindred

No need to update because of the message
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: