News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Track Activity error for one user

Started by Julius_2000, May 22, 2023, 04:33:20 PM

Previous topic - Next topic

Julius_2000

I get the following error message when I try to look up the activity from one specific user:

Wrong value type sent to the database. IPv4 or IPv6 expected.(ip_list)
You cannot view this attachment.

You cannot view this attachment.

It's weird because I also get an error message for the same user related to a new spoiler mod I installed today which I addressed here
https://www.simplemachines.org/community/index.php?msg=4152712


Julius_2000

Bump.

Well. I now get this error message for a number of other users as well. What's weird is that for none of them does the Track Activity work, as if something's has screwed with the database. Can anyone reproduce this?


Also, is there a reason why for some users I can pull log-in activities while for others there's no data, even though they've logged in recently and there are entries for IP address or profile changes, too?

Doug Heffernan

What was the latest change/modification done to the forum prior to this happening? What mods do you have installed? Are you using the latest version?

Julius_2000

The latest mods I updated to the most current versions were Fancybox and the new Spoiler by Bugo. The Spoiler mod gave an initial error, and keeps on producing this error, that I mentioned in the Spoiler topic:
https://www.simplemachines.org/community/index.php?msg=4152712

Another edit to the Profile-View.php was made by me as discussed here:
https://www.simplemachines.org/community/index.php?msg=4152487

Mods installed


All other changes were made only to css files.

I don't get those kind of error logs for the same users when I do that on our test forum with an older database. All changes to php and css files are copied to the test forum as well.

Edit:
I did a re-attributing of posts from one deleted account to my test account recently, but there were no issues and the newly attributed account works as supposed,

Julius_2000

#4
Alright, I might have discovered the culprit.

Since I first got that message in association with the new Spoiler mod that I installed, I looked again at the error log and it was always telling me that the key "spoiler" in the array was undefined. I then manually added $txt['spoiler'] to the index.English.php. On our test forum I uninstalled and re-installed the mod and the error was not coming up again like it was when I installed it the first times.

And now I'm able to access the "Track Activity" tab again for all those users for which I got a Cron error before. Thus, these two things must be correlated.

The Spoiler mod creates a sub-folder in the Default Theme folder which contains seperate language files where the above $txt code is present. But for some reason it isn't pulled.

Doug Heffernan

Glad to see that you identified the culprit and fixed it. Marking this as solved.

Advertisement: