SMF Upgrade Utility - does it continue to run?

Started by 808server, September 21, 2023, 02:42:42 PM

Previous topic - Next topic


I was upgrading my SMF from 2.0.19 to 2.1.4.
The SFM Upgrade Utility was backing up and I have a backup so I tried to run it again.
It tells me that "user is running the upgrade script."
The upgrade script has been running for the last 2 hours, 43 minutes and 50 seconds

My question. Is it really running and will it eventually stop when done? The progress bar says overall progress 0 and Time Elapsed: 163 mins, 50 seconds.

Is it really doing it's thing or is there some way to stop it and start over?


I tried logging in and it says that Overall Progress 31%. Step progress 34.2%.
Time Elapsed: 179 mins, 4 seconds.

But it has been stuck on adding likes.
Please be patient - this may take some time on large forums. The time elapsed increments from the server to show progress is being made.
Executing: "Adding support for likes" (23 of 71)


Server has not responded for 30 seconds. It may be worth waiting a little longer before trying again.Click here to try again.

Is it stuck or really running?


OK just in case this might help someone. I am running a VPS, you can go into WHM, check the MySQL processes and see if it's doing something. In my case it was.
Hope this helps others.

Sir Osis of Liver

Unless you have an enormous database the upgrade is failing.  Any server errors?
Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters


OMG. It has been going for over 6 hours for the "post" database part and I think the upgrade stopped during "Convert to UTF-8". It's stuck on "Current Table: "members"

Yes, my database is 2.4GB!

What can I do at this point? I don't see any activity in WHM now.
Thanks for any help.


can you run the upgrade from CLI? that is usually recommended with a large forum.

Sir Osis of Liver

Quote from: 808server on September 22, 2023, 07:11:57 PMYes, my database is 2.4GB!

Did you empty log_errors table?  Have you been running pretty urls mod?  If so, how large is the pretty cache table?
Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters


Thank you for the reply. It indeed did stop. Someone ran it again from ssh and it completed.
Luckily it is done.


It's getting to the point where the forum is so large that upgrades can take days!


I help on a forum with 2.7 million posts and 41 thousand users still only took a few hours

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."