Google goes to wrong home page

Started by pw1, February 12, 2024, 06:30:21 AM

Previous topic - Next topic

pw1

Hello!

When I search my forum on Google and click the link, it takes me to an incorrect home page (see attached). The url at that page ends in ".com/?i=1".

When I hit home from that page, it takes me to the correct home page of my forum. That url ends in .com/index.php?i=1

Any idea as to how to fix this?

I am using SMF 2.1.4

You cannot view this attachment.


AlanDewey

Google webmaster tools    Sign up and then you can tell it to remove that link.

https://search.google.com/search-console/about

How do other search engines work for your site?  Bing, DuckDuckGo, etc
Causing lots of electrons to push each other around since 1985.

Kindred

what is your forum URL?
What is the forum url in Settings?

Did you ever add a mod or do something which removed the index.php from your URL?
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

pw1

The forum URL is hxxp:patientlyweightingforum.com [nonactive].


From settings, the theme's URL is hxxp:patientlyweightingforum.com/Themes/NameX_v1.2.5 [nonactive]

I don't believe I have added any mod or done anything to remove the index.php from my url but it is possible I suppose (I know very little about this stuff).

If you type the url directly in the address bar it goes to the site just fine. It is just when going from Google that it goes to the wrong place. The forum isn't showing up in other web browsers search yet to look there.

Kindred

What is that ?i=1 stuff?   That's not part of SMF's core design.

however, I just went to your site from google and got the correct page, DESPITE the no index.php and the ?i=1


BTW: IMNSHO You have ***WAY*** too many boards.    You have almost all boards with zero or one topic.  That's never going to get traction from users. It's too spread out.  You should START with a minimal number of boards on broad topics and only split them out when a specific topic becomes so popular that it crowds out the other content
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Sir Osis of Liver

Are you using a redirect?  I get directly to your homepage and see ?i=1 when it first loads, but remove it in url and it stays removed.
Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters

pw1

Kindred- thank you, that is very good feedback!

I have no idea where the ?i=1 is coming from. Is a redirect what I need to do to get the incorrect page to stop showing?

pw1

Sir Osis of Liver- you just jogged my memory. I was having issues before with the forum loading as a non-secure site. To fix this, I added to .htaccess file to force traffic to https version of site.

Do you think that is what is causing it perhaps? Here is what I added:

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:CF-Visitor} !{"scheme":"https"}
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

I got this from here: hxxp:forum.infinityfree.com/docs?topic=49322 [nonactive]


Steve

Quote from: Kindred on February 12, 2024, 10:53:27 AMBTW: IMNSHO You have ***WAY*** too many boards.
I'm afraid I'm going to have to disagree with my boss. Looking at the objective of your forum I think you've covered all areas that might be discussed. If it pans out that a board is seeing no action, you could delete it.

I could be wrong though, I was once.  :P
DO NOT pm me for support!

Arantor

While it's not really the issue being discussed, let's go with 'you're both right'.

Having a list of boards is good - but having a long list, even a thorough one, is usually counterproductive for a new forum. A thorough list has limited value if half of them are empty or only have one or two topics in, because it takes what content there is and spreads it out thinly, making it look less busy (=fewer people to talk to) than there might actually be.

But there is value in having your bases covered too. Sort of thing it would really help to get people in early to talk about.

Sir Osis of Liver

Quote from: pw1 on February 12, 2024, 01:12:48 PMSir Osis of Liver- you just jogged my memory. I was having issues before with the forum loading as a non-secure site. To fix this, I added to .htaccess file to force traffic to https version of site.

Do you think that is what is causing it perhaps? Here is what I added:

RewriteEngine On
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteCond %{HTTPS} off
RewriteCond %{HTTP:CF-Visitor} !{"scheme":"https"}
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

I got this from here: https://forum.infinityfree.com/docs?topic=49322


Try this -


# 301 REDIRECT HTTP TO HTTPS AND WWW TO NON-WWW
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} ^www\. [NC]
RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
RewriteRule ^ https://%1%{REQUEST_URI} [L,NE,R=301]
</IfModule>

Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters

pw1

That worked! I can't thank you enough!!!

Advertisement: