Need help solving a mistake & upgrading to 2.1.4

Started by awks, April 10, 2024, 01:09:33 PM

Previous topic - Next topic

awks

I tried to move a board and I now seem to have trashed 3 or 4 boards. All the data is there, I just need the order of the boards sorted with the correct posts in them please?

Sir Osis of Liver

SMF version?  What exactly did you do?  Does your host package include 30 day backups?
Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters

awks

#2
SMF 2.0.19

I tried to move a board down in the list, then it seemed that some boards were empty. After a refresh all looks ok, then after a while I find a board or 2 that has all its post missing.
To be honest it seems to look different each time I go back in. I am a bit confused at the moment!

OK, it seems that if I log in as admin, everything looks fine and everything is where should be. If I log in as a standard user, the top 3 boards show as if they are empty. The 3 boards that look empty, are boards I did not try to move. Now after a refresh, all seems normal logged in as a standard user!
I do not understand why so much is messing about after just trying to move one board, lets leave this for 12 hours or so to see if things work out. If all seems fine tomorrow, I will delete this post.

I cannot see any 30 day back up, it is hosted with JustHosts.

Kindred

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."


Kindred

Well, what you describe is not reproducible on an unmodified installation of smf 2.0.19

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Illori

i seem to recall this being an issue in the past, i am not sure what the fix was but i found this https://www.simplemachines.org/community/index.php?topic=573325.0 and it has a fix in it.

Sir Osis of Liver

Back up your forum files and database before trying that fix.
Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters

awks

This morning the forum is exactly as it was before I tried to move a board.
I have no idea what went on.
I would still like to know how to move the order of some boards, but to be honest I am frightened to touch anything at the moment!  :-[

awks

Going a bit off topic but, although my version states 2.0.19, when drilling down I can see out of date files as below:

SMF File    Your Version    Current Version
SMF Package    SMF 2.0.19    SMF 2.1.4
Sources                   2.0.12           2.1.4
Default Templates     2.0.19           2.1.4
Language Files          2.0.18           2.1.4

I didn't get any notifications for an update as in the past. So I believe I need to download and install the large upgrade to get it updated to 2.1.4

Is that correct please?

This is what I see in my forum admin section
Version Information:
Forum version: SMF 2.0.19
Current        SMF version: SMF 2.0.19

which is what made me think it was up to date!


Steve

Quote from: awks on April 11, 2024, 08:09:37 AMIs that correct please?
Yes. Keep in mind it will remove any mods you may have, custom or not.
DO NOT pm me for support!

Sir Osis of Liver

I'd be hesitant to run 2.1 upgrade on this 2.0.19 forum as is.  If the current install is displaying boards and topics correctly, I would upload clean 2.0.19 files and see if that corrects the version errors and all runs correctly, then do the 2.1 upgrade.
Ashes and diamonds, foe and friend,
 we were all equal in the end.

                                     - R. Waters

awks

So do the 2.0.19 large upgrade as opposed to the Full Install first, if that goes ok, then do the 2.1.4 large upgrade?

Doug Heffernan

Quote from: awks on April 12, 2024, 04:00:15 AMSo do the 2.0.19 large upgrade as opposed to the Full Install first, if that goes ok, then do the 2.1.4 large upgrade?

You don't need to do it twice imo. You can do a direct upgrade to 2.1.4.

awks

#14
When uploading 2.1.4 OR 2.0.19 via package manager I get this error:
An Error Has Occurred!
vsprintf(): Argument #2 ($values) must be of type array, string given

Doug Heffernan

Quote from: awks on April 12, 2024, 06:07:40 AMWhen uploading 2.1.4 OR 2.0.19 I get this error:
An Error Has Occurred!
vsprintf(): Argument #2 ($values) must be of type array, string given

What is your php version?

Kindred

You cannot do a large upgrade in the package manager...

Upgrading SMF
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

awks

ok, create all folders and upload files to them on server is what I am now doing like this:
1) Download the package to your local PC and extract it into files.
2) Using an FTP client create a new directory in your "Packages" folder, in this example you may call it "shout".
3) Upload all the files from the extracted package to this directory.
4) Go back to the package manager browse page and the package will be automatically found by SMF.

Doug Heffernan

Quote from: awks on April 12, 2024, 07:46:08 AMok, create all folders and upload files to them on server is what I am now doing like this:
1) Download the package to your local PC and extract it into files.
2) Using an FTP client create a new directory in your "Packages" folder, in this example you may call it "shout".
3) Upload all the files from the extracted package to this directory.
4) Go back to the package manager browse page and the package will be automatically found by SMF.

What is it that you are trying to do, an upgrade? If so those are not the right steps. Check out the link posted above on how to do a manual upgrade.

Kindred

No...  that is how to do a package manager patch...  you are supposed to be dying a large upgrade.
You can not use the package manager at all.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: