Can't acces website after theme change

Started by Vincent Volmer, April 26, 2024, 06:30:03 AM

Previous topic - Next topic

Vincent Volmer

Hello,

A long time ago someone added a sort of portal to our forum that I wanted to disable. i asked this person who added it but he did not answer, so I tried to move to the core theme. But than I could not switch back. Just fatal error.

So, I tried to 'install' the 2.0.18 again this way:

Quotedelete the Sources and Themes directories (Save any custom graphics from your default or custom themes that you may want)
delete all php files other than Settings.php in the root
THEN upload/extract all of the 2.0.18 files....

And that brings back the forum (ugly, without styling)... but I can't login or upgrade to 2.0.19 because I see this error when I try:

Unable to load Themes/default/Errors.template.php!

And yes... I did this without making a backup. Did this without thinking  :-[  :-[

I hope someone has an idea how to fix this so I can login and upgrade to 2.1.x I don't care about mods etc. Just want it online in the default SMF theme. That's enough for me. The rest I can do myself.

btw... I cleared the /cache and the forum DNS is 'connected' to cloudflare.

The website is https://digiscrap.nl

[EDIT]
When I try to update (2.0.18 to 2.0.19) I get this error:
Updating Your SMF Install!
The upgrader found some old or outdated language files, for the forum default language, english.
Please make certain you uploaded the new versions of all the files included in the package, even the theme and language files for the default theme.


I uploaded all language packages but still this error.. Running repair_settings makes also no difference.

Thanks for any help...  :)
Regards, Vincent

Doug Heffernan

#1
Quote from: Vincent Volmer on April 26, 2024, 06:30:03 AMWhen I try to update (2.0.18 to 2.0.19) I get this error:

Small updated from one version to another within the same version branch are best done through the Package Manager.

Also, there are do database changes between the 2.0.18 and 2.0.19 versions. So running the upgrader is not required.

Quote from: Vincent Volmer on April 26, 2024, 06:30:03 AMI uploaded all language packages but still this error..

Try to switch the default language of the forum from dutch to english and run the upgrader again.

Quote from: Vincent Volmer on April 26, 2024, 06:30:03 AMRunning repair_settings makes also no difference.

Does the themes directory/path and url point to the right location?

Vincent Volmer

Thanks for your answer!

Quote from: Doug Heffernan on April 26, 2024, 06:53:22 AMSmall updated from one version to another within the same version branch are best done through the Package Manager. Also, there are do database changes between the 2.0.18 and 2.0.19 versions. So running the upgrader is not required.
Ok, thanks!! ik went back to 2.0.18 now with this: https://www.simplemachines.org/community/index.php?topic=289917.msg1910808#msg1910808
But still getting the template error. And lost all the attachments but that's ok.

Quote from: Doug Heffernan on April 26, 2024, 06:53:22 AMTry to switch the default language of the forum from dutch to english and run the upgrader again.
Did that with the repair_settings but no difference with the upgrader.

Quote from: Doug Heffernan on April 26, 2024, 06:53:22 AMDoes the themes directory/path and url point to the right location?
I guess so. Directory is the same as the recommended value. Same values in the database...

Adding index.php?action=admin;theme=1 to the URL is giving still the error.


   

Steve

DO NOT pm me for support!

Vincent Volmer

Quote from: Steve on May 13, 2024, 07:55:32 AMIs this still an issue @Vincent Volmer?

Thanks Steve,

Yes and I had to remove / delete the whole forum including gallery a week ago. We could not find the issue so here it ends. Our forum was active since 2007 with a lot of users and activity. Don't startup a new one.

Thanks to the SMF team for the great forum software.

Regards to all
Digiscrap Plus
Vincent Volmer


Steve

Well, that's a shame ... I wish we could have helped you more.
DO NOT pm me for support!

Diego Andrés

If you have a copy of the dabatase you can still run the upgrader, with a fresh set of 2.1.4 files.

SMF Tricks - Free & Premium Responsive Themes for SMF.

Advertisement: