vB 3.8.5 to 2.0.19

Started by von Papst, May 15, 2024, 02:45:59 AM

Previous topic - Next topic

von Papst

Hi all I need a bit of help. I installed SMF 2.0.19 on nginx. All is working OK but when I want to convert vB with convert.php from package vbulletin37 I get error 500. Any hint what could be the issue. From access log I only have this:

[15/May/2024:08:09:55 +0200] "GET /convert.php HTTP/2.0" 500 0 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/124.0.0.0 Safari/537.36"

And nothing in the error log

von Papst

Managed to get this error now.
2024/05/15 09:08:37 [error] 32002#32002: *208 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Array and string offset access syntax with curly braces is no longer supported in convert.php on line 2813" while reading response header from upstream, request: "GET /convert.php HTTP/2.0"

von Papst

Managed to solve. Openede converter.php and replaced curly brackets on the reported lines and it worked.

Advertisement: