Advertisement:

Author Topic: MySQL Client/Server Issue?  (Read 6877 times)

Offline bneacetp

  • Semi-Newbie
  • *
  • Posts: 19
  • Gender: Male
    • TWSYFree.org
MySQL Client/Server Issue?
« on: December 28, 2005, 10:35:47 PM »
Ok, here is the basic ordeal I am in.  I am on a Windows XP Professional machine with IIS installed.  I am trying to get SMF installed and running.  I originally had PHP 5.1.1 and MySQL 5.0 installed, and I ended up getting the furthest, but kept getting database errors (for example when trying to view the "General Discussion" board) even after installing the patch for SMF for MySQL.  Anyway, I have uninstalled PHP 5.1.1 and MySQL 5.0 (or so I think) and have installed PHP 4.4.1 and MySQL 4.1.16.  I am able to get to the install page for the SMF, but I get the resulting error:

Quote
Cannot connect to the MySQL database server with the supplied data.

If you are not sure about what to type in, please contact your host.
Client does not support authentication protocol requested by server; consider upgrading MySQL client
Click here to try this step again.

I have tried the query below (from http://dev.mysql.com/doc/refman/5.0/en/old-client.html [nofollow]) in the MySQL Command Line:

Quote
mysql> SET PASSWORD FOR
    -> 'some_user'@'some_host' = OLD_PASSWORD('newpwd');

but it only brings up an error:

Quote
ERROR 1133 (42000): Can't find any matching row in the user table

I may be wrong, but doesn't that mean that MySQL can't even see the user that I put in?  When I use the MySQL Administrator tool, the user that I put in is in the user's list. 

Here is one thing that I think could be a problem: screenshot [nofollow]

Notice that the MySQL Version is 4.1.16, yet the Client Version is 5.0.11.  Is that the problem?  If so, shouldn't the MySQL command I entered earlier have fixed the problem? 

Please help me with what you think is the best solution for the fix I am in.  I'd really appreciate it if someone could finally help me get this working.  Thanks in advance. 

UPDATE: Issue fixed.  In MySQL Administrator, I deleted the user I was wanting to use for SMF and set the "Use Old passwords" option on the startup variables.  I then stopped the MySQL service, restarted it and then added the MySQL user that I want to use for SMF back and tried to go through the install process for SMF again and it worked.  :) 
« Last Edit: January 03, 2006, 09:11:10 AM by Oldiesmann »