News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Bug in Firefox 1.5 Causing Server Issues with SMF 1.1

Started by Grudge, January 20, 2006, 07:47:20 PM

Previous topic - Next topic

Grudge

I'm only a half geek really...

IchBin™

Would just like to compliment the SMF team on a timely FF fix. You guys are on it, and I appreciate it very much. Thank you!
IchBin™        TinyPortal

rebelsgirl

Thank you for the alert. I checked my logs and sure nuff, I was getting those  "index.php?action=keepalive". I changed all the index.template.php the way you said by putting the j after the question mark and put the script.js  in the default theme directory.

I wasn't sure that I was suppose to change all index.template.php's with the j, but it seems to work ok.

I love this place.. ;D

Kindred

Quote from: Prasad007 on January 22, 2006, 11:24:46 AM
how can notepad or anything mess up anything for adding a simple j
i did it correctly im sure


Just as a side note to anyone else...

Notepad will mess up ANY php files!!

DO NOT USE NOTEPAD TO EDIT YOUR PHP FILES.

Use a text editor like ConText, UltraEdit or EditPlus
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

NiCr0

i'm totaly lost but i suppose thats cause,

my theme i use don't have a "script.js", infact the only JS file it has is a collapse.js

My skin is : Daze Skin by Diplomat | Unofficial Grey Version modified by maCe

So would i just add the file attached to the 1st post and be done or *sigh*. i checked the index.template.php and there wasn't nothing in it that was like "$settings['default_theme_url'], '/script.js?"

Could this be related to why some of my users  are blocked, and the forum is not working properly, as in, time to time reciving a login_incomplete error (that i thought i got fixed from the related bridge topic for Smf + Mambo.)

Anyways Thanks for the notification email, and the quick fix. now i just got to figure it out :P

abcsurvivors

I don't have a question mark in the code where I'm supposed to add a "j." This is the only line I have like that in my theme:

<script language="JavaScript" type="text/javascript" src="', $settings['default_theme_url'], '/script.js"></script>

What should the code be?

Grudge

NiCRo - the script.js is in the theme directory called "default" - that is the only one you need to upload, not individual themes.

abcsurvivors, add "?j" after script.js
I'm only a half geek really...

Geas

GEAS

nokonium

I'd like to add

If you edit any forum files in Dreamweaver, DON'T update links, when you ftp any forum files, database backups included, select ASCII mode. Auto will not do, if possible add php, css and sql to the list of ASCII file names. Since doing this I have been free from errors caused by corrupted data.



manolain

Does this also affect you if you are working with SMF 1.0.5?

JayBachatero

manolain NO it does not affect you if you are using SMF 1.0.5.

-JayBachatero
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

cferd

I don't know if I had to, but I use the Joomla-SMF bridge and a code for it was placed in the Joomla template index.php file. I changed the "script.js?" part in it also just to be safe.

capierno

#72
After I installed the new script, my smilies dont work anymore, my news fader wont fade, and I can't highlight words.

=\ Help!
Capierno

hxxp:ussdevestator.bravohost.org/forum [nonactive]

manolain

Quote from: JayBachatero on January 22, 2006, 02:33:09 PM
manolain NO it does not affect you if you are using SMF 1.0.5.

-JayBachatero
Thanks for the answer Jay
we just suffered a few DoS attacks, couple of weeks ago....It is such a coincidence!!!

JayBachatero

Quote from: capierno on January 22, 2006, 02:49:39 PM
After I installed the new script, my smilies dont work anymore, my new fader wont fade, and I can highlight words.

=\ Help!

Can you please make sure that you have uploaded the script.js file.  If so check the size of it.

Quote from: manolain on January 22, 2006, 02:50:46 PM
Quote from: JayBachatero on January 22, 2006, 02:33:09 PM
manolain NO it does not affect you if you are using SMF 1.0.5.

-JayBachatero
Thanks for the answer Jay
we just suffered a few DoS attacks, couple of weeks ago....It is such a coincidence!!!
No problemo.  Well it just affects the 1.1 line.

-JayBachatero
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

capierno

I dont know what you mean, i did upload the new script, thats what i said.
Capierno

hxxp:ussdevestator.bravohost.org/forum [nonactive]

JayBachatero

Can you please verify that the file uploaded correctly?  Maybe upload it using another FTP client.

-JayBachatero
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Han

Tnx for the quick fix of this problem.
Always nice to know that there are people who take care of us.   :)

Grudge

I'm only a half geek really...

Grudge

capierno,

I registered on your site and it works fine with IE, Firefox and Opera. (Opera doesn't support the fade though). Can you try hitting Ctrl+F5 on your browser?
I'm only a half geek really...

Advertisement: