• Welcome to Simple Machines Community Forum. Please login or sign up.
January 29, 2022, 09:43:51 AM

News:

SMF 2.0.19 has been released! Please update. Read more.


SMF 1.0.6 Released

Started by Grudge, January 28, 2006, 06:39:21 AM

Previous topic - Next topic

dtm.exe

Quote from: loudog on January 28, 2006, 12:36:29 PM
Grudge, can you update shoutbox for version 1.06?? If so I'll wait to install this update, thanks Lou

It should work just fine with SMF 1.0.6.

dtm.exe

Quote from: Tippmaster on January 28, 2006, 12:34:02 PM
update went good, but...

it modifies SSI.php. I made a copy of ssi.php, and modified it alot to use it on my site. Should i make them same changes that the update did to SSI.php, or is it not that big a deal?

How about you keep your current SSI.php and just apply the 1.0.6 changes yourself?  That's what I would do :).

1MileCrash

hehe, that's what i had in mind. thanks.


here's what's changed:

$boarddir/SSI.php
</edit file>

<search for>
* Software Version:           SMF 1.0.3                                       *
</search for>

<replace>
* Software Version:           SMF 1.0.6                                       *
</replace>

<search for>
krsort($return['users']);

if (!empty($return['users']))
$return['users'][array_pop(array_keys($return['users']))]['is_last'] = true;
</search for>

<replace>
if (!empty($return['users']))
{
krsort($return['users']);
$userlist = array_keys($return['users']);
$return['users'][$userlist[count($userlist) - 1]]['is_last'] = true;
}
</replace>
The only thing php can't do is tell you how much milk is left in the fridge.



MuddHarryS

Alot of replies since I posted this so I thought I might bring it foward a bit, does anyone have any thoughts on this? I am not sure what needs to be chmoded as it doesn't tell me and the readme for the update itself doesn't say anything.

Thanks - Mudd


Quote from: MuddHarryS on January 28, 2006, 11:06:59 AM
I tried to run the update and I get a list of successes prior to clicking the "proceed" button.

It tells me "Some of the files this package needs to modify are not writable. This needs to be changed by logging into FTP and chmoding the files."

I put in my ftp info, click Proceed and nothing happens. I do see the tar file in my packages directory on the server. But not showing any signs of update. So the one click doesn't seem to be doing it for me.

Any thoughts? This will be my first time upgrading an SMF forum so I am not sure what I should be seeing. (I used phpBB2 for a few years and SMF smokes it).

Thanks,
Mudd


Cool Surfer

I just upgraded the old forum, thro admin control panel, it asked mt for ftp is n pwd and on providing it, it did the upgrade in 2minutes :)
www.xpindia.com ; www.onlinemedicalforum.com/smf 

Be Kind And courteous To People On Your Way Up
For You Might Meet Them On Your Way Down...

wing

Easiest upgrade ever, Thanks

Dexy

dtm.exe do you check your PM  ???

devilkin

I applied the patch.

I had to manually first revert SSI.php back to the 1.0.5 version (making a diff from my version to the 1.0.5), then apply the upgrade to 1.0.6, and then manually re-apply the diff to the file. Everything seems to be working perfectly.

Jan
SMF 1.1.1, located at http://www.aelst.be/smf/

Prasad007

i hav 1.1 rc2
can i shift to this?

Fiery

Mine worked great!

The mods it worked with (for me) are:


Mod Name     Version      
1.    SMF 1.0.6 Update    1.0    [ Uninstall ] [ List Files ] [ Delete ]
2.    Integrated Chat    2.3    [ Uninstall ] [ List Files ] [ Delete ]
3.    Member Specific Permissions    1.31    [ Uninstall ] [ List Files ] [ Delete ]
4.    Visual Warning / Post Moderation    1.21    [ Uninstall ] [ List Files ] [ Delete ]
5.    Gmail Field    1.1    [ Uninstall ] [ List Files ] [ Delete ]
6.    Zodiac Signs    1.0    [ List Files ] [ Delete ]
7.    SMF Arcade    1.2.1    [ Uninstall ] [ List Files ] [ Delete ]
8.    SmileysAlign    1.0.0    [ List Files ] [ Delete ]
9.    Topic Ratings    1.02    [ Uninstall ] [ List Files ] [ Delete ]
11.    Thread's Bookmarks    1.2    [ List Files ] [ Delete ]
12.    Total Login Time, Days to Day    1.0    [ Uninstall ] [ List Files ] [ Delete ]
13.    MySQL 5.0.12 Compatibility Update    1.0    [ List Files ] [ Delete ]
14.    Karma Log    1.0.2    [ Uninstall ] [ List Files ] [ Delete ]
15.    Buddy List    1.21    [ Uninstall ] [ List Files ] [ Delete ]
16.    OnLine Users Today    1.3    [ List Files ] [ Delete ]
17.    Topic Solved    1.21    [ Uninstall ] [ List Files ] [ Delete ]
18.    Group Moderators    1.0b    [ List Files ] [ Delete ]
19.    Message Icon Manager (Quick Reply)    1.2    [ Uninstall ] [ List Files ] [ Delete ]
21.    Lots_o_Smileys    1.0    [ Uninstall ] [ List Files ] [ Delete ]
22.    Report PM to Administrator    0.2    [ Uninstall ] [ List Files ] [ Delete ]
23.    PHP 4.4.0 Compatibility Update    1.0    [ List Files ] [ Delete ]
25.    Message Icon Manager    1.2    [ Uninstall ] [ List Files ] [ Delete ]
26.    G&S_Sticky    1.1    [ List Files ] [ Delete ]

Good luck!

Fiery

Quote from: Prasad007 on January 28, 2006, 01:54:06 PM
i hav 1.1 rc2
can i shift to this?


No, you are not suppose to... see first post

Prasad007

Quote from: pmp6nl on January 28, 2006, 01:55:49 PM
Quote from: Prasad007 on January 28, 2006, 01:54:06 PM
i hav 1.1 rc2
can i shift to this?


No, you are not suppose to... see first post
ya i did
but wat if i wanna "downgrade"? can i ?

Fiery

Quote from: Prasad007 on January 28, 2006, 01:57:21 PM
Quote from: pmp6nl on January 28, 2006, 01:55:49 PM
Quote from: Prasad007 on January 28, 2006, 01:54:06 PM
i hav 1.1 rc2
can i shift to this?


No, you are not suppose to... see first post
ya i did
but wat if i wanna "downgrade"? can i ?


Well... if you want to I suppose you could revert to a backup, other then that I dont know...

Prasad007

Quote from: pmp6nl on January 28, 2006, 02:00:41 PM
Quote from: Prasad007 on January 28, 2006, 01:57:21 PM
Quote from: pmp6nl on January 28, 2006, 01:55:49 PM
Quote from: Prasad007 on January 28, 2006, 01:54:06 PM
i hav 1.1 rc2
can i shift to this?


No, you are not suppose to... see first post
ya i did
but wat if i wanna "downgrade"? can i ?


Well... if you want to I suppose you could revert to a backup, other then that I dont know...
okay
but no forget it :P im very happy with 1.1 rc2 :)

Fiery

Quote from: Prasad007 on January 28, 2006, 02:03:53 PM
Quote from: pmp6nl on January 28, 2006, 02:00:41 PM
Quote from: Prasad007 on January 28, 2006, 01:57:21 PM
Quote from: pmp6nl on January 28, 2006, 01:55:49 PM
Quote from: Prasad007 on January 28, 2006, 01:54:06 PM
i hav 1.1 rc2
can i shift to this?


No, you are not suppose to... see first post
ya i did
but wat if i wanna "downgrade"? can i ?


Well... if you want to I suppose you could revert to a backup, other then that I dont know...
okay
but no forget it :P im very happy with 1.1 rc2 :)

Sounds good!

coolguy949

The update worked perfectly on my Mambo/SMF/Coppermine integration. I didnt need to remove any mods (I already had the googlebot and spiders mod). The only file it had problems changing was changelog.txt. Thanks for the update guys!

http://www.socalevo.net [nofollow]

Prasad007

why cant all updates be done through the package manager like so ?

Dexy

i change this code
$forum_version = 'SMF 1.0.5';

to this
$forum_version = 'SMF 1.0.6';

and now it works! :)

catfished

I upgraded 6 forums in a few minutes and had no problems whatsoever.
You use and like this forum software? Then show your appreciation and support by becoming a Charter Member.



CatfishEd.com

Maddoktor2


Advertisement: