News:

SMF 2.1.3 has been released! Take it for a spin! Read more.

Main Menu

MessagePreviewOnMouseOver

Started by snork13, February 03, 2006, 12:39:52 AM

Previous topic - Next topic

estes

since there are no errors but the mod doesnt seem to work...is there any alternative option (perhaps another mod i can try)?

Kindred

are you using the default theme?   If not, did you install the code changes into your custom theme?
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

estes

Quote from: Kindred on November 05, 2013, 10:19:51 AM
are you using the default theme?   If not, did you install the code changes into your custom theme?

im using a custom theme.  when you say code changes to custom theme....are you referring to the errors that you might receive during an install?  i didnt receive any errors so installed as regular (ie/ no changing the code)

Kindred

but did you actually INSTALL the code changes into your custom theme?
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

estes

Quote from: Kindred on November 05, 2013, 10:35:17 AM
but did you actually INSTALL the code changes into your custom theme?

i believe i did but let me double check by doing a reinstall

estes

Quote from: estes on November 05, 2013, 10:39:43 AM
Quote from: Kindred on November 05, 2013, 10:35:17 AM
but did you actually INSTALL the code changes into your custom theme?

i believe i did but let me double check by doing a reinstall

good catch.  i see it installed in the default theme only  :o    that's what i get for working too many hours.

i'm using the ClearSky theme.  should i just copy over the MessageIndex.php file?

Kindred

no, probably not.

The reason there is  a separate file with that name in your custom theme is because that is a file designed specifically for the custom theme...

So, you should do a manual parse of the mod (link on the mod download page) and manually make the changes to your custom theme file(s)
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Shambles

.. or just uninstall then reinstall the mod, remembering to tick the box(es) for your custom theme during (re)installation.

estes

Quote from: Shambles on November 05, 2013, 12:50:08 PM
.. or just uninstall then reinstall the mod, remembering to tick the box(es) for your custom theme during (re)installation.

worked perfectly...thanks for the help i really appreciate it.

MRM4

I love this mod on my 1.1.x board. But I upgraded with a fresh install to a 2.0.6 board. I finally got the mod to install, but there is no preview of the posts. I did change the setting for the number of characters to display, so that isn't the issue. Any ideas?

Gwenwyfar

#530
Still works great on 2.0.8 with a manual install, thanks for the mod! :)

Also, if anyone was wondering the same, you add the addMessagePreview_settings.php file to your theme folder. (The parser doesn't say where to put it).

Any simple way to add "..." to the ending of the message when it is cut off?
"It is impossible to communicate with one that does not wish to communicate"

Kerrith

Can this be made to work with SMF 2.0.10? I tried installing it using Package Manager and got: "The package you are trying to download or install is either corrupt or not compatible with this version of SMF."

Thanks,

Kerry
Kerrith H. (Kerry) King
Communication Skills Coach
Big Island Forum


lazo50

The mod works fine, but how can I be able to view the images?

Kindred

I do not believe that images are loaded into the preview
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Obsydian

I emulated 2.0 to install this on 2.0.14.   However, I cannot get it to work, even after changing character count.

All it did to my forum is increase the font size on my admin pages (ouch, my eyes) and I'm left with this snippet at the top of the page: "$txt['hover_length'] = 'Length of the message preview on hover'; $txt['hover_characters'] = 'characters';"

If anybody can figure out how to fix this, it'll be forever appreciated.  Everyone wants this feature on my forum!

Kindred

The mod failed to install correctly.
Edit modifications.english.php and move the ?> to the end of the file
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Obsydian

Quote from: Kindred on January 13, 2018, 02:24:10 PM
The mod failed to install correctly.
Edit modifications.english.php and move the ?> to the end of the file

Thank you for your help.

The theme I am currently using as a default doesn't have that file.  Is this something I can/should add?

Kindred

All language files are in the default tgeme
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Obsydian

Looking at the file, it appears that the ?> is already at the end.  Is there something else I need to be checking, or something I'm missing?

Quote$txt['footerads_text'] = '(paste Adsense code)';
$txt['toppostads_enable'] = 'Enable AdSense at the top of a thread';
$txt['toppostads_text'] = '(paste Adsense code)';
$txt['ad_text'] = 'Advertisement</br>';


?>

Advertisement: