Advertisement:

Author Topic: Can't run upgrade.php  (Read 14252 times)

Offline TF_

  • Semi-Newbie
  • *
  • Posts: 87
  • Gender: Male
  • I'm a llama!
Can't run upgrade.php
« on: March 14, 2004, 01:18:28 PM »
I got this error:

Warning: main(/usr/home/sites/mysite/www/smf2/Settings.php): failed to open stream: No such file or directory in /usr/home/sites/mysite/www/smf2/upgrade.php on line 48

Fatal error: main(): Failed opening required '/usr/home/sites/mysite/www/smf2/Settings.php' (include_path='.:/usr/local/share/pear') in /usr/home/sites/mysite/www/smf2/upgrade.php on line 48


And I got no settings.php files in the upgrade zip file. In the upgrade text some have write: "The files you need to change the permissions for are Settings.php and Setting_bak.php. The permissions for these two files should be set to 666" But there is no settings.php and setting_bak.php.

Help me out?

Offline Chris Cromer

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,745
  • Gender: Male
  • I am just a figment of your imagination!
    • Chris's AGI Web Site
Re: Can't run upgrade.php
« Reply #1 on: March 14, 2004, 01:19:58 PM »
You are supposed to run the upgrade over your YaBBSE board not in a different url. The upgrade does NOT come with the Settings.php file because it would overwrite your YaBBSE settings if it did.
Chris Cromer

"I was here, here I was, was I here, sure I was" - The little voice in my head.

Offline TF_

  • Semi-Newbie
  • *
  • Posts: 87
  • Gender: Male
  • I'm a llama!
Re: Can't run upgrade.php
« Reply #2 on: March 14, 2004, 02:23:44 PM »
Ok. I have done that now. All converting is fixed, but the Converting activity logs is unsuccessful.

what do I do? Upgrading YaBB se 1.4.1 to SMF.

Help me out?

Offline warrior

  • Jr. Member
  • **
  • Posts: 226
  • Gender: Male
  • [-vip-warrior :)-]
    • [-vip-]
Re: Can't run upgrade.php
« Reply #3 on: March 14, 2004, 02:26:27 PM »
Ok. I have done that now. All converting is fixed, but the Converting activity logs is unsuccessful.

what do I do? Upgrading YaBB se 1.4.1 to SMF.

Help me out?

upgrade your yabb 1.4.1 to 1.5.5 and try it again to smf... dont think you can upgrade from yabb 1.4.1 without any problems direct to smf.

Offline TF_

  • Semi-Newbie
  • *
  • Posts: 87
  • Gender: Male
  • I'm a llama!
Re: Can't run upgrade.php
« Reply #4 on: March 14, 2004, 03:15:29 PM »
I try to upgrade YaBB se 1.4.1 to 1.5.5 but it stopped. Out ot memory error. Allowed memory size of 8388608 bytes exhausted (tried to allocate 35 bytes) Strange... Because i have a dedicated server. Help ?

"date or month" and "members" table which 1.5.5 upgrade use (?) is not in my YaBB SE 1.4.1 MySQL database.

My forum is very big. 100 000 posts and 3000 members. Seems to I must use YaBB Se 1.4.1 for ever.....  :(
« Last Edit: March 14, 2004, 03:58:34 PM by TF_ »

Offline Ben_S

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,727
  • xxx
Re: Can't run upgrade.php
« Reply #5 on: March 14, 2004, 03:56:32 PM »
Try increasing the memory limit from 8mb to 16 in php.ini
Liverpool FC Forum with 14 million+ posts.