No puedo crear parámetros en el td de las tablas

Started by Kusanagui, March 05, 2006, 02:34:33 PM

Previous topic - Next topic

Kusanagui

Estoy tratando de darle algo más de funcionalidad a las tablas a travéz de parámetros pero no me ha ido nada bien, la erdad que no entiendo bien como funciona el código que estoy modificando así que más o menos copie algo que vi en otros tags

Abrí Subs.php y debajo de

	
	
	
array(
	
	
	
	
'tag' => 'td',
	
	
	
	
'before' => '<td valign="top" style="font: inherit; color: inherit;">',
	
	
	
	
'after' => '</td>',
	
	
	
	
'require_parents' => array('tr'),
	
	
	
	
'trim' => 'outside',
	
	
	
	
'block_level' => true,
	
	
	
	
'disabled_before' => '',
	
	
	
	
'disabled_after' => '',
	
	
	
),


coloqué

	
	
	
array(
	
	
	
	
'tag' => 'td',
	
	
	
	
'type' => 'unparsed_commas',
	
	
	
	
'parameters' => array(
	
	
	
	
	
'bgcolor' => array('optional' => true),
	
	
	
	
	
'valign' => array('optional' => true),
	
	
	
	
	
'align' => array('optional' => true),
	
	
	
	
),
	
	
	
	
'before' => '<td bgcolor={bgcolor} valign={valign} align={align} style="font: inherit;">',
	
	
	
	
'after' => '</td>',
	
	
	
	
'require_parents' => array('tr'),
	
	
	
	
'trim' => 'outside',
	
	
	
	
'block_level' => true,
	
	
	
	
'disabled_before' => '',
	
	
	
	
'disabled_after' => '',
	

),


Hasta ahora no he logrado que funcione y estoy medio perdido con los parámetros que deben pasarse en cada caso. Agradecería cualquier ayuda que me puedan dar. La intensión es poder pasar como parámetros opcionales bgcolor, valign y align. Gracias
¿A quién se le ocurre?
mount /dev/girl -t auto /mnt/me (afanado a Pretorius)

Advertisement: