Advertisement:

Author Topic: not sure what to do  (Read 7544 times)

Offline oscar2001

  • Jr. Member
  • **
  • Posts: 201
  • Gender: Male
not sure what to do
« on: March 21, 2004, 05:54:53 AM »
Forum was working ok for 24 hours or so then suddenly this started happening
Code: [Select]
$db_last_error = 1079845480; ?>
Notice: Undefined variable: sourcedir in /home/worldcic/public_html/yabbse/index.php on line 35

Warning: main(/QueryString.php): failed to open stream: No such file or directory in /home/worldcic/public_html/yabbse/index.php on line 35

Warning: main(): Failed opening '/QueryString.php' for inclusion (include_path='') in /home/worldcic/public_html/yabbse/index.php on line 35

Notice: Undefined variable: sourcedir in /home/worldcic/public_html/yabbse/index.php on line 36

Warning: main(/Subs.php): failed to open stream: No such file or directory in /home/worldcic/public_html/yabbse/index.php on line 36

Warning: main(): Failed opening '/Subs.php' for inclusion (include_path='') in /home/worldcic/public_html/yabbse/index.php on line 36

Notice: Undefined variable: sourcedir in /home/worldcic/public_html/yabbse/index.php on line 37

Warning: main(/Errors.php): failed to open stream: No such file or directory in /home/worldcic/public_html/yabbse/index.php on line 37

Warning: main(): Failed opening '/Errors.php' for inclusion (include_path='') in /home/worldcic/public_html/yabbse/index.php on line 37

Notice: Undefined variable: sourcedir in /home/worldcic/public_html/yabbse/index.php on line 38

Warning: main(/Load.php): failed to open stream: No such file or directory in /home/worldcic/public_html/yabbse/index.php on line 38

Warning: main(): Failed opening '/Load.php' for inclusion (include_path='') in /home/worldcic/public_html/yabbse/index.php on line 38

Notice: Undefined variable: sourcedir in /home/worldcic/public_html/yabbse/index.php on line 39

Warning: main(/Security.php): failed to open stream: No such file or directory in /home/worldcic/public_html/yabbse/index.php on line 39

Warning: main(): Failed opening '/Security.php' for inclusion (include_path='') in /home/worldcic/public_html/yabbse/index.php on line 39

Notice: Undefined variable: maintenance in /home/worldcic/public_html/yabbse/index.php on line 41

Fatal error: Call to undefined function: db_fatal_error() in /home/worldcic/public_html/yabbse/index.php on line 49
I have been having a few database issues but my host reckons theres been nothing wrong with it. However a friend who uses the same host says his forum crashed in the same way with phpBB so it has me wondering.
If anyone has a idea on how to fix this it would be a great help
heres the url
www.worldcichlids.com/yabbse

Offline oscar2001

  • Jr. Member
  • **
  • Posts: 201
  • Gender: Male
Re: not sure what to do
« Reply #1 on: March 21, 2004, 07:39:35 AM »
ok I seem to have found the cause but still mystified how it happened
The settings.php file was empty except for the last DB error number
It was chmodded to 666 etc with the original upgrade etc
I uploaded the original setting.php file and re-ran the upgrade and it seems to be back.

Any ideas on how this would happen?
Thanks for any help

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: not sure what to do
« Reply #2 on: March 21, 2004, 05:08:56 PM »
A few people have had this problem, but I've been unable to find a cause, and it works for me..

For now, please try turning off automatic error fixing in the settings.

-[Unknown]

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: not sure what to do
« Reply #3 on: March 21, 2004, 05:12:57 PM »
Also, make a backup of the file to Settings_bak.php.... that should help.

Are you willing to let me try to debug this issue?  I tried before and thought I had it fixed.

-[Unknown]

Offline oscar2001

  • Jr. Member
  • **
  • Posts: 201
  • Gender: Male
Re: not sure what to do
« Reply #4 on: March 21, 2004, 11:56:19 PM »
I might be blind lol but do you mean "Automatically fix broken tables"?
Sure I dont mind if you got the time. Just let me know what info you may need to do so.

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: not sure what to do
« Reply #5 on: March 22, 2004, 12:01:53 AM »
Admin -> Edit Features and Options -> uncheck "Automatically fix broken tables" in "Basic Features".

I'd need FTP access and some install you don't mind having problems for about 30 minutes - the plan is, I want to *replicate* this problem (which doesn't happen on my server or here, mind you!) and fix it.  I just can't fix it if I can't figure out what is causing it.... it's okay if you'd rather not, but if you're willing please do send me ftp information over personal message.

-[Unknown]

Offline oscar2001

  • Jr. Member
  • **
  • Posts: 201
  • Gender: Male
Re: not sure what to do
« Reply #6 on: March 22, 2004, 12:59:49 AM »
Thanks :)
Just sent you the ftp info

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: not sure what to do
« Reply #7 on: March 22, 2004, 07:53:35 PM »
Of course it won't happen anymore, no... I couldn't be so lucky.

-[Unknown]

Offline oscar2001

  • Jr. Member
  • **
  • Posts: 201
  • Gender: Male
Re: not sure what to do
« Reply #8 on: March 22, 2004, 10:54:33 PM »
lol yeah typical murphys law.
I will let you know if it happens again anytime soon :)
Thanks :)