• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 06:29:23 PM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Lord of the Rings

Started by TechnoDragon, April 12, 2006, 02:13:06 PM

Previous topic - Next topic

TechnoDragon

Link to the theme


My all-time favorite book series became my all-time favorite movies series!  Now i bring to you a theme based on that very thing.
Don't tell me to get into shape...I have a shape...It is round!


B Patterson

Could use a demo.... or larger screens

Horme Gaming

I wouldnt say its a theme just a variation of amber :)

TechnoDragon

April 17, 2006, 12:39:36 PM #3 Last Edit: April 17, 2006, 12:45:27 PM by technodragon73
You are correct that it is an Amber Variation...I liked the way that theme lends itself to retooling better than any others...and Bloc has been very supportive of my theme conversions.

http://forum.technodragon.net/index.php?theme=36
Don't tell me to get into shape...I have a shape...It is round!


Prasad007

ooh wow thanks!
was just gonna make a LOTR forum...
made this just in time ;)
thanks! :)

G3mInI

I went and installed this theme on my boards. When I went to view it, no graphics!

After a little inspection of the theme package, I found the .zip archive had a folder inside called Lord of the Rings. Inside that folder was the the files and folders needed for the theme. In other words the theme was zipped into a folder which contains a subfolder of all the necessary info.

Was an easy fix for me as I extracted the the theme to my hard drive, then went inside the Lord of the Rings folder it created, then selected all files and folders there and zipped it up. Deleted previous install, and reinstalled with my new .zip archive and it worked like a charm.

Just thought I would post this if anyone else ran into this issue.

Boards version - 1.1RC2

G3mInI

TechnoDragon

Thank you...I fixed that and put the correct file in the themes area.
Don't tell me to get into shape...I have a shape...It is round!


TechnoDragon

I have updated this theme to work for SMF RC3!  You can check out a demo at

http://golddragonhosting.com/smf/index.php?theme=11

and the new place to get the TP version is http://dragontalk.net
Don't tell me to get into shape...I have a shape...It is round!


scoooooty


TechnoDragon

Fixed it...apparently my home directory path was change without being notified first...silly little thing...

thanks for letting me know!
Don't tell me to get into shape...I have a shape...It is round!


B Patterson


TechnoDragon

Seems to work fine for me!
Don't tell me to get into shape...I have a shape...It is round!


B Patterson

Ah, so it does.  The issue was following the link above.  For whatever reason a PHPSESSID was added to the URL, and that threw everything off.  Once I removed it, it worked fine.

Comments on Theme:
It looks good at first glance, but I see a few minor flaws.  This seems to have been created for a fixed width; however, my browser was wider than your fixed width and the forum is fluid (meaning the width changes).  So the items with class "catbg" looked off.

Here's a screeny: Click here (ImageShack)

Same thing with the left sidebar with the login and search functions.  They seem to be cut off too.

What seems to be the problem is that in IE, everything on the left shows fine & dandy.  The catbg classes are still off, but that's an image / coding issue.  But if you use IE (I'm using IE7) there's a break between the bottom of the forum and the rounded footer.

My advice, take it as you will, would be to code to Firefox first, then start hacking away for IE.  Firefox 2, and FF 3 (Minefield) even more, adheres to the w3c standards for CSS and displaying.  If you're on a mac, Safari adheres to them too; and for Linux Konqurer does too.  So code to a browser that does standards right (FF2/3, Safari, Konqurer) and then include a secondary IE stylesheet that fixes the IE crap.

Other than that, the theme looks good.  Very good selection of colors.

TechnoDragon

Why thank you...actually the catbg it that long because i used original files to come up with the widths, unfortunately it was also one of the very first themes that I had come up with and have since gotten MUCH better at graphics AND coding.  You can see the latest theme I had created at my personal forum...

http://dragontalk.net

I do appreciate the critique though, and when things slow down on my curent project, i will take a look at all of my themes to see what kind of updates I can make to clean them up...

As for the IE issue...OH BOY do i know how much of a pain it is to make something work in IE AND everything else!  LOL
Don't tell me to get into shape...I have a shape...It is round!


pvthudson01

Any way to get rid of all the info on the left side?

i dont want the news and member info on the side, rather up top

B Patterson

Temporarily you can just "close" the left side-bar and that will remove it; however, in order to permanently move it to above the rest of the forum, you'd need to do some major theme modification.  Honestly, you'd be better off using a different theme.

TechnoDragon

I was just going to say that...yes, the theme has been coded to add that left bar...sorry.
Don't tell me to get into shape...I have a shape...It is round!


B Patterson

Woops... sorry.  I guess I kinda hijacked your thread ;)

Advertisement: