• Welcome to Simple Machines Community Forum. Please login or sign up.

Bridge 1.1.4

Started by Orstio, April 23, 2006, 07:59:20 AM

Previous topic - Next topic

Anthony Araullo

Thanks for the tip. I need your help once again. Is it possible to for smf and joomla just using only a single user? If so, tell how?

Orstio

QuoteIs it possible to for smf and joomla just using only a single user?

Can you explain what you mean by that?

Anthony Araullo

There are users on both smf and the joomla. Since there is the bridge connect them both together and I was hoping to use a single user when I enter the smf from the joomla.

Anthony Araullo

Let me try this again.

When I register as a user in joomla, the same user should be registered in smf automatically as well and vice versa.

Is my explaination is clear? 

Orstio

QuoteWhen I register as a user in joomla, the same user should be registered in smf automatically as well and vice versa.

Essentially, yes.  If you use the Joomla default registration, however, the user will not appear in SMF until the first time they login.

Moonray

Quote from: Anthony Araullo on June 22, 2006, 04:06:02 AM
Let me try this again.

When I register as a user in joomla, the same user should be registered in smf automatically as well and vice versa.

Is my explaination is clear? 

That I believe the whole purpose of the Joomla-SMF Bridge!

Of course there are other advantages like visual integration (if wrapped) and the ability to use Joomla modules in SMF pages and vice versa.

shashikiranu

Moonray

Quote from: imforumman on June 18, 2006, 04:00:17 AM
Quote from: Orstio on April 23, 2006, 07:59:20 AM
Group Synch option

Be very careful with the Group Synch button.  If you do not have your Group Synch options saved correctly, you can erase admin status from all Joomla administration.  Do not click the Group Synch button without first making absolutely sure your settings in the Group Synch tab are correct, and you will have at least one Super Admin after synching.

Yes, this is exactly what happend to me. I will pass this installation on to a customer once it's done. What if he ever decides to hit that button? Messing with "...acl_groups_aro_map" is IMHO a very bad idea. Is this absolutly necessary? At least please have a quadrouple warning before doing the synching. It took me forever to find out what the problem was and how to fix it (manual restoration of the codes for the groups and so on, I'm still not confident I got it all right, so I will have to copy some db-contents from a second installation to make sure. Very much disappointed.


Tell your customer NOt use that. If he still hits the button, ask him to contact you. Charge him for the service :)
Anyway, if you can ensure that all users with Admin/Super Admin status in SMF/ Joomla respectively, have the same username and password in both Joomla and SMF, including capitalization, there should be no problems...

And, if you get into trouble, you always have the tutorial to reinstate the administrator. :)



shashikiranu

ahewgill

I installed bridge 1.1.4 into Mambo 4.5.4 (SMF 1.1 RC2) everything is default.

When viewing the mambo main page I was getting this error embedded in the page:

Notice:  Undefined index:  USER_AGENT in <location>Sources/Load.php on line 278

It's mambo and I had added the template code as per the directions but was still getting this.
Lo and behold the error was that I put the code into wrong template so it wasn't active.

Just an FYI for others who might get this error.
;D

Gattsu

i have joomla 1.0.10 and smf 1.1.4
so where is download for bridge between this two ??
ehh srry, but i am new in this
can someone post link
alot thanx

Kindred

1- there is no smf version 1.1.4. the most recent version of SMF is 1.1RC2

2- 1.1.4 is the version of the bridge that is attached to the first message in this thread. This is not SMF...   1.1.4 is the bridge. You must download and install joomla and SMF as standalone installations before installing the bridge
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Phil-Brown

Have the same problem reported by some others - After installing 1.14 with Joomla 1.09 my front page layout is now messed up - seems the window for the SMF section is set too wide and now displays below the window space.

Can you tell me what the install does to the teamplates - and what is the simple fix.

Thanks



Orstio

Use a better template.

Phil-Brown

Thanks for the response

I'm just using the default Joomla template which worked before install - and now doesnt - absolutely no content yet because I wan't to get this working first. 

Can you suggest one or two templates that work? Your help would be appreciated



Phil-Brown

Thanks a million - problem fixed  :)

aurax

Hello, i got a serious problem with the new brige, problem is i can't figure out where it starts.
can someone have a look @ hxxp:www.audioforce.net [nonactive]

thanks.


tonzar

About Gallery2:
I've lost the authentication using orstio smf bridge 1.1.4. Logging with joomla module is OK, but so I can't enter the forum. I've tried to modyfy line:
if (!defined('SMF') && $_REQUEST['option'] != 'com_smf' && $_REQUEST['option'] != 'com_gallery2'){
in SMF_header_include.php but I've not resolved my problem.
I'm not using SEF now!
Some suggestion?

Thanks in advance

Kindred

please try bridge 1.1.5.

This topic is now locked...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: